Archiv Windows XP 25.916 Themen, 128.567 Beiträge

Svchost.exe lähmt CPU - zu starke Auslastung

fragenüberfragen / 9 Antworten / Baumansicht Nickles

Hallo!

OS: Windows XP 32-bit mit SP3

Schon kurz nach dem Hochfahren lastet die svchost.exe das System zu ca. 90 % aus. Einzige Möglichkeit, den Laptop überhaupt noch nutzen zu können, ist, die automatischen Updates abzustellen. Das kann ja aber keine Dauerlösung sein.


Die Suche nach Updates über den Internet-Explorer hat den gleichen Effekt wie aktivierte automatische Updates: CPU ca. 90 % Auslastung, System reagiert nur noch sehr zögerlich und läuft heiß.


Winfuture-Update-Packs vom Oktober sind aufgespielt - hat nix gebracht.

Malwarebytes findet keine Schädlinge, Hijackthis findet auch nichts Verdächtiges.

Alle Tips für Programme und Downloads, die ich im Internet finden kann (z.B. Windows Update Agent, WindowsXP-KB123456) sind zu alt, da kommt jeweils die Meldung, es sei schon etwas Neueres drauf.


Gibt es eine aktuelle Lösung für das Problem?


Danke schonmal für Euere Hilfe, Manuel

winnigorny1 fragenüberfragen

„Svchost.exe lähmt CPU - zu starke Auslastung“

Optionen

Ich habe dir mal ein Posting aus dem Winfuture-Forum hier reinkopiert; also kein Plagiat, einfach nur, damit du in den Postings nicht lange suchen musst - vielleicht hilft es dir ja auch:

Es könnte sein, dass der Windows Update Dienst spinnt -> Workaround:

Win+R drücken und services.msc aufrufen.

Dienst Automatische Updates beenden.

Im Ordner C:\WINDOWS\SoftwareDistribution folgende Ordnerinhalte leeren (nicht die Ordner löschen!!!): DataStore, Download, EventCache

Dienst Automatische Updates wider starten.

Windows Updates Durchfühen!

fragenüberfragen winnigorny1

„Ich habe dir mal ein Posting aus dem Winfuture-Forum hier reinkopiert also kein...“

Optionen

Hallo winnigorny1!


Danke - aber schade: Das habe ich schon 2x versucht, aber sowie ich danach die Updates entweder aktiviere oder suchen lasse, besteht wieder das gleiche Problem.

Die wuauclt.exe und die svchost.exe liefern sich erst ein Rennen in puncto Cpu-Auslastung, schließlich siegt die svchost.exe ;-)


Grüße von Manuel

fragenüberfragen

Nachtrag zu: „Hallo winnigorny1! Danke - aber schade: Das habe ich schon 2x versucht, aber...“

Optionen

Boah, inzwischen habe ich über den Prozess Explorer rausbekommen, daß die wuauclt.exe die svchost.exe so hochtreibt. Zwar ist es svchost.exe, die dann das System dauerhaft auslastet, aber wenn die wuauclt.exe nicht startet, bleibt die svchost.exe ruhig.

Den Ordner System32 habe ich mit Avast überprüft - negativ.


Vielleicht kann mir ja doch noch ein Spezialist helfen?????


Gute Nacht wünscht Euch Manuel

winnigorny1 fragenüberfragen

„Boah, inzwischen habe ich über den Prozess Explorer rausbekommen, daß die...“

Optionen

Du kannst auch noch einmal Folgendes versuchen:

1. Dienst "Automatische Updates" beenden und auf "deaktiviert" stellen
2. das Verzeichnis "SoftwareDistribution" in "C:\Windows\" bzw. in "C:\WINNT\" bei W2000 umbenennen (z.B. SD_old)
3. Reboot
4. prüfen ob sich durch den nicht laufenden Dienst alles normalisiert hat
4. Dienst wieder starten (das Verzeichnis wird jetzt neu aufgebaut)
5. wenn dadurch der Fehler behoben ist den Dienst wieder auf "automatisch"

Ist auch nicht auf meinem Mist gewachsen, sondern war ein Tipp aus dem Forum administrator.de.

Dort hat es einem Fragesteller, der dein Problem beschrieb, jedenfalls geholfen. - Ich drücke dir die Daumen!

fragenüberfragen winnigorny1

„Du kannst auch noch einmal Folgendes versuchen: 1. Dienst Automatische Updates...“

Optionen

Hallo winnigorny1!

Das werde ich auf jeden Fall versuchen. Aber erst müßte ich definitiv wissen, ob durch das Umbenennen des Ordners "SoftwareDistribution" irgendwas mit Outlook Express passiert, denn da sind jede Menge Mails drin und die dürfen nicht verschwinden.

Sicherheitshalber werde ich jetzt erstmal versuchen, den Dienst "Automatische Updates" dauerhaft zu deaktivieren (stellt sich beim Einschalten des Laptops immer wieder auf "automatisch") und mich dann um die Outlook Express-Mails kümmern.

Vielen Dank für Deinen Tip, ich werde es demnächst testen.

Gruß von Manuel

winnigorny1 fragenüberfragen

„Hallo winnigorny1! Das werde ich auf jeden Fall versuchen. Aber erst müßte ich...“

Optionen

Durch das Umbenennen des Ordners ist ja nichts weg, Windows findet den Ordner halt nur nicht.

Die Daten gehen also nicht verloren. Wenn der Ordner neu angelegt ist, sollte es also kein Problem sein, die OutlookExpress-Dateien von dem umbenannten Ordner (aus dem passenden Unterordner) in den neuen passenden Unterordner zu kopieren.

Wenn dann alles funzt, kannst du den umbenannten Ordner löschen.

Das wäre vielleicht auch mal ne Überlegung wert, sich einen vernünftigen E-Mail-Client wie den Thunderbird zu installieren. - Der ist zudem auch sicherer und komfortabler....

fragenüberfragen winnigorny1

„Durch das Umbenennen des Ordners ist ja nichts weg, Windows findet den Ordner...“

Optionen

>>Die Daten gehen also nicht verloren. Wenn der Ordner neu angelegt ist, sollte es also kein Problem sein, die OutlookExpress-Dateien von dem umbenannten Ordner (aus dem passenden Unterordner) in den neuen passenden Unterordner zu kopieren.>>

Mmmhhhh, woher weiß ich, welches der passende Unterordner mit den Outlook-Dateien ist? Es gibt folgende Unterordner: "AuthCabs" - "DataStore" - "Download" (der ist leer) - "EventCache" (auch leer) - "SelfUpdate" - WebSetup" - "WuRedir".

In den Unterordnern sind Dateien mit Endung
.xml .cab .cat .txt .inf .ebd .log .chk

Deutet da irgendwas auf Outlook-Express-Dateien hin?



Könnte der Ordner "Self Update" die entscheidende Datei enthalten, die das Problem mit der svchost.exe verursacht? Es gibt hier die Unterordner:

"Default" (Inhalt: wsus3setup.cab - wsus3setup.cat - wsus3setup.inf - wuident.cab - wuident.txt) und

"Registered" (Inhalt: muident.cab - muident.txt - musetup.cab - musetup.cat - musetup.inf).



>>Das wäre vielleicht auch mal ne Überlegung wert, sich einen vernünftigen E-Mail-Client wie den Thunderbird zu installieren. - Der ist zudem auch sicherer und komfortabler....>>

Es ist nicht mein Laptop. Ich habe auch schon vor Outlook Express gewarnt - aber es ist halt so praktisch und bequem, die Windows-Programme zu nutzen. Werde es jetzt nochmals anregen, ein anderes Programm zu benutzen - sehe aber wenig Erfolgsaussichten.


Ich habe nun schon mit einem Firefox-Update die eingetragenen Internetadressen und alle Lesezeichen gehimmelt, da möchte ich mit Outlook-Express nicht nochmals so einen Fauxpas begehen, deshalb meine Übervorsicht wegen dem Ordner "Software-Distrubution" - ich bitte um Nachsicht.


Vielen Dank für Deine geduldige Hilfe, vielleicht schaffen wir es ja noch??? Manuel

winnigorny1 fragenüberfragen

„ Die Daten gehen also nicht verloren. Wenn der Ordner neu angelegt ist, sollte...“

Optionen

Guck mal hier:

http://windows.microsoft.com/de-DE/windows-vista/Import-messages-into-Windows-Mail-from-Outlook-Express

Die Mails sind also gar nicht in software distribution abgelegt!

Du kannst das also gefahrlos für die Mails erledigen. - Alles andere in dem Ordner schreibt Windows automatisch neu. - Den umbenannten Ordner behälst du erst mal nur zur Sicherheit.

Wenn alles funzt, löscht du den.

fragenüberfragen winnigorny1

„Guck mal hier:...“

Optionen

Den Sekt habe ich nach 8 Minuten wieder weggepackt......


"SoftwareDistribution" umbenannt in "SoftwareDistribution OLD" und o.g. Prozedur eingehalten. Nach einem Neustart und wieder aktivierten Updates sah es zuerst sehr gut aus, wuauclt.exe und snchost.exe und avast.exe (oder so) hielten abwechselnd den oberen Platz der CPU-Auslastung ein, die Prozessorbelastung war aber trotzdem nicht immer ganz oben, es war so, wie es sein sollte.

Doch nach 8 Minuten hatte die svchost.exe wieder ihren Platz mit 94 bis 99% Auslastung errungen. Ich habe es dann testweise 'mal 10 Minuten so laufen lassen, aber da tat sich nichts, außer daß das Laptop immer heißer wurde. Den Dienst "Automatische Updates" konnte ich nicht mehr beenden, es half nur ein Neustart.

Seltsamerweise hatte sich kein neuer Ordner "SoftwareDistribution" hergestellt, vielleicht wird ja immer noch der umbenannte genutzt? Aber die 8 Minuten lang war es anders als vorher.


Ich gebe jetzt auf, sitze seit 3 Tagen am gleichen Problem. Ich melde mich dann die Tage wieder.


Merci bien und Tschüs, Manuel