Archiv Windows 95, Registry 3.154 Themen, 8.811 Beiträge

Problem bei der Neuinstallation von Win95

lars_kabel / 9 Antworten / Baumansicht Nickles

Ich habe einen Pentium 133-Rechner (Win 95). Auf der 1. Festplatte sind drei Partitionen (C:, D:, E:). Zusätzlich ist noch eine zweite, alte Festplatte (F:) drin, die nicht mehr ganz einwandfrei ist, die ich nicht mehr benutzt habe, die aber bisher auch nie gestört hat.
Als ich Software für einen Internetzugang (surfEU) installieren wollte, stürzte der Rechner ab. Bei ersten Hochfahren startete ScanDisk und erklärte, Laufwerk F: sei fehlerhaft und könne nicht gescannt werden. Der Rechner startete Windows 95 nur noch im abgesicherten Modus, stürzte aber auch dort immer ab, sobald ein Programm geöffnet wurde.
Ich habe daraufhin C: neu formatiert und dann von der Setup-Boot-Diskette für CD-ROM neu gestartet. Alles lief normal. Dann erschien ein Bildschirm mit blauem Hintergrund ("Microsoft Windows 95-Startmenü"), auf dem man mit der Eingabetaste das passende CD-ROM Gerät auswählen konnte. Dann erschien "Mode \'Codepage vorbereiten\' ausgeführt" und Mode \'Codepage auswählen\' ausgeführt" [...]
"Driver Z: = Driver OEMCD001 unit 0". Gleich darauf erschien folgender Bildschirm: "Microsoft Windows 95-Setup [...] Drücken Sie die Eingabetaste, um Windows zu installieren." Die Win 95-CD-ROM hatte ich vorher eingelegt. Ich habe dann mit der Eingabetaste bestätigt, worauf folgender Text erschien: "Die Windows-Installation wird vorbereitet", "Die Installation wird vorbereitet", "Der Computer wird jetzt einer Routineprüfung unterzogen", "Weiter mit der Eingabetaste. Abbrechen mit Esc".
Ich habe die Eingabetaste gedrückt. Daraufhin machte der PC ein Geräusch als ob er hochfahren würde, dann brach das Geräusch wieder ab, fing wieder an, usw. Sonst passierte nichts. Jeder neue Versuch lief genauso ab. Wie installiere ich Win 95? Kann mir jemand helfen?

Moldmaker (Anonym: 217.2.145.166) lars_kabel

„Problem bei der Neuinstallation von Win95“

Optionen

Hallo Lars,

Es sieht so aus, als ob das CD-ROM-Laufwerk nicht richtig angesprochen wird, wenn du von der Startdiskette startest. Die
einfachste Lösung ist, es mit einer Win98-Startdiskette zu versuchen; da sind Standardtreiber drauf. Einfach von einer solchen
Startdiskette starten. Zusätzlich zu den vorhandenen Laufwerken wird ein weiteres virtuelles Laufwerk angelegt, das dann bei dir F:
heißen wird; also mußt du nach dem Hochfahren mit G: in das CD-ROM-Laufwerk wechseln. Vorher natürlich die Win95-CD einlegen! Dann
setup einhacken und Windows95 installieren. Daß es sich um eine Win98-Startdiskette handelt, spielt keine Rolle.
Wenn du keine Win98-Startdiskette zur Verfügung hast oder an keine herankommen kannst, mußt du die vorhandene
Win95-Startdiskette anpassen. Zusätzlich zu den Dateien, die sich auf der Standard-Startdiskette befinden, muß die Datei
mscdex.exe und der richtige Treiber für das CD-ROM-Laufwerk (!) daraufkopiert werden. Beispiel: Meine Startdiskette enthält
folgende Dateien:

Attrib.exe
Autoexec.bat
Chkdsk.exe
Command.com
Config.sys
Country.sys
Cr_atapi.sys
Debug.exe
Display.sys
Drvspace.bin
Ebd.sys
Edit.com
Ega.cpi
Fdisk.exe
Format.com
Himem.sys
Io.sys
Keyb.com
Keyboard.sys
Mode.com
Mscdex.exe
Msdos.sys
Regedit.exe
Scandisk.exe
Scandisk.ini
Sys.com
Uninstal.exe

Dann mußt du noch Anpassungen in der autoexec.bat und in der config.sys vornehmen.
Beispiel: Die komplette autoexec.bat der Startdikette sieht bei mir wie folgt aus:

mode con cp prepare=((850) ega.cpi)
mode con cp select=850
keyb gr,,keyboard.sys
A:MSCDEX.EXE /D:MSCD000 /M:15 /V

Der Treiber für mein CD-ROM-Laufwer heißt cr_atapi.sys. Das ist wichtig für die config.sys. Die komplette config.sys meiner
Startdikette sieht so aus:

device=display.sys con=(ega,,1)
country=049,850,country.sys
DEVICE=HIMEM.SYS
DEVICE=A:CR_ATAPI.SYS /D:MSCD000 /Q

Ich habe zwei Partitionen, also C: und D: und das CD-ROM-Laufwerk ist demnach E: und läßt sich nach dem Starten von dieser
Diskette auch mit E: ansprechen. Du solltest vor einem neuerlichen Installationsversuch aber nochmal C: formatieren; möglicherweise liegen da jetzt schon einige Dateileichen drauf, die hinterher stören könnten.
Versuch's mal. Ich hoffe, ich konnte dir helfen.
Viel Erfolg.

Gruß

Moldmaker

Moldmaker (Anonym: 217.2.132.171) lars_kabel

„Problem bei der Neuinstallation von Win95“

Optionen

Hallo Lars,

Sollten meine Hinweise zu der Startdiskette dein Problem nicht lösen, solltest du einfach mal die fehlerhafte Platte ausbauen bzw. abklemmen und es dann erneut versuchen.

Viel Erfolg

Gruß

Moldmaker

(Anonym) Moldmaker (Anonym: 217.2.132.171)

„Hallo Lars, Sollten meine Hinweise zu der Startdiskette dein Problem nicht...“

Optionen

Hallo Moldmaker,
danke für die Tipps. Sind für meine Freundin, die mir ihre Anfragen faxt, da sie ja nicht mehr ins Internet kommt ;-). Win 98-Startdiskette hatte sie noch nicht zur Hand. Muss man beim Ausbau der Festplatte was beachten. Es laufen dann einige Stecker ins Leere, muss das so sein?
Danke nochmal
Lars

Moldmaker (Anonym: 217.2.132.238) (Anonym)

„Hallo Moldmaker, danke für die Tipps. Sind für meine Freundin, die mir ihre...“

Optionen

Hallo Lars,

Noch'n Nachtrag zu meinem Roman von vorhin bezüglich der Kabelage: Die "eigentliche" Festplatte sollte natürlich nach wie vor mit
einem Flachkabel mit dem Mainboard verbunden sein. Sitzen die Stecker fest? Sie rutschen gerne mal ein bißchen raus, ohne
daß man es erkennen kann. Auf dem Board sollte die Platte dann auch mit dem "Primary IDE connector" verbunden sein
(Handbuch!) Das Flachkabel der anderen Platte, wo war das angesteckt? An dem Kabel der ersten Platte? (da sind auch
Steckerleisten integriert). Die können freibleiben; am besten entfernst du das Flachkabel der deaktivierten Platte ganz (also von der
Platte und vom Board bzw. der Steckerleiste des anderen Flachkabels abziehen). Du kannst die Platte ja drinlassen. Das CD-ROM-Laufwerk muß natürlich auch ordentlich verbunden
sein (Stecker alle fest?) Wenn das ganze hier noch per Fax hin- und herübermittelt wird, ist das ja wie ne Operation der Telefon...
Good Luck, Captain.

Gruß

Moldmaker

Moldmaker (Anonym: 217.2.150.193) (Anonym)

„Hallo Moldmaker, danke für die Tipps. Sind für meine Freundin, die mir ihre...“

Optionen

Hi Lars,

Sorry, mir fallen die Sachen leider nur nach und nach ein...
Hast du bzw. hat deine Freundin auch die richtige (also die defekte) Festplatte abgeklemmt? Sonst wäre es kein Wunder, wenn keine Platte gefunden wird... Nur so eine Idee.

Gruß

Moldmaker

(Anonym) Moldmaker (Anonym: 217.2.132.171)

„Hallo Lars, Sollten meine Hinweise zu der Startdiskette dein Problem nicht...“

Optionen

Die störende Festplatte wurde ausgebaut. Nun findet er nichts mehr außer dem a: drive. Was nun? Lars

Moldmaker (Anonym: 217.2.131.54) (Anonym)

„Die störende Festplatte wurde ausgebaut. Nun findet er nichts mehr außer dem...“

Optionen

Hallo Lars,

Das läuft ja nicht ganz wunschgemäß. Die jetzt noch installierte Festplatte sollte als "Primary Master" gejumpert werden. Die entsprechenden Einstellungen, die an der Platte selbst vorzunehmen sind, kannst du entweder dem Handbuch der Festplatte entnehmen (ich hoffe, das hast du noch...) oder du mußt die Platte inspizieren und den entsprechenden Jumper (der hoffentlich beschriftet ist...) richtig setzen. Und dann muß im BIOS noch die automatische Erkennung für die Primary Master Festplatte eingeschaltet werden. Das ist je nach BIOS verschieden; wenn du von der Startdiskette hochfährst, mußt du "Entf" oder eine andere Taste drücken, um ins BIOS zu gelangen (Meldung am unteren Bildschirmrand beachten), und dann mußt du dich zu der Option "IDE HDD Auto Detection" (oder so ähnlich) durchhangeln und den Auto-Modus einstellen. Wie die Optionen im einzelnen heißen, steht im Mainboard-Handbuch (das du hpffentlich noch hast...).
Und dann wird nach dem Hochfahren hoffentlich auch die Platte erkannt. Obwohl ich mich etwas wundere, weil von der jetzt noch montierten Platte auch vorher gebootet wurde, oder? Eventuell waren im BIOS feste Werte für die montierten Platten eingegeben; du solltest dann nur die löschen, die sich auf die alte (jetzt ausgebaute Platte) beziehen.
Normalerweise sollte sich auf der Platte auch ein Master Boot Record befinden. Wenn nicht, solltest du nach erfolgreichem Erkennen der Platte den MBR neu schreiben. Wenn du auf A: bist, einfach "format c: /mbr" (ohne Anführungsstriche) eingeben, damit schreibst du den MBR neu.
Noch was: Diese ganzen Operationen sind nicht ganz unkritisch, und aus der Ferne ist es nicht soeinfach zu bewerkstelligen. Es könnte durchaus passieren, daß meine Tips nicht zutreffen, daß du im BIOS eventuell die korrekten Einträge löschst und dann nicht mehr weißt, was da vorher stand oder ähnliches. Bei mir zum Beispiel ist die IDE HDD Auto Detection NICHT auf Auto gesetzt, sondern die Werte der Platte (Type, Size, Cyls, Head, Precomp, Landz, Sector, Mode) sind fest eingetragen... Notier dir also vor dem Ändern alle Werte, die da stehen, auf einem Blatt Papier, und zwar akribisch! Damit du bei einem Fehlschlag diese Werte wiederherstellen kannst! Wenn du gar nicht weiterkommst, frag einen Kumpel, der sich auskennt, oder geh in einen guten PC-Laden mit Werkstatt... Versteh mich da nicht falsch, ich helf dir gerne so gut wie ich kann, aber wenn die Büchse hinterher im Eimer ist, sollst du mir nicht die Schuld daran geben müssen...
Viel Erfolg!

Moldmaker

(Anonym) Moldmaker (Anonym: 217.2.131.54)

„Hallo Lars, Das läuft ja nicht ganz wunschgemäß. Die jetzt noch installierte...“

Optionen

Hi Moldmaker,
viiielen Dank für die Hilfe! Der PC funktioniert wieder - der Jumper war das Problem...
Lars

Moldmaker (Anonym: 217.2.144.70) (Anonym)

„Hi Moldmaker, viiielen Dank für die Hilfe! Der PC funktioniert wieder - der...“

Optionen

Hallo Lars,

freut mich, daß es geklappt hat. War mir ein Vergnügen.

Gruß

Moldmaker