Linux 14.905 Themen, 105.310 Beiträge

Epson Ecotank unter Linux Mint 19.2 installieren bricht ab

Holk / 20 Antworten / Baumansicht Nickles

Hallo Linuxer,

habe meinen Epson Ecotank L355 in Linux Mint 19.2 zur Zeit unter dem im Auswahlmenü verfügbaren L310 mit mäßigem Druckbild laufen. Nun habe ich gesehen, dass Epson einen speziellen Treiber für meinen Drucker anbietet und habe ihn entsprechend Anleitung aufgerufen und die Installation gestartet. Er bricht bei ca. 70% ab und lässt sich nicht mehr zum Weitermachen nötigen. In verschiedenen Foren wurde mein Vorgehen wie ausgeführt beschrieben, so daß ich momentan keinen direkten Fehler meinerseits feststellen konnte. Vielleicht hat jemand Erfahrung gerade mit diesem Drucker, da ich mit diesem Druckbild aus dem L310 Treiber, zu Zeiten des Homeschooling, nicht wirklich zufrieden sein kann.

Für sachdienliche Hinweise wäre ich sehr dankbar.

Gruß Holk

bei Antwort benachrichtigen
KarstenW Holk

„Epson Ecotank unter Linux Mint 19.2 installieren bricht ab“

Optionen

Du  mußt wissen das GNU/Linux ein paar Dinge von Unix übernommen hat. Unter Unix wurde schon vor vielen Jahren als Standarddruckformat Postscript festgelegt. Unter GNU/Linux ist derzeit Postscript auch das Standarddruckformat. Alle Unix - und Linuxprogramme erzeugen ihre Druckdaten im Postscriptformat. Normalerweise braucht man unter GNU/Linux einen Drucker der die Druckersprache Postscript beherrscht- Wenn man so einen postscriptfähigen Drucker nutzt, dann braucht man gar keine Druckertreiber unter Linux. Man muß nur die richtige ppd-Datei (Postscriptdruckerbeschreibungsdatei für die Konfiguration der Druckerwarteschlange) installieren. Manche Hersteller liefern die richtige ppd Datei für Linux und andere Hersteller eben nicht. Diese postscriptfähigen Drucker sind aber sehr teuer und werden nur im professionellem Umfeld genutzt. Das aber nur nebenbei.

Ich habe im Internet gesucht und erkannt das Epson keine Druckertreiber für Linux anbietet:

https://www.epsondruckertreiber.com/epson-ecotank-l355-treiber/

Aber ich habe einen Treiber auf der Seite

https://www.openprinting.org/printer/Epson/Epson-L355_Series

gefunden. Ist Englisch ein Problem ?

Linux Mint nutzt derzeit die deb Pakete von Debian. Deshalb kannst du die deb Pakete herunterladen und mit dem dpkg Befehl in der Konsole oder in einem Terminal Fenster (xterm , Konsole oder einem anderen Terminalprogramm) installieren. Du braucht dazu root Recht. Ich nutze Debian. Entweder du loggst dich als root ein oder du schreibst den sudo Befehl vor dem dpkg Befehl davor.

sudo dpkg -i Datei.deb

oder wenn du dich als root einloggen kannst, dann tippst du den Befehl

dpkg -i Datei.deb

.ein. Alles weitere steht in den manpage (manualpage oder Handbuchseite):

man dpkg. Sie ist sogar in deutsch.

dpkg kann allerdings keine Abhängigkeiten auflösen. Deshalb mußt du aptitude , apt-get oder auch apt in der Konsole starten, um eventuell fehlende Programme oder auch Bibliotheken nachinstallieren.

Wenn du über den Kauf eines neuen Drucker nachdenkst, dann kann ich dir HP Drucker empfehlen. HP unterstützt das HPLIP Projekt.

https://developers.hp.com/hp-linux-imaging-and-printing

Ich habe mit HP Drucker unter Linux gute Erfahrungen gemacht.

Debian GNU/Linux https://www.debian.org/index.de.html
bei Antwort benachrichtigen
KarstenW

Nachtrag zu: „Du mußt wissen das GNU/Linux ein paar Dinge von Unix übernommen hat. Unter Unix wurde schon vor vielen Jahren als ...“

Optionen

Installiere das deb Paket am besten gleich mit dem Programm gdebi.

Installiere das Programm gdebi

sudo apt-get install gdebi

Oder eben mit einem grafischen APT Frontend.
Und danach kannst du mit gdebi das deb Paket installieren.

sudo gdebi /Pfad/zu/Datei.deb

gdebi löst Abhängigkeiten selbst auf und installiert benötigte Bibliotheken und fehlende
Programme gleich mit.
Alles weitere steht in der manpage.

man gdebi

PS: Ich hoffe gdebi ist unter Linux Mint wie bei Debian überhaupt verfügbar.





Debian GNU/Linux https://www.debian.org/index.de.html
bei Antwort benachrichtigen
Alpha13 KarstenW

„Du mußt wissen das GNU/Linux ein paar Dinge von Unix übernommen hat. Unter Unix wurde schon vor vielen Jahren als ...“

Optionen

http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX

https://epson.com/Support/wa00821

Wenn man bei Epson nach L355 sucht wird man auch fündig und "deine" Seite hat mit Epson sowas von überhaupt nix zu tun!

Und Epson bietet für das Teil 2 Linux Druckertreiber und einen Scannertreiber an.

bei Antwort benachrichtigen
Raecher_der_Erwerbslosen1 Alpha13

„http://download.ebz.epson.net/dsc/search/01/search/?OSC LX https://epson.com/Support/wa00821 Wenn man bei Epson nach L355 ...“

Optionen
Wenn man bei Epson nach L355 sucht wird man auch fündig

Genau! Erste Anlaufstelle unter/für Linux ist in solchen Fällen immer diese Seite: http://www.openprinting.org/printers

Und wenn man dort nach dem Treiber für den oben genannte Drucker sucht, dann findet man das hier: http://www.openprinting.org/printer/Epson/Epson-L355_Series

Und was steht da? Ich setze mal einen Screenshot hier rein:

Alles klar?

Der KarstenW vergalloppiert sich da immer "etwas" mit seinen ganzen Erklärungen. Aber das hat er früher auch schon immer gemacht...... :-))

Wer nach allen Seiten offen ist, der kann nicht ganz dicht sein.
bei Antwort benachrichtigen
Alpha13 Raecher_der_Erwerbslosen1

„Genau! Erste Anlaufstelle unter/für Linux ist in solchen Fällen immer diese Seite: http://www.openprinting.org/printers ...“

Optionen
bei Antwort benachrichtigen
Alpha13

Nachtrag zu: „http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2 DE CN2 DSCMI 18787 DSCCHK ...“

Optionen

Und AMD64 = Linux = Mint 64Bit, aber wer das nicht weiß und bei Linux nen Drucker installieren will...

bei Antwort benachrichtigen
Holk Alpha13

„http://download.ebz.epson.net/dsc/search/01/search/?OSC LX https://epson.com/Support/wa00821 Wenn man bei Epson nach L355 ...“

Optionen

Hallo Alpha 13,

Danke für Tiips, alles versucht Ergebnis gleich. Abbruch kurz vor Ende mit Fehlermeldung, dass es eine fehlende Abhängigkeit von  lsb(>=3.2) gibt und somit abgebrochen wird.

Soweit so schlecht.

LG Holk

bei Antwort benachrichtigen
Holk KarstenW

„Du mußt wissen das GNU/Linux ein paar Dinge von Unix übernommen hat. Unter Unix wurde schon vor vielen Jahren als ...“

Optionen

Hallo Karsten

habe deine Vorschläge durchprobiert. Es scheitert alles kurz vor knapp an der Abhängigkeit von lsb (>=3.2)

Gruß Holk

bei Antwort benachrichtigen
KarstenW Holk

„Hallo Karsten habe deine Vorschläge durchprobiert. Es scheitert alles kurz vor knapp an der Abhängigkeit von lsb 3.2 Gruß Holk“

Optionen

Mit lsb ist die Linux Standardbase gemeint. Die LSB ist ein Industriestandard , welcher für eine Binärkompatibilität zwischen den Distributionen entwickelt worden ist. Das Problem ist, das  sich viele Distributionen nicht an die LSB halten.

https://de.wikipedia.org/wiki/Linux_Standard_Base

Die Linuxtreiber von Openprinting.org sind im Grunde genommen Filter und keine Treiber. Ein "richtiger" Drucker kann irgendeine Druckersprache wie PCL3 oder PCL6. Diese Linuxdruckertreiber haben die Aufgabe das Postscriptdruckformat in die Druckersprache umzuwandeln, die der jeweilige Drucker verarbeiten kann. Der Drucker kann dann selbst den Druckkopf oder das Druckwerk steuern. Es gibt sogenannte GDI Drucker die überhaupt keine Druckersprache können. Für solche GDI Drucker muß wirklich ein Treiber installiert werden , welcher den Druckkopf steuert. Mir ist nicht bekannt das irgendeine Firma für diese billigen GDI Drucker Linuxtreiber programmiert.

Ich habe jedenfalls gute Erfahrungen mit den Treiber oder Filtern vom HPLIP Projekt gemacht.

Oder du kaufst eine postscriptfähigen Drucker. Du mußt dich  dann  beim Hersteller erkundigen ob er eine passende ppd Datei für das Drucksystem CUPS (Common Unix Printingsystem) liefern kann.

Debian GNU/Linux https://www.debian.org/index.de.html
bei Antwort benachrichtigen
fakiauso Holk

„Epson Ecotank unter Linux Mint 19.2 installieren bricht ab“

Optionen

Welche Architektur nutzt Du unter Mint (32- oder 64bit) und hast Du auch das Paket lsb installiert?

Wie bist Du vorgegangen, um zu installieren? Bei dem Drucker brauchst Du eigentlich nur das entsprechende *.deb-Paket zu doppelklicken und dann sollte der treiber an sich installiert sein.

Danach gehst Du unter Einstellungen in das Druckermenü und wählst erst den Drucker aus, wenn er nicht ohnehin automatisch erkannt wird und weist anschliessend den entsprechenden Treiber von Hand zu.

Müsste dann so in etwa beniemt sein:

Epson L355 Series - epson-inkjet-printer 1.0.0-1lsb3.2 (Seiko Epson Corporation LSB 3.2)

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Holk fakiauso

„Welche Architektur nutzt Du unter Mint 32- oder 64bit und hast Du auch das Paket lsb installiert? Wie bist Du vorgegangen, ...“

Optionen

Hallo Fakiauso,

ich nutze die 32bit Version 19.2 "Tina" und habe sowohl mit dem Terminal als auch grafisch sichtbar das Problem mit der Abhängigkeit von lsb(>=3.2). Der Treiber wird fast komplett installiert und kurz vor Ende erscheint die Fehlermeldung mit dem o.g. Hinweis. Habe auch die Tips der anderen User hier im Forum alle durchpropiert, es hängt an dieser Abhängigkeit. Könnte ein Update auf 19.3 evtl. helfen.

Gruß holk

bei Antwort benachrichtigen
Alpha13 Holk

„Hallo Fakiauso, ich nutze die 32bit Version 19.2 Tina und habe sowohl mit dem Terminal als auch grafisch sichtbar das ...“

Optionen
bei Antwort benachrichtigen
fakiauso Holk

„Hallo Fakiauso, ich nutze die 32bit Version 19.2 Tina und habe sowohl mit dem Terminal als auch grafisch sichtbar das ...“

Optionen
ich nutze die 32bit Version 19.2 "Tina" und habe sowohl mit dem Terminal als auch grafisch sichtbar das Problem mit der Abhängigkeit von lsb(>=3.2). Der Treiber wird fast komplett installiert und kurz vor Ende erscheint die Fehlermeldung mit dem o.g. Hinweis.


Eigentlich merkwürdig, denn wenn lsb korrekt installiert ist, dann dürfte die auch bei 19.2 deutlich höher sein als die geforderte 3.2. Unter 19.3 ist es die Version 9.20170808ubuntu1.

Habe mir gerade die Mühe gemacht, auf einem 19.3 in 64bit erst die lsb zu installieren und anschliessend lässt sich das entsprechende Treiberpaket problemlos mittels sudo dpkg -i installieren.

Was spuckt denn ein:

apt-cache policy lsb

aus?

Ansonsten einfach noch einmal erneut installieren oder wie in Alpha13´s Link mittels sudo apt-get -f install lsb kaputte Abhängigkeiten korrigieren. Die xsltproc war bei mir übrigens nicht erforderlich.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
KarstenW fakiauso

„Eigentlich merkwürdig, denn wenn lsb korrekt installiert ist, dann dürfte die auch bei 19.2 deutlich höher sein als die ...“

Optionen

Mit lsb ist die Linuxstandardbase gemeint. Das ist nicht ein einzelnes Paket, sondern eine komplette standardisierte Laufzeitumgebung. Mit der LSB soll eine Binärkompatibilität zwischen den Distributionen gewährleistet werden. Wahrscheinlich ist Linux Mint nicht LSB kompatibel.

https://de.wikipedia.org/wiki/Linux_Standard_Base

PS: Diese Problem gibt es auch unter "richtigem" Unix. Jede Firma will "Ihr" Unix verkaufen und am Ende nimmt kaum jemand Unix. Es gibt gibt nicht das EINE Unix, sondern verschiedene Betriebssystem die als Unix zertifiziert worden sind. Diese Probleme sollten eigentlich bei GNU/Linux mit seinen offenen Standards verhindert werden.

Debian GNU/Linux https://www.debian.org/index.de.html
bei Antwort benachrichtigen
KarstenW

Nachtrag zu: „Mit lsb ist die Linuxstandardbase gemeint. Das ist nicht ein einzelnes Paket, sondern eine komplette standardisierte ...“

Optionen

Es gibt auch ein paar LSB Pakete bei Debian. Diese Pakete sind aber nicht die komplette Linux Standardbase Kompatibilität. Wenn bei Linux Mint diese LSB Pakete fehlen, dann deutet das darauf hin das Linux Mint nicht Linux Standardbase kompatibel ist. Dadurch kann ein Mint Anwender Probleme bekommen, wenn er Fremdsoftware installieren möchte. So weit ich weiß ist Ubuntu LSB kompatibel. Debian war LSB kompatibel, aber die Maintainer haben kein richtiges Interesse mehr an der LSB Kompatibilität.

Debian GNU/Linux https://www.debian.org/index.de.html
bei Antwort benachrichtigen
fakiauso KarstenW

„Es gibt auch ein paar LSB Pakete bei Debian. Diese Pakete sind aber nicht die komplette Linux Standardbase Kompatibilität. ...“

Optionen
Wenn bei Linux Mint diese LSB Pakete fehlen, dann deutet das darauf hin das Linux Mint nicht Linux Standardbase kompatibel ist.


Och Karsten;-)

Natürlich sind die lsb-Pakete in Mint enthalten. Siehe auch mein Beitrag etwas weiter oben.

Die LSB selber gibt es zwar schon mittelewig, aber anscheinend hält sich da so oder so kaum eine Distri komplett daran, sondern baut immer noch ihr eigenes Zeug drumherum. Selbst Debian hält sich also nicht dran und liefert unter Buster "nur" die Pakete lsb-base und lsb-release aus.

Da wie beschrieben das Installieren bei mir funktioniert hat unter einem Testsystem mit Mint, liegt der Wurm an irgendetwas in Holks Installation und sei es nur, das neben dem eigentlichen Paket für lsb die restlichen nicht enthalten sind.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Holk fakiauso

„Eigentlich merkwürdig, denn wenn lsb korrekt installiert ist, dann dürfte die auch bei 19.2 deutlich höher sein als die ...“

Optionen

Hallo Fakiauso,

apt-cache policy lsb zeigt folgendes Ergebnis:

apt-cache policy lsb
lsb:
  Installiert:           9.20170808ubuntu1
  Installationskandidat: 9.20170808ubuntu1
  Versionstabelle:
 *** 9.20170808ubuntu1 500
        500 ftp://ftp.fu-berlin.de/linux/ubuntu bionic/universe amd64 Packages
        500 ftp://ftp.fu-berlin.de/linux/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status

 Und sudo apt-get -f install lsb bringt das zum Vorschein:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
lsb ist schon die neueste Version (9.20170808ubuntu1).
lsb wurde als manuell installiert festgelegt.
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 epson-inkjet-printer-201207w:i386 : Hängt ab von: lsb:i386 (>= 3.2) ist aber nicht installierbar
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

Vielleicht hast eine Idee dazu.

LG Holk

bei Antwort benachrichtigen
fakiauso Holk

„Hallo Fakiauso, apt-cache policy lsb zeigt folgendes Ergebnis: apt-cache policy lsb lsb: Installiert: 9.20170808ubuntu1 ...“

Optionen
Vielleicht hast eine Idee dazu.


Die erste wäre die Lösungshilfe mit apt --fix-broken install oder äquivalent sudo apt-get install -f auszuführen, um die kaputten Abhängigkeiten zu richten.

Anschliessend kannst Du lsb noch einmal komplett entfernen (purge entfernt ggf. falsche Konfigurationsdateien mit):

sudo apt-get purge lsb

Anschliessend am besten erst das System durchaktualisieren, dann lsb installieren und dann das Druckerpaket neu reinklatschen (eventuell lädst Du auch das Paket für den Treiber noch einmal neu herunter, falls da was kaputt ist):

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install lsb

Wechsel in den Downloadordner:

sudo dpkg -i Dämlicher_Druckertreiber.deb

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
KarstenW Holk

„Epson Ecotank unter Linux Mint 19.2 installieren bricht ab“

Optionen

Bevor hier noch weiter diskutiert wird, wie man diesen Uralttreiber unter Linux-Mint installieren kann, habe ich eine Hardwarelösung.

Man bekommt bei Amazon für 186,89 € einen Kyocera Ecosys P5021cdn Farblaserdrucker welcher unter Windows, MacOS und unter Linux läuft.

https://www.amazon.de/dp/B01M35FNWJ/?coliid=I8YOESX92D068&colid=2I19TVA1L12JW&psc=1&ref_=lv_ov_lig_dp_it

https://www.kyoceradocumentsolutions.de/de/products/printers/ECOSYSP5021CDN.html

Das ist kein richtiger Postscriptdrucker. Die sind ohnehin unbezahlbar teuer. Aber dieser Drucker läuft unter Unix(Oracle Solaris beispielsweise) und unter GNU/Linux. Er kann sogar PDF Dateien direkt ausdrucken. Das Postscriptdruckformat soll irgendwann in der Zukunft unter Linux durch PDF ersetzt werden. PDF baut auf Postscript auf. Die Dateien sind kompakter und es gibt immer mehr Drucker die PDF direkt ausdrucken können.

Debian GNU/Linux https://www.debian.org/index.de.html
bei Antwort benachrichtigen
KarstenW

Nachtrag zu: „Bevor hier noch weiter diskutiert wird, wie man diesen Uralttreiber unter Linux-Mint installieren kann, habe ich eine ...“

Optionen

Ich brauche selbst auch einen Drucker . Mein HP Laserjet 6L hat nach 20 Jahren den Geist aufgegeben. Und mein HP Deskjet  5652 ist wegen der hohen HP Patronenpreise auch nicht mehr zu gebrauchen. Ich werden mir diesen Drucker auf jeden Fall kaufen.

Debian GNU/Linux https://www.debian.org/index.de.html
bei Antwort benachrichtigen