Linux 14.959 Themen, 106.039 Beiträge

Monitor-Reihenfolge ändern

hansapark / 44 Antworten / Baumansicht Nickles

Hallo. 

Ich würde gerne die Reihenfolge ändern, in der meine Monitore erkannt werden. Ich habe PC über VGA als 2 und einen TV über DVI als 1, wollte es aber andersherum einstellen.

An der Reihenfolge, in der sie angeschlossen werden, scheint es nicht zu liegen, da DVI erst später dazu kam. Ich habe hier archlinux mit gnome 3.10.1. Meine graka ist eine [AMD/ATI] RV770 [Radeon HD 4850].

Irgendwie wird DVI bevorzugt, denn z.b. grub erscheint auf dem TV in korrekter Größe und passend, aber auf dem PC-Monitor etwas zu groß und verschoben. Ich suche schon eine Weile aber bin noch nicht fündig geworden. Vielleicht gibt es eine ganz einfach Lösung?

Ich habe mir schon eine /etc/X11/xorg.conf erstellt (die identifier habe ich aus xrandr -q entnommen) aber die hat nichts geändert:

Section "Monitor"
Identifier "VGA-0"
Option "Primary" "true"
EndSection

Section "Monitor"
Identifier "DVI-0"
Option "LeftOf" "VGA-0"
EndSection

mfg

bei Antwort benachrichtigen
Borlander hansapark „Monitor-Reihenfolge ändern“
Optionen
rub erscheint auf dem TV in korrekter Größe und passend, aber auf dem PC-Monitor etwas zu groß und verschoben.

Schon mal mit der Auto-Tastate am Monitor versucht? Damit sollte sich die Bildgeometrie korrigieren lassen.

Mit der xorg.conf hast Du auf Grub oder den Textmodus keinen Einfluss.

bei Antwort benachrichtigen
Acader hansapark „Monitor-Reihenfolge ändern“
Optionen

hansapark schrieb:

Ich würde gerne die Reihenfolge ändern

Installiere dir mal das Paket arandr bzw xrandr.

Danach mit Alt+F2 ausführen und unter Ausgabegeräte dann deine Wahl festlegen.

Im Terminal bekommst du mit arandr bzw xrandr auch eine Ausgabe.

MfG Acader

bei Antwort benachrichtigen
fakiauso hansapark „Monitor-Reihenfolge ändern“
Optionen

Hi

Eine Krückenlösung ist das Ändern der Auflösung von grub2 (?) unter /etc/default/grub, indem Du dort bei GRUB_GFXMOD=xxxx die Werte Deines Monitors angibst.
Das skaliert zwar das Bild auf dem TV hoch, aber dann passt es dafür auf dem Monitor.

Bei gleichzeitiger Nutzung beider Geräte hast Du da m.E. kaum eine Chance, das anzupassen, maximal noch wie in diesem Thread:

http://askubuntu.com/questions/362878/xorg-conf-nvidia-second-monitor-getting-settings-of-first

Dann müßtest Du entweder VGA-0 auf Screen0 antackern oder per xrandr --output VGA-0 --primary --mode "Deine_Auflösung" übergeben.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Acader fakiauso „Hi Eine Krückenlösung ist das Ändern der Auflösung von ...“
Optionen

faki, er hat eine ATI- Graka da funzt das nicht wie er das will.

MfG Acader

bei Antwort benachrichtigen
fakiauso Acader „faki, er hat eine ATI- Graka da funzt das nicht wie er das ...“
Optionen

Mir ging es da auch nicht um Nvidia, sondern um das Beispiel, den Monitor an VGA als ersten einzustellen. Mit xrandr --primary sollte das am einfachsten gehen.
Sonst wäre noch die Frage, warum es über die xorg.conf nicht funktioniert:

http://superuser.com/questions/546069/setting-primary-monitor-in-ubuntu-without-xrandr

Eventuell übergibt hansapark nochin der xorg.conf die korrekte Auflösung und gibt vorher den passenden Treiber mit, also so:

Section "Device"
 Identifier   "Device"
 Driver       "fglrx"
EndSection
Oder so:

 Section "Device"
   Identifier "Device"
   Driver "radeon"
EndSection

Die komplette Ausgabe von xrandr müßte so lauten:

xrandr --output VGA0 --primary --mode "Deine_Auflösung" --output DVI0 --mode "Deine_Auflösung" --left-of VGA0

Vereinfach geht auch:

xrandr --output VGA0 --primary --auto --output DVI0 --auto --left-of VGA0

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Acader fakiauso „Mir ging es da auch nicht um Nvidia, sondern um das ...“
Optionen
den Monitor an VGA als ersten einzustellen

Das kann man unter Debian leicht in der GUI von arandr machen.

Da kann man dann auch gleich die Auflösung bestimmen.

Das sollte doch unter Arch auch gehen denke ich.

MfG Acader

bei Antwort benachrichtigen
hansapark Acader „Das kann man unter Debian leicht in der GUI von arandr ...“
Optionen

Ja , das geht per drag and drop, aber die Nummerierung an sich ändert sich nicht, so wie auf dem Bild:

bei Antwort benachrichtigen
Acader hansapark „Ja , das geht per drag and drop, aber die Nummerierung an ...“
Optionen
aber die Nummerierung an sich ändert sich nicht

Dann mach den 17 Zöller aktiv

MfG Acader

bei Antwort benachrichtigen
hansapark Acader „Dann mach den 17 Zöller aktiv MfG Acader“
Optionen

Ja das geht, dann sind die Anzeigen nicht mehr gespiegelt sondern nebeneinander oder übereinander (die anordnung kann man mit dem Button darunter einstellen). Aber es ändert nichts an der 1 und der 2. Und beim booten genau das gleiche Problem.

das ist das Problem :/

bei Antwort benachrichtigen
hansapark fakiauso „Mir ging es da auch nicht um Nvidia, sondern um das ...“
Optionen

Ist das nicht bis auf den Bindestrich vor den Nullen, das was ich im startpost habe? Ich werds mal ohne Bindestrich probieren, wobei mir xrandr -q die identifier mit strich ausgegeben hat:

[me@my-pc ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
VGA-0 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
1280x1024 75.0* 75.0 60.0
1024x768 75.1 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 75.0 72.8 60.0
720x400 70.1
DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 434mm x 270mm
1680x1050 59.9 + 60.0
1280x1024 75.0* 60.0
1280x960 60.0
1152x864 75.0
1024x768 75.1 60.0
832x624 74.6
800x600 75.0 60.3 56.2
640x480 75.0 60.0
720x400 70.1
HDMI-0 disconnected (normal left inverted right x axis y axis)

bei Antwort benachrichtigen
fakiauso hansapark „Ist das nicht bis auf den Bindestrich vor den Nullen, das ...“
Optionen
Ist das nicht bis auf den Bindestrich vor den Nullen, das was ich im startpost habe? Ich werds mal ohne Bindestrich probieren, wobei mir xrandr -q die identifier mit strich ausgegeben hat:


Ja sicher, aber irgendwie scheint es der Kamerad nicht zu fressen;-)

Hier habe ich noch etwas gefunden, zwar für aptosid, aber das düfte ja analog auch für Arch gelten:

http://manual.aptosid.com/de/hw-dev-mon-de.htm

Versuche es also einmal mit einer separaten /etc/X11/xorg.conf.d/30-screen.conf. Die Benennung mit durch randr Bindestrich scheint danach nur bei den Atis so zu sein.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
hansapark fakiauso „Ja sicher, aber irgendwie scheint es der Kamerad nicht zu ...“
Optionen

Ja okay, hab mir eine angepasste 30-screen.conf angelegt. grub ist immer noch nicht ganz tacko. aber es geht (ich hab auch mal auf auto gedrückt , es hat grub ein klein bisschen bewegt - nicht so ganz wo er hin müsste aber im sichtbaren bereich alles)

und durch das kopieren der monitors.xml hab ich ja nun den gdm wo ich ihn haben will. da müsste ich erstmal die gdm - monitors.xml löschen um zu sehen ob es nun auch ohne geht. aber die ist nun verschollen. (ich habe sie nach ~gdm/.config/ kopiert aber sie ist irgendwo anders gelandet, so unwahrscheinlich das klingt. irgendwie var oder usr oder sowas wurde angezeigt, vielleicht weil der slash vor gdm nicht da ist (!?))

nun ja. im großen und ganzen geht es jetzt und tut was es soll. von daher geb ich mich mal zufrieden für heute. es gab zwar nicht die wunder-einfache-option aber man hat wieder was gelernt. ;) 

die Nummern der TFTs sind leider immer noch so wie vorher:

TV - DVI - 1

PC - VGA - 2

bei Antwort benachrichtigen
hansapark Acader „faki, er hat eine ATI- Graka da funzt das nicht wie er das ...“
Optionen

Ich hab schon mit arandr und lxrandr herumprobiert, und habe da keine einstellung gefunden, die die nummerierungsreihenfolge der screens festlegt. also so, dass es schon vor gdm greift.

Dann hab ich noch die ~/.config/monitors.xml nach ~gdm/.config/ kopiert, dadurch hab ich wenigstens jetzt den gdm auf beiden schirmen..

Es muss doch auch etwas sein, was sehr früh beim booten abgefragt wird, oder? Ich habe daher in /etc/mkinitcpio.conf die Zeile MODULES="radeon" hinzugefügt und dann das image (?) neu erstellt. Aber das brachte auch keine änderung nach einem Neustart.

Vielleicht geht es mit catalyst einzustellen, aber das wollte ich vermeiden zu installieren. Vermutlich muss ich es doch mal probieren. Die Frage ist, wo der das dann speichert und ob man das nicht auch mit dem freien Treiber einstellen kann.. 

bei Antwort benachrichtigen
Acader hansapark „Ich hab schon mit arandr und lxrandr herumprobiert, und habe ...“
Optionen
Ich hab schon mit arandr und lxrandr herumprobiert, und habe da keine einstellung gefunden, die die nummerierungsreihenfolge der screens festlegt

Es reicht doch wenn du  den Aktiven und die Auflösungen für beide Monitore festlegst, die können doch auch unterschiedlich sein. Da ich keine ATI  Grakas habe kann ich das leider nicht ausprobieren. Mit NVIDIA geht es jedenfalls.

was sehr früh beim booten abgefragt wird, oder?

In dem Fall die Aktive.

MfG Acader

bei Antwort benachrichtigen
hansapark Acader „Es reicht doch wenn du den Aktiven und die Auflösungen ...“
Optionen

sogar wenn ich den TV deaktiviere (mit arandr z.b.) und ihn auch ausschalte, geht das Bild beim booten 'in das dvi kabel'. erst nach dem login bekam ich auf dem pc monitor die menüs und alles angezeigt. ich hab jetzt gottlob den gdm auf beiden screens aber nur weil ich die monitors.xml zum gdm config ordner kopiert habe :/

edit: im bios findet sich nichts zu bildschirmen und co (asus)

bei Antwort benachrichtigen
Acader hansapark „sogar wenn ich den TV deaktiviere mit arandr z.b. und ihn ...“
Optionen

Wohl doch ein ATI Problem.

Du hattest ja die Frage schon mal im Arch-Forum gestellt. Ich selbst nutze seit Jahren keine ATI mehr auf meinen Rechnern und kann daher nichts konkretes weiter dazu schreiben. Tut mir leid.

Vielleicht kannst du noch mal im Debian-Forum nachfragen.

MfG Acader

bei Antwort benachrichtigen
hansapark Acader „Wohl doch ein ATI Problem. Du hattest ja die Frage schon mal ...“
Optionen

Vielleicht liegt es an der graka, ja. Versuch wars wert ;)

bei Antwort benachrichtigen
Alekom hansapark „Vielleicht liegt es an der graka, ja. Versuch wars wert“
Optionen

hallo hansapark

ich bin unter debian unterwegs, habe eine Ati X1200 und auch ich habe öfters Probleme mit der Anzeige auf 2 Monitoren.

Man kann sich aber ein Skript machen lassen und es abspeichern, in meinem Fall hab ich die Datei dualmonitor.sh genannt, per autostart werden die Monitore immer erkannt und so wie ich es haben will, der eine links, der andere rechts.

ich muss jetz nur schauen ob ich es unter Arandr oder Xrandr gemacht habe ...

und natürlich mit chmod die rechte setzen ...

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
Acader Alekom „hallo hansapark ich bin unter debian unterwegs, habe eine ...“
Optionen
ich muss jetz nur schauen

Dann schau mal nach, würde mich auch interessieren.

MfG Acader

bei Antwort benachrichtigen
Alekom Acader „Dann schau mal nach, würde mich auch interessieren. MfG Acader“
Optionen

so liebe leute, euch zuliebe hab ich den pc neu aufgesetzt, damit ich ein frisches system habe ohne altlasten, unterwegs bin ich mit debian 7.3

sorry nochmals, ich hatte eine falsche angabe gmacht nämlich die ati X1200, das war auch falsch, es ist eine ati X1250..und die hab ich im laptop....vergesst das schnell.

alles was jetzt kommt, behandelt ein pc mit einer ati X600 pro, sowie zwei monitore.

der eine monitor hat VGA Anschluss und der andere monitor hat DVI-Anschluß

das mit dem skript dualmonitor.sh hab ich auf die schnelle nicht mehr nachvollziehen können...aber ich schätze das muss man mit einem Editor wie Nano erstellen, bestimmte befehle eingeben, abspeichern und mittels chmod ausführbar machen und im autostart eintragen, alles mit root-rechten...alles zu kompliziert. wie man das macht, da mache ich mir die arbeit und werde probieren wenn es ausdrücklich erwünscht wird.

hab mich grad schlau gemacht und folgendes gemacht.

mit root-rechten das terminal aufgemacht und dort xrandr eingegeben

bei mir war zu lesen (nur ein Auszug daraus):

VGA-0 connected 1280+1024+0+0

darunter 

DVI-0 connectet 1280+1024+0+0

gut wie mache ich das, das jetzt DVI rechts von VGA kommt:

ins verzeichnis /etc/X11/Xsession.d/ wechseln und dort eine datei mit nano 45-custom_xrandr-settings erstellen

im editor selbst schreiben:

#!/bin/sh

xrandr_--output_DVI-0_--auto_--right-of VGA-0

mit STGR und O abspeichern und mit STRG und X beenden

(Anmerkung: die _ dienen nur als Platzhalter für Leerzeichen, diese NICHT eintippen!!!)

datei muss NICHT extra ausführbar gemacht werden, hab da grad nachgeguckt

kleiner hinweis noch, monitore kann man einfachst vertauschen wenn VGA-0 zuerst und danach DVI-0 geschrieben wird. 

ich habe den pc neugestartet und siehe da, er hat sich alles gemerkt, monitor auflösung ist so wie ich es möchte, VGA links und DVI rechts.

nach eingabe im terminal von xrandr müsste dann es so aussehen:

VGA-0 connected 1280x1024+0+0

und darunter

DVI-0 connectet 1280x1024+1280+0

that's it :-)

natürlich will ich nicht sagen das es alles auf meinen  misthaufen gewachsen ist, denn ich bin bestenfalls ein laie, darum die quellenangabe ob meiner risikobereitschaft:

http://wiki.ubuntuusers.de/RandR

wichtig ist die manuelle statistische konfiguration dann.

mfg Alekom

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
Acader Alekom „so liebe leute, euch zuliebe hab ich den pc neu aufgesetzt, ...“
Optionen

Hast du arandr ausprobiert?

Genau das interessiert mich.

MfG Acader

bei Antwort benachrichtigen
Alekom Acader „Hast du arandr ausprobiert? Genau das interessiert mich. MfG ...“
Optionen

hallo Acader,

ich muss sagen ich schaue jetzt etwas belämmert aus der Wäsche.

unter apt-get install findet er das Paket arandr gar nicht. 

Bevor ich die Neu-Installation gemacht habe, hatte ich das Programm noch auf dem Pc, hab nämlich nachgeguckt was Sache ist, eine GUI halt.

habe grad bei der Sources liste noch die Zusätze contrib und non-free hinzugefügt.

keine Reaktion ausser E: Paket Arandr kann nicht gefunden werden.

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
fakiauso Alekom „hallo Acader, ich muss sagen ich schaue jetzt etwas ...“
Optionen
unter apt-get install findet er das Paket arandr gar nicht. 


arandr steckt in den universe-Quellen;-)

Gute Nacht

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Alekom Nachtrag zu: „hallo Acader, ich muss sagen ich schaue jetzt etwas ...“
Optionen

hello Acader,

ich musste die Sources List um den Eintrag für Sid erweitern! dort hat er das Paket arandr. *tz*

habe mir grad arandr installiert. habe einen terminal unter root aufgemacht und arandr eingegeben.

zu sehen sind zwei rechtecke, VGA-0 ist über das rechteck DVI-0 überlagert.

mittels maus kann man die rechtecke so verschieben wie man möchte.

ich habe VGA-0 links und DVI-0 rechts geschoben, auf anwenden klicken.

speichern mittels unter speichern, dort irgendeinen dateinamen angeben und auf entertaste drücken.  habe es kontrolliert, die dateiendung war auf sh.

habe den pc neugestartet und was war? er hat sich die einstellung NICHT gemerkt.

und jetzt weiss ich wieder was das mit dualmonitor.sh war...das war genau die zeile die ich mit nano aufgemacht habe...dort war die ausgabe zu lesen:

#!/bin/sh

xrandr --output VGA-0 --mode 1280x1024 --pos 0x0 --rotate normal --output S-video --off --output DVI-0 --mode 1280x1024 --pos 1280x0 --rotate normal

habe es unter dem normalen benutzerkonto erstellt, also nicht mit rootrechten, abgespeichert und zu den startprogrammen hinzugefügt.

(unter root konnte ich nix dem startprogrammen hinzufügen weil ich im moment nicht weiss, wie ich es aufrufen kann, ich habs mitn normalen konto gemacht)

Pc neugestartet und voila...so wie ich es mag: VGA links und DVI rechts

zum Startmenü kommt man so:

Anwendungen ->Systemwerkzeuge ->Einstellungen-Startprogramme

dort auf hinzufügen klicken und datei auswählen

mfg Alekom

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
Acader Alekom „hello Acader, ich musste die Sources List um den Eintrag ...“
Optionen
ich musste die Sources List um den Eintrag für Sid erweitern!

???? ----->  klick bzw siehe hier

okay, wenn ich mal die Gelegenheit bekomme ein Debian mit einer ATI einzurichten, werde ich mir das selbst mal anschauen.

MfG Acader

bei Antwort benachrichtigen
Alekom Acader „???? ----- klick bzw siehe hier okay, wenn ich mal die ...“
Optionen

hallo Acader,

natürlich steht in meiner Sources Liste das mit dem wheezy main. dort findet er aber das paket nicht. Auch mit den Zusätzen contrib und non-free findet er es nicht.

die debian seite empfiehlt es sogar über synaptic zu installieren, nur dort in dem paketmanager hat er es leider nicht gefunden *hrhr*

Erst wie ich die Sources Liste um Sid erweiterte mittels

deb http://ftp.at.debian.org/debian unstable main 

dort hat er anstandslos das paket gefunden!

ich wollte halt nicht von der normalen debian seite was herunterladen und dann erst manuell entpacken.

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
fakiauso Alekom „hallo Acader, natürlich steht in meiner Sources Liste das ...“
Optionen
die debian seite


Ups, da habe ich nicht aufgepaßt, sondern bin von Mint/Ubuntu ausgegangen;-)

Laut Paketbeschreibung von Debian Wheezy soll es tatsächlich in main enthalten sein, das kannst Du mit apt-cache policy arandr prüfen.

http://packages.debian.org/wheezy/all/arandr/download

Möglicherweise hatte der Server gerade eine dünne Leitung, mir wird unter Wheezy die Version 0.1.6-1 aus dem stable und und die 0.1.7.1-1 aus dem unstable angeboten.
Das von arandr erstellte Script hast Du aber nicht in die Startprogramme eingefügt, um zu sehen, ob es dann geladen wird?
Das Hauptproblem von hansapark ist ja immer noch, dass sich die Reihenfolge nicht so einstellen lässt, dass der Monitor an VGA zuerst angesprochen wird.
Sonst spiele ich heute abend einmal mit meinem Schleppi und zwei Schirmen, nur muss ich da erst wieder etwas umfrickeln und ob sich das von meiner ollen Ati7500 im Schleppi auf die andere graka übertragen lässt, ist auch nicht klar.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Alekom fakiauso „Ups, da habe ich nicht aufgepaßt, sondern bin von ...“
Optionen

hallo fakiauso,

doch ich habe es den startprogrammen hinzugefügt!

hinzugefügt aus dem verzeichnis benutzername/.screenlayout

danach hab ich einen reboot gemacht um zu sehen ob es geladen wurde.

ja es wurde problemlos geladen!

ich verstehe nur nicht, warum der VGA zuerst angesprochen werden soll.

bei mir werden meine beiden monitore angesprochen, welchen sinn hat es welcher monitor zuerst angesprochen werden soll?

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
Alekom fakiauso „Ups, da habe ich nicht aufgepaßt, sondern bin von ...“
Optionen

die 0.1.7.1-1 hab ich eben von Sid

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
Acader Alekom „hallo Acader, natürlich steht in meiner Sources Liste das ...“
Optionen
natürlich steht in meiner Sources Liste das mit dem wheezy main

Keine Ahnung was da mit deiner Sources.list los ist. Man muß da nicht auf Sid gehen.

Schau mal:

dietmar@debian:~$ apt-cache policy arandr
arandr:
  Installiert:           0.1.6-1
  Installationskandidat: 0.1.6-1
  Versionstabelle:
 *** 0.1.6-1 0
        500 http://ftp.tu-chemnitz.de/pub/linux/debian/debian/ wheezy/main i386 Packages
        500 http://ftp.de.debian.org/debian/ wheezy/main i386 Packages
        100 /var/lib/dpkg/status
dietmar@debian:~$

MfG Acader

bei Antwort benachrichtigen
Alekom Acader „Keine Ahnung was da mit deiner Sources.list los ist. Man ...“
Optionen

ich habe es gestern paar mal über debian main versucht

immer wieder las ich das man das paket arandr nicht findet.

und bezüglich reihenfolge, sorry, er will den tv haben...versteh schon

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
fakiauso Alekom „ich habe es gestern paar mal über debian main versucht ...“
Optionen
ich habe es gestern paar mal über debian main versucht


Nachdem Debian bei mir auf dem Book installiert war, hatte ich auch oft Probleme mit dem Update-Server, ich habe dann einen der näheren Spiegel genutzt, sonst mußte ich teilweise die Paketdatenbank mehrmals neu laden, bis alle eingelesen waren. Vielleicht weichst Du auch auf einen anderen aus.

Beim Schleppi kann ich halt noch per Tastenkombination den Ausgabeschirm verändern, eine ähnliche wie hansaparks Konstellation kann ich nur im Livesystem am Kasten meiner Guten nachstellen, da ist eine Radeon HD drin, Download von Arch läuft gerade. Per arandr ist zumindest bei mir das Festlegen des primären Schirms nicht drin, sondern die laufen simultan.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Alekom fakiauso „Nachdem Debian bei mir auf dem Book installiert war, hatte ...“
Optionen

ich habe grad was entdeckt.

man kann unter den monitoreinstellungen auf der GUI durchaus den monitor primär einstellen. ich kanns aber nur momentan auf der GUI machen.

beschrieben ist die vorgangsweise unter Debian 7.3

Anwendungen -> Systemwerkzeuge -> Einstellungen ->Systemeinstellungen -> Monitore

Dort sieht man 2 Monitore, wenn man welche hat, wichtig ist das das Hakerl bei Bildschirme spiegeln entfernt ist.

Dann kann man die Monitore so positionieren wie man möchte.

Und jetzt das wichtigste wie man den bevorzugten Monitor als primären einstellt:

Man sieht einen schwarzen Balken über den jeweiligen Monitor, der kennzeichnet den primären. Das perfide ist jetzt, man muss die Maus so positonieren das aus dem Mauszeiger ein Finger wird, das geschieht wenn man mit dem Zeiger über den  Balken verweilt. Mit der rechten Maustaste drücken, halten und so kann man den schwarzen Balken verschieben. Auf Anwenden klicken und auf Diese Einstellungen beibehalten klicken. Voila.

Wenn man aber es wieder retour machen will, dann muss man das An ausschalten in dem man auf An klickt, dann springt der Balken wieder rüber und dann wieder auf Aus klicken, sodaß man den zweiten Monitor wieder hat und natürlich wieder auf Anwenden und Diese Einstellungen behalten klicken.

Ich hoffe ich konnte mich verständlich ausdrücken *g*

Leider ist das beim nächsten Reboot wieder vorbei, darum muss man es in eine Configdatei reinschreiben.

Wie das alles geht ist hier beschrieben:

http://linuxundich.de/ubuntu/drei-wege-den-primaren-monitor-unter-ubuntu-unitygnome-shell-oder-das-terminal-zu-bestimmen/

dort sind Bilder zu sehen, die alles leichter machen.

mfg Alekom

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
fakiauso Alekom „ich habe grad was entdeckt. man kann unter den ...“
Optionen

Der Link ist klasse und ich möchte fast meinen, dass die doppelte Konfigurationsorgie des Rätsels Lösung auch ohne den fglrx als Treiber ist für hansapark!

Das Lesezeichen habe ich mir jedenfalls gesetzt und Archi ist bereits auf Stick, dass muss jetzt noch auf ein Testbook, allerdings ebenfalls mit XFCE, denn mit meinem habe ich inzwischen mit Debian XFCE herumgedoktert und auch mit unserem TV und einem Monitor auf crunchbang von Stick. Gnome3 kann ich auf der Kiste abhaken (Pentium M 1.7, Intel 855 und 1GB RAM)
Dort ist das Verhalten aber wie bereits erwähnt so, dass beide Kisten gleichzeitig laufen mit einer HD4670 AGP und dem radeon, die ignoriert das wieder völlig.

Danke für die Mühe!

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Alekom fakiauso „Der Link ist klasse und ich möchte fast meinen, dass die ...“
Optionen

Hallo fakiauso,

gern geschehen.

Mich würde es sehr interessieren, ob der TE das Problem beseitigen kann.

mfg Alekom

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
hansapark Alekom „Hallo fakiauso, gern geschehen. Mich würde es sehr ...“
Optionen

Hallo.

Bei Gnome 3.10.1 sieht das anders aus, da ist kein schwarzer Balken mehr. Ich habe auch die monitors.xml bearbeitet, hatte das glaube auch schon geschrieben weiter oben. Und da habe ich auch ein Bild gepostet, wo man sieht, wie das jetzt aussieht.

Das Einstellen als "primär" ändert nicht die Nummerierung der Bildschirme. Es kann auch Monitor 2 = primär sein. Aber danke für die Mühe. Fürs erste geht es, so wie es jetzt grade ist. (kopieren der monitors.xml in die gdm Konfiguration, dadurch erscheint der gdm auf beiden Bildschirmen.) der genau befehl steht hier: https://bbs.archlinux.org/viewtopic.php?pid=1337221#p1337221

Ich werde mal abwarten, ob bald mal wieder updates kommen und ob die was beheben. Ich habe seitdem nämlich auch noch das Problem, dass ich keine Anwendungen in der Übersicht auf eine andere Arbeitsfläche ziehen kann. :(  (hab das im gnome bugzilla  gemeldet)

bei Antwort benachrichtigen
Alekom hansapark „Hallo. Bei Gnome 3.10.1 sieht das anders aus, da ist kein ...“
Optionen

hallo hansapark,

da bleibt mir nur ein wort übrig: verdammt.

schade das es nicht so "einfach" funktioniert. aber wenn das ein bug ist, dann ist das natürlich ein problem.

ich muss mal sehen unter welchem gnome ich eigentlich bin.

mfg Alekom

ps: schönen Tag trotzdem noch

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
Alekom Nachtrag zu: „hallo hansapark, da bleibt mir nur ein wort übrig: ...“
Optionen

hab jetzt geschaut unter gnome-session. dort wird mir angezeigt 3.4.2.1

beim laden des desktops schlägt aber gnome 3 fehl, weil meine hardware nicht mehr zeitgemäß ist, darum bin ich im ausweichmodus.

Alles hat seinen Sinn, auch das scheinbar Sinnlose, denn es gibt nichts ohne Sinn.
bei Antwort benachrichtigen
Acader Alekom „hab jetzt geschaut unter gnome-session. dort wird mir ...“
Optionen
hab jetzt geschaut unter gnome-session. dort wird mir angezeigt 3.4.2.1

In der Konsole gnome-shell --version eingeben ist einfacher.

MfG Acader

bei Antwort benachrichtigen
Acader hansapark „Monitor-Reihenfolge ändern“
Optionen
Ich würde gerne die Reihenfolge ändern, in der meine Monitore erkannt werden

An dieser Stelle nochmal meine Frage:

Warum ist das für dich eigentlich wichtig?

Die Auflösungen kannst du doch für jeden deiner Monitore separat einstellen.

Da ist es doch vollkommen "wurscht" wer als Nr.1 oder Nr.2 angezeigt wird.

MfG Acader

bei Antwort benachrichtigen
hansapark Acader „An dieser Stelle nochmal meine Frage: Warum ist das für ...“
Optionen

Es ging mir darum, dass der Bootvorgang auf dem falschen Monitor angezeigt wird. Also grub und gdm. Die waren auf dem TV. Also bei grub bin ich mir nicht mehr sicher, aber der gdm auf jeden Fall. Selbst wenn der TV ausgeschaltet war, wurde der nicht auf dem PC-Monitor angezeigt.

Somit musste ich den TV einschalten um etwas zu sehen, oder mich 'blind' einloggen.

Erst nach dem Login scheint die Gnome-Konfiguration zu greifen. Da kam die Idee, die Monitor-Reihenfolge zu ändern.

bei Antwort benachrichtigen
Acader hansapark „Es ging mir darum, dass der Bootvorgang auf dem falschen ...“
Optionen
Es ging mir darum, dass der Bootvorgang auf dem falschen Monitor angezeigt wird

Wenn du beide Monitore immer an hast ist das doch aber eigentlich egal.

Ansonsten sollte es aber immer mit dem aktiven gehen d.h. man sieht dann auch etwas.

Die Anleitung von Alekom siehe link sollte unter deiner ATI vielleicht auch gehen.

Probiere es doch einfach mal so aus und gebe dann hier ein Feedback.

MfG Acader

bei Antwort benachrichtigen
hansapark Acader „Wenn du beide Monitore immer an hast ist das doch aber ...“
Optionen

Ja. Ich habe meist aber nicht beide Monitore an. Die Anleitung.. da hatte ich doch schon drauf geantwortet.. Nichts für ungut.

mfg ,h

bei Antwort benachrichtigen
Acader hansapark „Ja. Ich habe meist aber nicht beide Monitore an. Die ...“
Optionen
Die Anleitung.. da hatte ich doch schon drauf geantwortet.

Ach ja, hatte ich doch glatt überlesen.

MfG Acader

bei Antwort benachrichtigen