Linux 14.850 Themen, 104.742 Beiträge

Nvidia-settings

dacard / 20 Antworten / Baumansicht Nickles

Ich habe mir vor 3 Tagen Debian installiert. Nun sitze ich hier und verzweifle so langsam.
Ich habe Nvidia-settings aufgerufen um den Treiber einzustellen bzw ihn zu aktivieren. Leider brauche ich dazu rootrechte.
Aso habe ich folgenden Befehl eingegeben Kdesu nvidia settings. Ergebnis: Ich habe trotzdem keine Rechte.
Also habe ich Dolphin mit rootrechten gestrtet mittels Kdesu dolphin.
Habe dann die xcon.org schreibrechte als root zugeordnet.
Kurzum ich bin nach wie vor keinen Deut weiter.

Mein OS ist Debian Squeeze mit KDE 4xxx

Da sich hier ein paar Debiananwender auf Nickles befinden wäre es schön wenn mir jemand bitte Schritt für Schritt erklären könnte wie ich weiter vorgehen muss.

PS: Langsam vergeht mir die Lust an Linux....

Wenn hier im falschen Forum dann bitte umkopieren. Danke

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
schoppes dacard

„Nvidia-settings“

Optionen

Hallo dacard,

ich bin mir sicher, dass die Debiankenner auf Nickles dir weiterhelfen können und werden.


PS: Langsam vergeht mir die Lust an Linux....

Bevor DAS passiert, solltest du Ubuntu 10.04 LTS oder 10.10 eine Chance geben.
Dabei brauchst du keine fremde Hilfe. ;-)

Grüße
Erwin

"Früher war alles besser. Sogar die Zukunft." (Karl Valentin)
bei Antwort benachrichtigen
DergroßeGuru dacard

„Nvidia-settings“

Optionen

Hi!

Kenne mich zwar mit Debian nicht besonders aus, aber versuche es mal mit nvidia-xconfig, welches wohl eventuell noch vorher installiert werden muss: apt-get install nvidia-xconfig

Be happy! DgG
bei Antwort benachrichtigen
dacard DergroßeGuru

„Hi! Kenne mich zwar mit Debian nicht besonders aus, aber versuche es mal mit...“

Optionen

Habe es genau so gemacht aber keine Änderung.

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
fakiauso dacard

„Nvidia-settings“

Optionen

Hallo

Die 3D-Treiber von Nvidia sind installiert?

Jetzt gibt es zumindest 2 Wege:

1. Öffne einen Schnellstarter mit Alt+F2 und gib dort kdesu nvidia-settings ein, dann sollte das root-Paßwort abgefragt werden und das Ganze mit root-Rechten laufen.

2. Öffne die Konsole, werde dort durch eingabe von su root und gib dort entweder nvidia-settings oder kdesu nvidia-settings ein.

fakiauso

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
dacard fakiauso

„Hallo Die 3D-Treiber von Nvidia sind installiert? Jetzt gibt es zumindest 2...“

Optionen

keine Änderung Habe eure Tipps ausgeführt, leider kann ich immer noch keine Einstellungen vornehmen.

Folgende Fehlermeldung:ERROR: The control display is undefined; please run `nvidia-settings --help` for usage Information.

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
fakiauso dacard

„keine Änderung Habe eure Tipps ausgeführt, leider kann ich immer noch keine...“

Optionen

Hallo

Starte auf der Konsole einmal glxinfo, dazu muß das Paket mesa-utils installiert sein.
Dann sollte eine Ausgabe kommen wie hier:

direct rendering: Yes
server glx vendor string: NVIDIA Corporation

Damit wäre zumindest der Nvidia-Treiber installiert, aber ich vermute fast, das hier nur der nv oder nouveau aktiv ist.

Allerdings habe ich mir auch nicht die Pakete von Debian installiert, sondern den Treiber von Nvidia direkt installiert und dann die xorg.conf automatisch einrichten lassen am Ende der Installation.

http://wiki.linuxgaming.de/index.php/NVidia_Treiber_Installation_%28Debian%29

Der Nachteil dieser Methode liegt darin, das bei Installation eines neuen Kernels der Treiber jedesmal frisch eingebunden werden muß.

fakiauso

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
dacard fakiauso

„Hallo Starte auf der Konsole einmal glxinfo, dazu muß das Paket mesa-utils...“

Optionen

Laut glxinfo ist der treiebr nicht installiert.??????????????
Hier die Ausgabe:name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
3 GLXFBConfigs:
visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Speicherzugriffsfehler

Dabei habe ich aber den DKM-Treiber von Debian installiert.

.

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
dacard fakiauso

„Hallo Starte auf der Konsole einmal glxinfo, dazu muß das Paket mesa-utils...“

Optionen

Sorry aber nun steh ich entgültig im Walde. Was zum Kuckuck ist das denn für eine komische Downloadmethode bei Nvidia ? So etwas habe ich noch nie erlebt.. Erstmal nur kauderwelch und dann stürtzt der Iceweasel dabei ab.

Also langsam aber sicher mache ich mich auf dem Weg zum Regal und installiere mir wieder Windows 7.
Mit Benutzerfreundlich ist es unter Debian ja noch immer nicht weit her.

Also nach Jahren wo Linux mit auf der Platte lag werde ich wohl doch wieder zu Win zurückgehen.
Ich habe keine Lust mehr Tage und Nächte lang an diesem sch.... Treiber rumzumachen....

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
fakiauso dacard

„Sorry aber nun steh ich entgültig im Walde. Was zum Kuckuck ist das denn für...“

Optionen

Hallo

Entschuldigung, das ich erst heute antworte, aber ab und an muß man ach schlafen;-)

Das mit Download ist "normal" und liegt nicht an Debian, vermutlich hast Du den FF zum herunterladen genutzt und der weiß mit einer *.run eben nichts anzufangen.
Dazu gehst Du nach dem Anklicken des Downloads, wenn sich diese komische Seite öffnet, auf Datei-->Seite speichern unter und speicherst das so ab, das klappt dann schon.
Anschließend geht es mit der Installation wie oben beschrieben weiter.

fakiauso

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
dacard fakiauso

„Hallo Entschuldigung, das ich erst heute antworte, aber ab und an muß man ach...“

Optionen

Hallo fakiauso
Habe deinen Rat beherzigt und es so genacht.
Nun besitze ich ein stabiles und sauschnelles Debian mit modernen Desktop.

Das mit dem Download von Nvidia war mir vöölig unbekannt und daher wußte ich damit nichts anzufangen.

Möchte mich dann bei dir erstmal recht herzlich bedanken für deine Hilfestellung und deine Zeit die du dir genommen hast.

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
Soulmann63 dacard

„keine Änderung Habe eure Tipps ausgeführt, leider kann ich immer noch keine...“

Optionen

Hallo dacard,

ich weiß nicht wie fit Du mit Linux bist, aber mit Debian anzufangen ist nicht sonderlich ratsam. Dies ist zumindest meine Meinung.

Warum?

Wie Du selbst bemerkst, ist es nicht leicht für einen Linux Zögling Debian richtig einzustellen. Man verliert leicht die Lust und gibt dann entnervt auf.
Schoppes hat Dir ja schon sein System genannt.
Nun würde ich Dir einfach zu Linux Mint raten. Lade dir eine Live CD runter und Teste diese einmal. Du wirst sehen, es ist einiges leichter und vieles schon mit an Board.

Überlege es Dir bevor Du Linux aus dem Fenster wirfst.

Gruß Soulmann

*_Du bist nicht Vergessen G P_*
bei Antwort benachrichtigen
schoppes Soulmann63

„Hallo dacard, ich weiß nicht wie fit Du mit Linux bist, aber mit Debian...“

Optionen

Hallo dacard,

ich kann mich den Worten von Soulmann nur anschließen:

ich weiß nicht wie fit Du mit Linux bist, aber mit Debian anzufangen ist nicht sonderlich ratsam. Dies ist zumindest meine Meinung.

Du hast dir mit Susi 11.4 (anderer Thread) und Debian nicht gerade einsteigerfreundliche Distributionen ausgesucht.

Wenn du wirklich in die Linuxwelt einsteigen willst, dann probiere doch die Distributionen, die auch als einsteigerfreundlich gelten:

Ubuntu und deren Derivate (z. B. Linux Mint, PinguyOS)

Grüße
Erwin

"Früher war alles besser. Sogar die Zukunft." (Karl Valentin)
bei Antwort benachrichtigen
dacard Soulmann63

„Hallo dacard, ich weiß nicht wie fit Du mit Linux bist, aber mit Debian...“

Optionen

Ich nutze Linux schon seit Jahren. Angefangen hat es mit Suse Linux 6.4 bis Suse 11.2.
Danach habe ichUbuntu 10.4 genutzt und war eigentlich sehr zufrieden, gerade was die Treiber-Einbindung anbelangt.
Aber leider hatte ich öfter Probleme mit dem Sound und dem Netwerkchip.
Deswegen habe ich mir gedacht ich steige auf ein sicheres und stabiles OS um, eben Debian mit dem KDE-Desktop.
Das ich unter Debian etwas mehr Hand anlegen muss als zb unter Ubuntu oder der Suse war mir von vornherein klar.
Ist ja auch kein Problem, bin ja schließlich mit MS-Dos und dem C64 groß geworden was den IT-Bereich angeht.
Aber das ich einmal dermaßen Ärger mit den NV Treiber unter Debian kriegen könnte hätte ich nicht gedacht.

Also ich bin kein Frischling mehr was Linux anbelangt. -:))

PS: Nö ich werfe Linux nicht aus dem Fenster. Ich stecke keinem Monopolist wie MS mehr Geld in dem Rachen. -:)

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
dacard Soulmann63

„Hallo dacard, ich weiß nicht wie fit Du mit Linux bist, aber mit Debian...“

Optionen

Keine Sorge Debian rennt nun so wie ich es mir gewünscht habe. Windows 7 kann nun weiter verstauben. -:))
zumindest auf meien Arbeitsrechner....

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
dacard Soulmann63

„Hallo dacard, ich weiß nicht wie fit Du mit Linux bist, aber mit Debian...“

Optionen

Werde Mint mal in der Vbox ausprobieren auch Mandriva mal anschauen, soll ja auch sehr benutzerfreundlich sein.

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
Index dacard

„keine Änderung Habe eure Tipps ausgeführt, leider kann ich immer noch keine...“

Optionen

Bei mir läuft Squeeze mit Gnome und ich habe 2 Terminals einen normalen und einen Root-Terminal am besten liest du dir das mal durch wiki.debian.org/NvidiaGraphicsDrivers

bei Antwort benachrichtigen
dacard Index

„Bei mir läuft Squeeze mit Gnome und ich habe 2 Terminals einen normalen und...“

Optionen

Das werde ich beherzigen und mich dann mal ordenlich einlesen.
auch dir vielen Dank

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
Acader dacard

„Nvidia-settings“

Optionen
Langsam vergeht mir die Lust an Linux

Nun mal ganz ruhig.

Bevor wir hier dein Problem angehen:

1.Welche Debian Version von hier wurde installiert ?

2.wurde nach der Installation die sources.list aktualisiert und anschließend ein System-Update durchgeführt ?

Deine sources.list sollte in etwa so aussehen:

http://www.nickles.de/user/images/32643/05.png

Als Spiegelserver kannst du auch einen Anderen nehmen.
Nach der Aktualisierung ist in den meisten Fällen der Graka Treiber automatisch aktiviert.
Sollte das nicht der Fall sein, nenne bitte deine Grafikkarte.
Falls diese Graka nemlich nicht unterstützt wird muß sie manuell installiert werden.

Wichtig:

Du solltest dich auch schon mal hier einlesen.


Nachtrag:

Mit Benutzerfreundlich ist es unter Debian ja noch immer nicht weit her

Da tust du dem Debian-System aber Unrecht, denn man muß nur wissen wo man anzufangen hat.



MfG Acader













bei Antwort benachrichtigen
dacard Acader

„ Nun mal ganz ruhig. Bevor wir hier dein Problem angehen: 1.Welche Debian...“

Optionen

@Arcader
Ich habe im Rechner die popelige Nvidia g210 stecken da mir die Ati Radeon 4870 vor einiger Zeit abgeraucht ist.
Als OS habe ich mir Debian Sqeeze Stable 6.01 runtergeladen.
Auch habe ich Updates durchgeführt mit apt-get update.
Dann habe ich die Source List nach deinen Vorgaben eingerichtet.
Anschlie0end wieder apt-get update ausgeführt.
Den Graka-treiber habe ich mir nach @fakiauso Ratschlag von der Hp von Nvidia runtergeladen und installiert.
Und nun habe ich ein stabiles und schnelles OS.

Also auch dir recht vielen Dank für dine Mühen bzw Hilfestellung.
Natürlich auch den anderen.

Back to the Roots, by by Linux. Ich liebe Win 8.1 Pro.
bei Antwort benachrichtigen
Acader dacard

„@Arcader Ich habe im Rechner die popelige Nvidia g210 stecken da mir die Ati...“

Optionen

Schön das es nun auch bei dir geklappt hat.
Wer Debian nutzt sollte auch immer stets mit etwas mehr Ruhe an die Sache gehen, denn automatisch hat diese
Distribution nun mal keine "Super-Kuh-Kräfte"

Ich habe im Rechner die popelige Nvidia g210

Diese Graka läuft unter Debian hervorragend.

Als OS habe ich mir Debian Sqeeze Stable 6.01 runtergeladen

Du weiß aber das es davon mehrere Ausführungen gibt (deshalb meine Frage)

Noch ein Satz zu deinen Nichtlinux-Spielen:

Beachte auch das es mehrere Wine-Versionen gibt siehe hier.
Die Neueste ist dabei nicht immer die Beste. Man muß es halt einfach ausprobieren.

Wenn du keine Fragen mehr hast diesen Thread bitte als gelöst markieren.



MfG Acader








bei Antwort benachrichtigen