Linux 14.794 Themen, 104.185 Beiträge

Hilfe - Suse7.3 im Windows LAN etc etc etc.. - frustrierter

Felix99 / 4 Antworten / Baumansicht Nickles

HAllo,
HAbe heut endlich mal wieder nen Linux installiert bekommen. Da ich bis jetzt immer irgendwo in Linux gescheitert bin und mich dann der Wille verlasssen hat oder sich das System selbst zerstört hat möchte ich nun endlich mal nen funktionnierendes System haben. Mit FLI4L kenn ich mcih ja so\'n bissle aus und so kleinigkeiten weiss ich auch.

Mein HAutproblem ist folgendes :
- Der Rechner befindet sich im LAN - IP: 192.168.0.99 - Der linuxrechner soll auf anderen Rehnern die Windowsfreigaben sehn zugreifen und sonstwas machen koennen , und via unserem DSL Server 192.168.0.1 ins Internet - Doch hier verweigert das Linux den Dienst - Host not found- hab bei der netzwerkkarte unter Routing hiess das glaub cih als Gateway den 192.168.0.1er als GAteway eingestellt.- NIX- So da ich keinen Normalen Telefonanschluss ahbe würd ich ahlt doch gerne mal darüber ins web und im weiterne später mal nen FTP& Webserver sowie vielleicht dieses ICECAST laufen alssen.

Wie gesagt hauptproblem is- Ich muss via 192.168.0.1 ins netz. der se4rver hat keinen proxy sodass ich unter windows auch nur DNS & GAteway auf 192.168.0.1 gestellt hab.

Bitte bitte was muss ich installieren , einstellen usw damit ich ins web komme und was muss ich wegen den Windows freigaben machen - sprich was anschalten /einstellen damit ich auf meinem Windowsrechner z.B. meine MP3\'S hören kann ?

Dank IM Voraus

- In hoffnung bald endlich mal nen PC mit "Linux running " zu haben :-)

felix

bei Antwort benachrichtigen
Kirin Felix99

„Hilfe - Suse7.3 im Windows LAN etc etc etc.. - frustrierter“

Optionen

Du musst folgendes tun:
1. Schreiben und gleichzeitig dabei gucken, dann kommen nicht wirklich so viele Rechtschreibefehler in dein Thread.
2. Hast du dem Linuxrechner einen DNS(Nameserver) Eintrag verpasst? Wenn nicht, dann kann er auch nix finden.
3. hast du auf dem Server eine Internetfreigabe oder ähnliches Installiert, was Masquerading oder NAT macht?
4.Wenn du von Winrechner auf den Linuxrechner zugreifen willt, schau im Archiv mal unter Samba nach, da wirst du einige finden.
5. Nimm als DSL-Server einen Linuxrechner :)

Grüße
Kirin

bei Antwort benachrichtigen
Felix99

Nachtrag zu: „Hilfe - Suse7.3 im Windows LAN etc etc etc.. - frustrierter“

Optionen

Ja du hast recht, aber normal klappt das mit dem "nicht hinschauen" - nein schaue nat. mal hin aber ich hab gerade ne neue Tastatur bekommen und da passiert sowas . Muss mich erst umgewöhnen.:-)

Also der DSL_router läuft momentan noch unter winNT4 mit sygate . bald aber FLI4L. Hab ich zuhause bei den Eltern als ISDN-XXL-Flatrateserver laufen.- wennd as Ding einal läuft dann läuft der und meine Eltern kommen sogar damit klar:-)
Zurück zu meinem Problem .
Irgendwie nachdem ich dann nochmal alles abgegrast hab. Hab ich son tool gefunden was mir die Freigaben meines Winrechners angezeigt aht - Bis zu den Dateien kam ich aber leider nicht.Der will die Verzeichnisse nicht mounten. SMBppp - kann das sein ?- hab die Kiste grade ausgemacht. Irgendwas von Fehler eins .

Pingen kann ich alle Rechner im LAN aber ins internet gehts nicht.

Kannst Du mir genau sagen wo ich im YAST/YAST2 was genau einstellen muss ?
Hier die aktuellen Windowseinstellungen (auf der kiste läuft neben Suse 7.3 auch noch Winxp):

Rechnername: Felix_2_linux
IP:192.168.0.99
IP des servers der mir das DSL bereitstellt via Sygate .( unter Win nur DNS & GATEWAY angegeben): 192.168.0.1

Was muss ich dafür nun wo unter dem Suse einstellen ?

Masquerading oder NAT wird die windows Kiste wahrscheinlich nicht koennen oder ?

Ganz vielen Dank

felix

bei Antwort benachrichtigen
neanderwix Felix99

„Ja du hast recht, aber normal klappt das mit dem nicht hinschauen - nein schaue...“

Optionen

Ich kann Dir leider nicht sagen, wie man das mit dem Yast1/2 erledigt, weil ich das Teil ungern anfasse, aber -wie schon gesagt- einen Nameserver solltest Du schon eintragen. In meinem Falle sind es die von T-Online :

#Einträge in /etc/resolv.conf.
search ralph.seltsam
nameserver 194.25.2.129
nameserver 217.237.159.193

Du solltest natürlich DEINE Werte eintragen, aber als Muster mag das taugen.
Zu Samba : Du hast sicher den KDE installiert ? Rufe den Konqueror auf und gib' als Adresse mal folgendes ein : smb://IP_des_Windowsrechners.

Gute Infos kriegst Du auch auf der SuSE-HP in der Supportdatenbank und bei Google.

bei Antwort benachrichtigen
Felix99 neanderwix

„Ich kann Dir leider nicht sagen, wie man das mit dem Yast1/2 erledigt, weil ich...“

Optionen

Hallo ich danke Allen ganz herzlich für die Tipps.

Die resolv.conf hat's gebracht !!!! Stand nur "domain 192.168.0.1" drin. als ich dann die 2 Nameserver dazugetragen habe funzte es dann perfekt ( haben ja hier auch t-dsl)
Mit dem SMB:// das klappt auch prima .- Irgendwie einfach- man muss halt nur wissen wie :-)

Jetzt werd ich noch was Linux rumspielen ( ICQ usw ans laufen bringen und Opera installieren und mich langsam an nen FTP server und Webserver ranmachen :-)


Danke nochmal ganz herzlich!!!

felix

bei Antwort benachrichtigen