Datenträger - Festplatten, SSDs, Speichersticks und -Karten, CD/ 19.453 Themen, 107.991 Beiträge

S-ATA und IDE Platte --> Laufwerkszuordnung

vnvrum / 7 Antworten / Baumansicht Nickles

Hallo,

ich habe im System:
2 IDE Controller
1 S-ATA Controller.

Auf der S-ATA Platte das OS installiert. OK.

Da ichs ja von Win gewohnt bin, dass es die Partion kaputt macht, wenn mit falschen MountingPoints zugegriffen wird, das weiss ich ja schon ein paar Jahre. Also überschreibe ich bei jedem Booten den HKEY_LOCAL_MACHINE\\SYSTEM\\MountedDevices und setz es auf die Daten der S-ATA Platte.
Aber: Ich möchte an den IDE Ports Wechseldisks betreiben und nun schieben sich die LW-Buchstaben der IDE Platten immer zwischen die LW der S-ATA Platte.
Wie kann ich das abstellen? Möchte ja mit dem Sync-Tool die Platten "spiegeln".

bei Antwort benachrichtigen
m. mann vnvrum

„S-ATA und IDE Platte --> Laufwerkszuordnung“

Optionen

Das Problem mit S-ATA und IDE im Parallelbetrieb kann ich überhaupt nicht nachvollziehen, dass sich da etwas zerschiesst umso weniger:

S-ATA: WD Raptor
IDE 1: Maxtor 120GB
IDE 2: Hitachi 160GB

kein Problem mit Partitionierung und CO. Da hast du einen anderen Fehler im System

bei Antwort benachrichtigen
vnvrum m. mann

„Das Problem mit S-ATA und IDE im Parallelbetrieb kann ich überhaupt nicht...“

Optionen

Hallo,
danke für die Infos.

Nochmals folgendes, hoffe diesmal klarer:

Ich möchte: 1 SATA Platte (2 und mehr Partitions) mit OS drauf. an die IDE 4 andere Platten (z.B. jeweils 1 Partition).
Im Windows Explorer (unter Linux kein Problem) möchte ich dann sehen:
c:\ 1. Partition der SATA
d:\ 2. Partition der SATA

e:\.. alle anderen IDE Platten.

Ich bekomme immer die IDE Platten zwischen die 1.Partition und 2. Partition der SATA geschoben.

Wie kann ich das erreichen? Im BIOS kann ich auch nicht viel umstellen....
Unter Windows mit Computerverwaltung umreihen der LW Buchstaben hilft mir nicht weiter, da ich ca. 30 Wechseldisks habe....

Gruss
vnvrum

bei Antwort benachrichtigen
nemesis² vnvrum

„S-ATA und IDE Platte --> Laufwerkszuordnung“

Optionen

So ein ähnliches Problem habe ich auch.

Die Buchstabenneuordnung - entgegen denn sonst üblichen Regeln - wird bei dir möglicherweise auch vom BIOS gemacht. Bei mir hängt das von der BIOS-Version ab (=> auch keine effektiv günstige Lösung).

Falls möglich, stelle mal S-ATA (0) als Prim. Master im BIOS ein (wenn es die Option gibt).

Wenn du Pech hast, bringt das auch nichts. Du müßtest das BIOS der Controller für die Wechselplatten deaktivieren (geht manchmal bei RAID-Controllerkarten) und die Platten dann von Windows erkennen lassen. Das reinschieben der anderen Buchstaben geschieht sicher auf BIOS-Ebene.

Den gleichen Zweck erfüllt eventuell auch, alle Ports für die Wechselplatten im BIOS auf "none" einstellen und die Platten dann von Windows erkennen lassen - falls es so unter XP funktioniert.

Wie sieht es aus, wenn du von CD/Floppy bootest? Hast du dann "normale" Buchstabenverteilung?

bei Antwort benachrichtigen
Borlander vnvrum

„S-ATA und IDE Platte --> Laufwerkszuordnung“

Optionen
Da ichs ja von Win gewohnt bin, dass es die Partion kaputt macht, wenn mit falschen MountingPoints zugegriffen wird, das weiss ich ja schon ein paar Jahre.
Also von solchen Probleme ist mir nichts bekannt...
(Ich mache übrigens regelmäßig Warm-Swaps (Computer nur im Ruhezustand = Strom aus, RAM auf Platte) - wenn ich da Platten wechsle gibt es keine Probleme...)

Also überschreibe ich bei jedem Booten den HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices und setz es auf die Daten der S-ATA Platte.
Und was genau sollte das jetzt bringen?


Also ich kann das ganze Problem nicht ganz nachvollziehen, bei fest eingebauten Platten ändern sich die LW-Buchstaben normalerweise nicht sofern die Platten immer drin sind...

Platten die nur gelegentlich drin hängen schnappen sich dann einfach den ersten freien - sofern der nicht schon durch eine "feste" belegt ist...


Gruß
Borlander
bei Antwort benachrichtigen
vnvrum Borlander

„ Also von solchen Probleme ist mir nichts bekannt... Ich mache übrigens...“

Optionen

Hallo,

also ich denke das Problem kommt daher, das Win so doof ist und den S-ATA Controller einfach als letztes berücksichtigt (glaube ich mal, aber im Bios ist es auch schon als IDE 5 aufgeführt, natürlich reihe ich bei der Bootreihenfolge die S-ATA Platte vor....) man siehts in der Computerverwaltung.

Zur Info: Auch windows erkennt die Partitions nur am Mounted Devices Point. Da ist die Konfiguration der LW und ihre ID Kennung drinnen. Das war auch bei XP (vor SP1) schon immer das Problem, wenn man einige Platten hat (also mehr als 32 Einträge enthalten sind) dann zerstört Win XP die Partions Infos (egal ob NTFS, FAT).

"Platten die nur gelegentlich drin hängen schnappen sich dann einfach den ersten freien - sofern der nicht schon durch eine "feste" belegt ist... "


--> Stimmt "eigentlich". Aber ich habe ja die 2. Partion der S-ATA Platte auf D: hängen, warum taucht dann, wenn ich die Wechseldisk am IDE 0 Port reinhänge die 1. Partition der Wechseldisk auf D: auf....? --> Wäre ja belegt....

Und das war die Frage. Wie kann ich eben festschreiben, dass die LWBuchstaben der S-ATA Platte so bleiben, wie ichs eingestellt habe?

Gruss
und erstmals Dank für eure Infos.

vnvrum

bei Antwort benachrichtigen
Borlander vnvrum

„Hallo, also ich denke das Problem kommt daher, das Win so doof ist und den S-ATA...“

Optionen
also ich denke das Problem kommt daher, das Win so doof ist und den S-ATA Controller einfach als letztes berücksichtigt
Also bei mir läufts Problemlos obwohl die SCSI-Platte (Systemplatte) erst nach den IDE-Platten aufgeführt wird...

Zur Info: Auch windows erkennt die Partitions nur am Mounted Devices Point. Da ist die Konfiguration der LW und ihre ID Kennung drinnen.
Ist mir alles bekannt...

Das war auch bei XP (vor SP1) schon immer das Problem, wenn man einige Platten hat (also mehr als 32 Einträge enthalten sind) dann zerstört Win XP die Partions Infos (egal ob NTFS, FAT).
Davon lese ich heute zum ersten mal - hast Du genauer Tiefergehende Quelle dafür?

warum taucht dann, wenn ich die Wechseldisk am IDE 0 Portbild reinhänge die 1. Partition der Wechseldisk auf D: auf....? --> Wäre ja belegt....
Existierte diese Partition denn schon bevor irgendeine IDE-Platte dran hing?


Zum Abschluß noch eine wohl total bekloppte Idee, die ich hier nur der Vollständigkeithalber erwähnen möchte und zu deren Praxistauglichkeit auch keine näheren Angaben machen kann:
Die Wechselplatten alle in ein NTFS-Verzeichnis mounten und diesen per Batch mit Subst einen LW-Buchstaben zuweisen ;-)


Gruß
Borlander
bei Antwort benachrichtigen
nemesis² vnvrum

„S-ATA und IDE Platte --> Laufwerkszuordnung“

Optionen

@Borlander

Dieses Problem gibt es wirklich, sei froh, daß du noch nicht damit konfrontiert wurdest.

@vnvrum

Wenn du von S-ATA bootest, ist das auch die 1. Platte ( => C: ) und der Rest kommt hinterher - eigentlich. Windows ist hier unschuldig, da das Board-BIOS von sich aus die Partitionen der weiteren Platten mittenrein schiebt - unabhängig vom OS (bei W98/DOS genau wie XP).

Hast du schon mal von CD gebootet?

Bei mir tritt selbiges auf: Bootplatte prim. Master, Zweitplatte prim. Slave und Wechselplatten am RAID-Controller. Wird von Platte gebootet, schieben sich die Laufwerke der Wechselplatten vor die Laufwerke der Zweitplatte.

Wird dagegen von CD gebootet => normale Buchstabenverteilung nach DOS-Regeln, ebenfalls wenn das RAID-BIOS deaktiviert ist. Das Board-BIOS kann dann keine Buchstaben für die Wechselplatten reinschieben, da es diese noch gar nicht erkennen kann.

Anderungen der Bootsequenz (1. HDD; 2. HDD; RAID-C. und auch sämtliche anderen Kombinationen) hilft leider nicht.

Ich gehe davon aus, daß es sich hier um eine spezielle Funktion im BIOS handelt, die möglicherweise das Booten von anderen Platten erleichtern soll. Leider bringt das in der Praxis aber nichts als großen Ärger.

Was für ein Board hast du eigentlich?

bei Antwort benachrichtigen