Windows 7 4.504 Themen, 43.202 Beiträge

USB-Device per DEVCON en/dis-abeln

Hardy© / 3 Antworten / Baumansicht Nickles

der VICE64 (Commodore Emulator) meldet beim Start immer diesen Fehler:

es liegt daran, daß ich 3 Speicherkartenleser und eine USB-Floppy ohne Medium am PC habe. Wenn diese Geräte disabled sind, läuft alles.

Nun ist es recht mühsam, daß im Gerätemanager einzeln zu machen und am Ende wieder rückwärts. Man kann das wohl als batch mit dem Befehl DEVCON machen und sich das dann als Icon auf den Desktop legen.

Leider bekomme ich die Abmeldung nicht hin, also zB für die 3,5" Diskette zeigt mir der Befehl

DEVCON64 status @USB\VID_054C* das zwar korrekt an:

USB\VID_054C&PID_002C\7&2FEC8E12&0&6
Name: Sony USB-Diskettenlaufwerk
Driver is running.
1 matching device(s) found.

aber ein disable bekomme ich irgendwie nicht zustande.

ich verwende Win7x64 und habe die devcon64.exe im Pfad G:\DEVCON\

vielleicht kann mir jemand helfen.

Gruß Hardy©
bei Antwort benachrichtigen
dirk1962 Hardy©

„USB-Device per DEVCON en/dis-abeln“

Optionen

Hallo Hardy,

aber ein disable bekomme ich irgendwie nicht zustande.

Welche Fehlermeldung gibt der Befehl zurück?

Gruß
Dirk

Das Leben beginnt auf alle Fälle - in einer Zelle ... und manchmal endet's auch bei Strolchen, in einer solchen. (Heinz Erhardt)
bei Antwort benachrichtigen
Hardy© dirk1962

„Hallo Hardy, Welche Fehlermeldung gibt der Befehl zurück? Gruß Dirk“

Optionen

wenn ich eingebe:

devcon64 -r disable "@USB\VID_054C&PID_002C*"

kommt als Fehler: Disable failed No matching device found 

obwohl er es ja zuvor gefunden hatte.

Das ist inzwischen aber schon alles hinfällig, denn ein wesentlich einfacher Befehl ist dies hier:
https://www.uwe-sieber.de/drivetools.html

damit ist das Abmelden auch überhaupt kein Problem aber neues Problem:

Nun will man am Ende der VICE-Sitzung die USB-Laufwerke auch wieder einschalten und das genau geht nämlich nicht mehr. Man kann immer nur den übergeordneten USB-HUB neu starten was aber nicht geht, wenn dort andere aktive USB-Geräte angemeldet sind. Am Ende hilft nur ein kompletter Kaltstart.

War das doch früher einfach, als es noch Hardwareprofile gab, die aber mit WinXP abgeschafft wurden....

Gruß Hardy©
bei Antwort benachrichtigen
Alpha13 Hardy©

„USB-Device per DEVCON en/dis-abeln“

Optionen
bei Antwort benachrichtigen