Windows 7 4.407 Themen, 42.084 Beiträge

Win7 umgezogen auf SSD, Boot Lkwk jetzt :G

Hardy© / 15 Antworten / Baumansicht Nickles

Habe eine SSD zusätzlich eingebaut und die Win7 x64 Partition darauf gecloned.

Die alte HD bleibt drin, BootPartition ist auf der HD Lfwk C:\

Das geclonte Win7 wird auf lange Sicht zum Standard. Wie kann ich diese Partition in C:\ändern?

unter Windows ist der Laufwerksbuchstabe nicht änderbar und ausblenden geht auch nicht.

Ich befürchte, daß meine Programme nicht ordnungsgemäss starten wenn die jetzt auf G:\ liegen.

Gruß Hardy©
bei Antwort benachrichtigen
Hardy©

Nachtrag zu: „Win7 umgezogen auf SSD, Boot Lkwk jetzt :G“

Optionen

macht ja wohl auch kein Unterschied, welches Lfwk das primäre ist. C:\ ist immer die Startpartition, richtig? Aber einige Installationen haben ja eine versteckte vorgeschobene kleine Partition mit dem Bootloader drauf. Die Hab ich in meinem System aber nicht.

Nachträglich kann man das sicher nicht noch so hinbiegen?

Gruß Hardy©
bei Antwort benachrichtigen
Alpha13 Hardy©

„macht ja wohl auch kein Unterschied, welches Lfwk das primäre ist. C: ist immer die Startpartition, richtig? Aber einige ...“

Optionen

https://tipps.computerbild.de/software/windows/windows-7-bootloader-reparieren-so-gehts-525169.html

macht man da mit nur der SSD angeschlossen und danach schließt man die HDD wieder an und stellt die SSD fest im Bios als Bootlaufwerk ein oder wählt die SSD per Taste beim Starten der Kiste im Bootmenü aus .

Dann läuft das normalerweise auch.

Wenn man richtig klont muß man übrigens nur die SSD im Bios als Bootlaufwerk einstellen und richtig klonen ist da niemals nur die W7 Partition zu klonen!

Zudem gibts mit G:\ statt C:\ auf der SSD natürlich viel Ärger...

bei Antwort benachrichtigen
Max Payne Hardy©

„Win7 umgezogen auf SSD, Boot Lkwk jetzt :G“

Optionen

Wie hast Du die geklont? Wenn Du die gesamte Platte geklont hast, befindet sich doch auch die Startpartition auf der SSD.

Im BIOS musst Du anschließend die SSD als Bootplatte einstellen.

The trouble with computers is that they do what you told them – not necessarily what you wanted them to do.
bei Antwort benachrichtigen
Hardy© Max Payne

„Wie hast Du die geklont? Wenn Du die gesamte Platte geklont hast, befindet sich doch auch die Startpartition auf der SSD. ...“

Optionen

nö, hab nur die Boot-Partition, also C:\ geclont mit miniTool Partition Wizard 9 und dann mit EasyBootCD einen zusätzlichen Eintrag ins Boot-Menü erstellt.

Komplette HD passt nicht auf die SSD.

Problem:

Die neue SSD befindet sich in einem DVD-Caddy den ich wahlweise anstatt meiner BR-verwenden möchte. Allerdings wird die BR max. 1x im Monat gebraucht.

Ich möchte also am liebsten den Bootloader fest auf der immer eingebauten HD haben.

Seltsam das das genau so bei meinem Desktop PC funktioniert hatte nur jetzt nicht beim Laptop.

Dadurch das G:\ jetzt das OS beherbergt und C:\ (die ursprungs Partition) auch im System ist, funktionieren die Pfadangaben noch, aber es wird dann eben nicht auf der schnellen SSD gearbeitet. Windows Neubewertung des Leistungsindex bringt auch keine Verbesserung.

Also so ist das noch Murcks.

Gruß Hardy©
bei Antwort benachrichtigen
Alpha13 Hardy©

„nö, hab nur die Boot-Partition, also C: geclont mit miniTool Partition Wizard 9 und dann mit EasyBootCD einen ...“

Optionen

"Ich möchte also am liebsten den Bootloader fest auf der immer eingebauten HD haben."

Dann ist auch absolut immer C:\ auf der HDD!!!

bei Antwort benachrichtigen
Hardy© Alpha13

„Ich möchte also am liebsten den Bootloader fest auf der immer eingebauten HD haben. Dann ist auch absolut immer C: auf ...“

Optionen

aber beim Desktop ist es nicht so. da habe ich Vista auf der Boot-Partition. Nach der Installation von Win7 hat Vista einen anderen Laufwerksbuchstaben bekommen und Win7 war auf C:\ und nach dem Einbau einer SSD konnte ich ganz leicht die neue SSD mit Buchstabe C:\ einrichten.

Alles immer Win7 x64. Ich experimentiere mal mit dem BIOS Bootloader....

Aber wir sind uns soweit einig daß die Startpartition immer C:\ heissen soll?

Gruß Hardy©
bei Antwort benachrichtigen
Alpha13 Hardy©

„aber beim Desktop ist es nicht so. da habe ich Vista auf der Boot-Partition. Nach der Installation von Win7 hat Vista einen ...“

Optionen

Äpfel und Birnen und Windows vergibt C:\ immer automatisch und das sollte man in Windows auch nie ändern!

Was man da macht habe Ich dir gesagt und machs oder auch nicht...

Übrigens würde Ich da aus vielen Gründen nur mit der SSD angeschlossen W7 neu installieren und dann über das Bootmenü des Bios von der SSD oder HDD starten, ist die mit Abstand beste Option und dann ist auf der SSD auch immer C:\...

bei Antwort benachrichtigen
Hardy© Alpha13

„Äpfel und Birnen und Windows vergibt C: immer automatisch und das sollte man in Windows auch nie ändern! Was man da macht ...“

Optionen

ja kann ich machen, aber ich will kein nacktes Win7 (Neuinstallation) auf der SSD sondern mein vorhandenes umziehen.

Gruß Hardy©
bei Antwort benachrichtigen
Hardy©

Nachtrag zu: „aber beim Desktop ist es nicht so. da habe ich Vista auf der Boot-Partition. Nach der Installation von Win7 hat Vista einen ...“

Optionen

also irgend etwas läuft schief. WEnn ich die SSD mit der geclonten Win7 Partition (Primär, sichtbar, aktiv) als einziges Lfwk an Stelle der HD einbaue und die Windows Reperatur laufen lasse, sollte danach normalerweise diese Partition starten, das tut sie nicht, es kommt nur der Cursor.

Vielleicht fange ich nochmal von vorne an.

Hardware: 2GB HD + DVD Schacht mit BR-Lfwk oder alternativ 480GB SSD

OS: Win7x64

1. Primäre Partition beinhalter den Bootloader und das zu clonende Win7

Ziel: wahlweise Verwendung des OS gebootet von der HD oder SSD.

Im jeweiligen Fall sollte die unbenutzte Partition unsichtbar (oder Lfwk A:\) sein und Windows sich auf dem Laufwerksbuchstaben C:\ befinden.

Hab mehrer Cloning Apps oder Acronis zur Auswahl.

Wie mache ich es richtig?

Oder kann es sein, daß mein Laptop nicht von einer SSD booten kann?

Ein Sache ist noch auffällig: Hab auf der HD diese Acronis F11 Funktion installiert, die beim Booten erscheint.

Dies kann natürlich nicht beim booten von der SSD funktionieren dann Acronis befindet sich dann ja an einem anderen Pfad.

Gruß Hardy©
bei Antwort benachrichtigen
Alpha13 Hardy©

„also irgend etwas läuft schief. WEnn ich die SSD mit der geclonten Win7 Partition Primär, sichtbar, aktiv als einziges ...“

Optionen

"Dort geben Sie nacheinander die Befehle „bootrec /fixmbr“, „bootrec /fixboot“ und „bootrec /rebuildbcd“ ein."

Wirklich gemacht und auch mit diskpart die SSD auf aktiv gesetzt???

Einfach nur die Reparatur laufen lassen ist da absolut für die Tonne!

bei Antwort benachrichtigen
Hardy© Alpha13

„Dort geben Sie nacheinander die Befehle bootrec /fixmbr , bootrec /fixboot und bootrec /rebuildbcd ein. Wirklich gemacht ...“

Optionen

also um sicher zu gehen, daß es überhaupt und prinzipiell funktioniert hab ich die SSD platt gemacht, als einziges Lfwk eingebaut und lasse gerade eine Win7 Neuinstallation laufen. Am Ende will ich aber mein aktuelles Win7 dort haben und kein nacktes...

Vielleicht kann ich dann im Anschluss einfach die Partitionen austauschen?

Gruß Hardy©
bei Antwort benachrichtigen
Alpha13 Hardy©

„also um sicher zu gehen, daß es überhaupt und prinzipiell funktioniert hab ich die SSD platt gemacht, als einziges Lfwk ...“

Optionen

https://www.tecchannel.de/a/zerstoerten-bootloader-von-windows-7-reparieren,2026656

wenn du es auch mit den Bildchen nicht hin bekommst wird das normalerweise nix mit dem behalten deiner W7 Installation...

bei Antwort benachrichtigen
Hardy©

Nachtrag zu: „also um sicher zu gehen, daß es überhaupt und prinzipiell funktioniert hab ich die SSD platt gemacht, als einziges Lfwk ...“

Optionen

also die Testinstallation hat funktioniert. Der Leistungsindex hat sich bei der SSD seltsamerweise nicht verbesser (5,9) Ich habe auf der SSD jetzt

eine 100MB System-reservierte Partition (sicher mit dem Win7 Bootloader)

eine 447GB NTFS Partition mit der Win7 Installation.

Kann ich damit etwas anfangen um mein Problem zu lösen?

Achso: Booten vom BIOS Bootmenü in die neue Installation geht.

Gruß Hardy©
bei Antwort benachrichtigen
Alpha13 Hardy©

„also die Testinstallation hat funktioniert. Der Leistungsindex hat sich bei der SSD seltsamerweise nicht verbesser 5,9 Ich ...“

Optionen

Da ist alles gesagt!

EOD

bei Antwort benachrichtigen
Hardy© Alpha13

„Da ist alles gesagt! EOD“

Optionen

"EOD" wenn Du das sagst, ich bin allerdings anders zum Ziel gekommen.

1. Von meiner Test-Installation alles gelöscht ausser die kleine System-reservierte Partition.

2. Mit Acronis ein Image meiner Ursprungs Partition von HD angelegt

3. Image recovered auf die SSD

das war's, Leistungsindex  der Festplatte jetzt 7,2 und die geclonte Win7 Partition wenn man vom BIOS-Bootmenü startet ist auf C:\

so wollte ich es haben Win7 ist mit allen Einstellungen und Programmen komplett auf der SSD.

Kann jetzt im BIOS noch die Bootreihenfolge ändern, dann wird by default von der SSD gestartet und nur wenn die nicht vorhanden ist von der HD...

System läuft gefühlt 10x schneller.

Gruß Hardy©
bei Antwort benachrichtigen