Archiv Server-Windows 15.877 Themen, 54.317 Beiträge

kaputte zeichen im dos programm unter win2000

cromaxxx / 6 Antworten / Baumansicht Nickles

Ich benutze oft ein DOS-Datenauswertprogramm (TurboLab). Unter Win2000 sind allerdings sämtliche normalen Zeichen (Schrift) unlesbar (irgendwelche Sonderzeichen-Hieroglyphen). Dieser Fehler trat unter Win98 nur mit ATI-Grafikkarten auf und war dort unlösbar. Kennt jemand ähnliche Probleme mit DOS-Programmen unter w2k und/oder ihre LÖSUNG??? Mit Win98 auf demselben Rechner ging das noch!
System: Win2000, ASUS P5A/B, ELSA Erazor II

Jensen

(Anonym) cromaxxx

„kaputte zeichen im dos programm unter win2000“

Optionen

Ich habe da gleiche Problem. Bei allen selbst geschriebenen Programmen werden die Sonderzeichen (ÜÖÄß...) nicht richtig dargestellt. Wie kann man das korrigieren. Ab schon alle möglichen Spachunterstützungen von Windows 2000 installiert. Was kann man dagegen machen ??

cromaxxx (Anonym)

„Ich habe da gleiche Problem. Bei allen selbst geschriebenen Programmen werden...“

Optionen

Gegen Dein Problem (falsch dargestellte Sonderzeichen) hilft eine kleine Veränderung der registry, win2000 benutzt nämlich die falsche Codepage (850 statt 437). Hilfe hierzu findet sich auf www.winfaq.de. Bei mir werden allerdings ALLE Zeichen nicht richtig dargestellt, hier hat der registry-Eintrag leider nichts gebracht.

(Anonym) cromaxxx

„kaputte zeichen im dos programm unter win2000“

Optionen

Hab das mit dem Registry-Eintrag ausprobiert, aber auch bei Codepage 437, werden alle Sonderzeichen falsch dargestellt. Gibt es denn keine Möglichkeit, die richtig auf den Schrim zu kriegen. KANN DOCH NICHT WAHR SEIN. So ein sündhaft teures Window$ und keine Sonderzeichen.

(Anonym) cromaxxx

„kaputte zeichen im dos programm unter win2000“

Optionen

Wie startest du das Programm? Über die Eingabe-Aufforderung? Damit wird cmd.exe gestartet; versuch es mal mit command.com im system32-Verzeichnis, dort befindet sich auch die config.nt, in der die Einstellungen einer config.sys vorgenommen werden, so auch Zeichensatz usw.

cromaxxx (Anonym)

„Wie startest du das Programm? Über die Eingabe-Aufforderung? Damit wird cmd.exe...“

Optionen

Ich habe versucht, das Programm über die Eingabeaufforderung und über eine Verküpfung (pif) zu startetn, Ergebnis ist dasselbe. Was meinst du mit command.com versuchen? Wenn ich die aufrufe, bekomme ich ein Eingabeaufforderungsfenster. Von dort aufgerufen bringt das Programm nach wie vor nur Mist auf den Schirm. Welche Einstellungen sollten in der config.nt vorgenommen werden?

cromaxxx

Nachtrag zu: „kaputte zeichen im dos programm unter win2000“

Optionen

Dies ist auf "Speicherplatzeinsparungen" im BIOS zurückzuführen: Um VBE-Funktionen zu implementieren, flog der 8x14 Font ´raus und der wird offenbar von einigen Programmen verwendet. Es gibt einen Fix (Fix8x14), der eine korrekte Anzeige im Vollbildmodus ermöglicht, soll angeblich auch bei ATI-Karten funktionieren: http://www.uwe-sieber.de/util.html. Neuere BIOS-Varianten sind tw. größer, 8x14-Font dort wieder drin. Warum das Problem bei Win9x nicht, unter windows 2000 jedoch auftritt weiss ich nicht. Unter win2k meckert ein VBE-Treiber, mit dem man Bildschirmwiederholfrequenzen einstellen kann (Eingabeaufforderung), dass meine Grafikkarte (ELSA Erazor II, unterstützt VBE 3.0 !!!) kein VBE 3.0 unterstützt, unter win9x (Dosfenster)geht das aber sehr gut...merkwürdig. Wie man VBE 3.0 unter win2k zum Laufen bekommt würde mich aber brennend interessieren, alternativ auch wie ich die Bildwiederholfrequenz in der Eingabeaufforderung ändern kann (640x480, standard VGA-modus)