Archiv Scanner 1.570 Themen, 3.787 Beiträge

Mustek 12000SP+ fraggt immer mein Windows!!!!

SeeksTheMoon / 7 Antworten / Baumansicht Nickles

Grrr! Wenn ich meinen 12000SP+ nicht am Controller (AHA2940) hängen habe und Win98 SE starte, dann bleibt Win mit Sanduhr stehen.
Wenn ich Strg+Alt+Entf drücke kommt der Blaue "Das Sys. ist ausgelastet". Weiter mit Enter und ich sehe die Anwendung "msgsrv32.exe" reagiert nicht. Wenn ich die Anwendung beende, dann kann ich normal weiterarbeiten.
Inzwischen habe ich den neuesten Treiber runtergeladen (den für europäische Scanner) und wenn der Scanner nicht am Controller hängt, dann fraggen alle Programme die es so gibt, ohne daß ich in Windows irgendwas machen kann.

Ich habe msgsrv mal umbenannt. Windows fährt kurz rauf-und schaltet den Rechner dann aus.
Also hab ich die Datei wiederhergestellt und mir das offizielle "Runterfahren Update" installiert (vielleicht fraggt msgsrv dann nicht mehr).
Das war ein Irrtum.

Eine Antwort könnte lauten: "Dann laß doch den Scanner dran."
Das nützt aber nichts, weil mit dem neuen Treiber dann die englische Fehlermeldung kommt "überprüfen sie ihr Kabel", welches aber 2 Sekunden vorher mit dem Treiber von der mitgelieferten CD noch funktioniert hat.

Ich verwende Adaptec-ASPI 4.6 und Adaptec AHA 2940AU.
Was soll ich noch machen?

Die Welt ist zu klein für diesen *........* Scanner und mich!!!
Ich dachte beim Kauf, Mustek würde vernünftige Treiber machen.
Irrtum Nr2. (Wenn es statt einem "OK"-Button einen "Um die Installation zu starten"-Button gibt, dann sollte man aufmerksam werden)

Brauche dringend Hilfe, sonst .....

Bombenleger SeeksTheMoon

„Mustek 12000SP+ fraggt immer mein Windows!!!!“

Optionen

Hallo

Schalte den Scanner mal an und boote. Dann deinstallier mal saemtliche Scannertreiber und starte erneut
mit angeschaltetem Scanner. Nachdem jetzt die Treiber neu installiert sind, neu starten und vor dem
Controller-Scan den Scanner ausschalten. Wenn er jetzt nicht booten will zieh mal das externe Kabel
am Controller ab und starte erneut. Klappt es jetzt, dann liegt es an der fehlenden Terminierung am Scanner
oder ist eine dran bzw. haengt noch was dahinter ? Das Problem bei der automatischen Controller-Terminierung
ist, wenn extern ein Kabel dranhaengt und intern auch, dann ist diese Automatik inaktiviert. Deshalb muss das
jeweils letzte Geraet am Kabel, vom Controller aus gesehen, terminiert sein. Alles dazwischen darf dabei aber
nicht terminiert werden, da es sonst zu erheblichen Problemen kommt.
CU

SeeksTheMoon Bombenleger

„HalloSchalte den Scanner mal an und boote. Dann deinstallier mal saemtliche...“

Optionen

Moin!

Ich habe die Treiber runtergeworfen und die von der original CD wieder installiert. Jetzt kommt wenigstens nicht mehr die Meldung, ich solle das Kabel prüfen und ich kann auch wieder scannen.

ABER:
Ist der Scanner vom Controller getrennt, (bzw. er hängt dran, ist aber ausgeschaltet), dann fraggt msgsrv32.exe nach wie vor.
Mit Strg+Alt+Entf, Task beenden, komme ich wieder in Win und kann arbeiten wie zuvor. Ich kann den Scanner auch nachträglich über die Systemsteuerung aktivieren; alles wie gehabt.

Eine Neuinstallation von Win funktioniert immer solange, bis ich den Scanner installiere.
Dann sehe ich bei Windows-Start nur die "hübsche" Sanduhr (und zwar solange, bis ich den "Affengriff" mache).

Am externen Strang hängt nur der Scanner. Innen ist das letzte (und nur das letzte) Gerät terminiert.

Am Scanner kann man keinen Terminator einstellen, lediglich die SCSI ID (welche nicht doppelt vergeben ist).
Das Handbuch erwähnt noch nicht einmal, daß man die ID irgendwo einstellen kann.

Das Problem liegt wohl am Treiber und nicht am Scanner.
Muß man im Controller-BIOS vielleicht was einstellen?
Oder liegt das Problem bei Win98SE (ist ja sowieso recht buggy)?
Was kann man da machen?

Fragmaster SeeksTheMoon

„Moin!Ich habe die Treiber runtergeworfen und die von der original CD wieder...“

Optionen

Ach jaaaa......,

SCSI-Scanner können immer wieder mal richtig Spaß machen – deswegen ist meiner USB.

Ich gehe mal davon aus, dass Du diesen Ärger nach Installation des Scanners bereits vom ersten Tag an hattest.

Das ganze Elend fängt damit an, daß SCSI-Scanner mit diesen verf****** 25poligen Anschlüssen ausgestattet werden, die nicht SCSI-konform sind! Ab Ultra-SCSI-Hostadaptern aufwärts ist damit Ärger garantiert. Falls Dein Adaptec-BIOS es zulässt, solltest Du die max. Datenrate des Scanners auf 10 oder 5 MB/s (somit SCSI-2- oder SCSI-1-Niveau) herabsetzen – das gibt Stabilität.

Natürlich müssen auch die üblichen SCSI-Regeln der Kabellänge und der Terminierung beachtet werden. Bis 4 Devices (inkl. Hostadapter) sind 3 Meter erlaubt, ab 5 Devices nur noch 1,5 Meter! Sollte das bei Dir so sein, dann behebt nur ein eigener (möglichst billiger) Hostadapter, der dann exklusiv Deinen Scanner bedient, Dein Problem. Bezüglich der Terminierung sind zwei Dinge wichtig. Wenn Du Deinen Scanner nicht immer am Netz hast, sollte die Terminierung des Adaptec natürlich auf „Auto“ stehen. Eigentlich sollte Dein Scanner neben dem Kabel Richtung Hostadapter noch über einen zweiten externen Anschluß verfügen, damit er wahlweise in eine externe SCSI-Kette integriert oder mit einem aktiven Abschlusswiderstand (=Terminator) terminiert werden kann. Sollte das nicht so sein und im Handbuch nix über eine geräteseitige Terminierung stehen, so ist dieses Produkt ein jämmerliches Stück Sch**** - und Du bist der Gearschte.

Treiber und Win98SE sind IMHO unschuldig.

Ich hoffe, dass ich Dir trotzdem etwas weiterhelfen konnte ;-)).

CU, Fragmaster

SeeksTheMoon Fragmaster

„Ach jaaaa......,SCSI-Scanner können immer wieder mal richtig Spaß machen...“

Optionen

Schön und gut, aber das Problem tritt ja nur auf, wenn der Scanner AB oder AUS ist, also muß es ja wohl an der Software liegen.
Scannen kann ich ja auch; es wird lediglich der Windowsstart blockiert, wenn der Scanner ab/aus ist.
Autotermination im Controller ist ein, eine Veränderung der Datenübertragungsrate ändert nix.
Der einzige Punkt, der vielleicht zutrifft ist die Kabellänge:
Habe 2Festplatten, Brenner, CD-R, Controller und (manchmal) Scanner dran. Kabel außen und Kabel inne sind zusammen ca. 2m (nicht gemessen), aber da ja alles bis auf den Win-Start funktioniert, dürfte das Problem dort auch nicht liegen.
Naja, danke trotzdem.
Wie schnell ist eigentlich Dein USB-Scanner?
USB ist doch langsamer als SCSI.

Bombenleger SeeksTheMoon

„Schön und gut, aber das Problem tritt ja nur auf, wenn der Scanner AB oder AUS...“

Optionen

Hallo

USB-Scanner sind nur dann langsam wenn nebenbei noch was anderes laeuft bzw. auch wenn
noch andere USB-Geraete dranhaengen, da diese sich im Gegensatz zu SCSI die gesamte
Bandbreite teilen muessen, ausserdem ist diese (noch) nicht besonders hoch (ca. 11 MB/s gesamt).
Jetzt zu Deinem Scanner: Da SCSI-Scanner beim Kauf immer einen Controller dabeihaben ist auch
das entsprechende Kabel dabei. In Deinem Fall muesste zuerst mal ein neues Kabel her das
auf der einen Seite den 50-Pol-Anschluss des AU und auf der anderen Seite den des Scanners hat, wenn
das mitgelieferte Kabel bisher weitergenutzt wurde.
Desweiteren sind SCSI-Scanner niemals terminiert, es sei denn er hat dafuer einen speziellen
Schalter und das haben eigentlich nur die (Netzwerk/Profi) Teile ab 5000,- aufwaerts. Also sieh Dir mal die
Rueckseite des Scanners an. Ist da nur ein Anschluss, oder sind da mehrere ? Ist da noch ein freier
25-Pol dann hol Dir im Handel einen externen (aktiven) Terminator der da draufpasst. Haettest Dir lieber
gleich einen von Microtek holen sollen, da ist naemlich ein Terminator dabei. Allerdings muss auch
dafuer ein neues Kabel besorgt werden, wenn er nicht am mitgelieferten Controller angeschlossen wird.
Was Win angeht: Wenn der Scanner einmalig installiert wurde und beim naechsten Boot nicht mehr
hochkommt, dann liegt das daran das Win den Geraetetreiber entfernen will und es aufgrund eines
SCSI-Bus-Fehlers aber nicht kann, denn es wartet auf die Geraete die hinter dem Scanner haengen,
da der erforderliche Terminator fehlt. Ohne Terminator ist der Bus naemlich offen und das nutzt
Win natuerlich aus. Das gleiche gilt fuer BNC-Netzwerke wenn einer der Endwiderstaende fehlt,
das Netz nimmt ungewohnte Ausmasse an und laesst keinen Rechner mehr starten, da alle ja solange
suchen bis das Ende der Leitung (fehlt ja) gefunden wird. Was mit dem Affengriff abgebrochen wird
ist genau diese suche und hat nichts mit installierten Treibern zu tun, da ein Scanner nur dann
tatsaechlich angesprochen wird, wenn dessen Software, nicht Treiber, etwas von ihm will.
Na denn schoenes (Bastel) Wochenende.

SeeksTheMoon Bombenleger

„HalloUSB-Scanner sind nur dann langsam wenn nebenbei noch was anderes laeuft...“

Optionen

Neues SCSI Kabel und Terminator, alles klar.
Mal sehen obs wirkt, oder ob das Geld ausm Windows geworfen ist :-)

alpino (Anonym) Bombenleger

„HalloUSB-Scanner sind nur dann langsam wenn nebenbei noch was anderes laeuft...“

Optionen

hi bombenleger,

dein betrag ist das beste, was ich jemals zu dem thema gelesen habe; danke, jetzt hab ich das problem eigentlich erst richtig erkannt.

ich habe auch den fehler gemacht, einen günstigen mustek-scanner (SCANEXPRESS 12000 SP) mit proprietärem scsi-controller zu erwerben. ich habe viel zu spät gesehen, daß der scsi-controller für einen ISA-steckplatz und nicht für PCI vorgesehen ist. da ist draufgedruckt: DCT 1381. meine anfrage bei DCT im folgenden spricht bände:

Subject: DTC-3133/3151/3152/3153/3181/3199/8200/8260 controller.

This is NOT OUR CARD….

We did not make or market the DTC3181/3151 cards, nor we have the drivers for them. Just say a company in Taiwan used the name DTC Technology marketed these cards and such a company does not exist (therefore DTCT on the chip). We are DTC Data Technology.

- mit anderen worten, da scheint ein noname-controller mit dem logo eines großen herstellers versehen worden zu sein - das ist einer der gründe, warum keine aktuellen treiber verfügbar sind.

ich habe mir letzt woche einen neuen pci-scsi-controller gekauft (dm 145), ein neues kabel gekauft (dm 59), aber nix geht bisher. jetzt gehe ich sofort einen terminator kaufen, halt mir die daumen.

gruß alpino