Miniatur-Einplatinenrechner für alle 82 Themen, 480 Beiträge

Raspberry Pi 3 - Openmediavault installieren

cacare / 9 Antworten / Baumansicht Nickles

Hallo zusammen

Ist es möglich es hat so viele Anleitungen und youtube Videos im Netz über die Installation

von Openmediavault für den Raspberry pi 3 aber keine hat bis jetzt funktioniert.

Ich war das Ganze Wochenende mit dieser Installtion beschäftigt gebracht hat es aber nichts.

Zuerst habe ich es mit dem Raspbi B versucht dann habe ich es gelassen und habe mit dem Raspbi 3 weitergemacht klappt einfach nicht.

Jedesmal kommt eine andere Fehlermeldung mal startet der monit nicht mal ist es der Samba der nicht starten will und dann wieder kann er openmediavault wegen Abhängigkeitsprobleme die Installation nicht fertig installieren.

Ich bin wirklich enttäuscht ich hätte mir das Ganze auch sparen können.

In der Anleitung wird alles schöngeredet wie einfach und das dass Ganze auch funktioniert

nix da funktioniert nicht!!!

Die Installation von Raspbian lite und die Aktualisierung funktioniert gut und ohne Probleme sobald man Rebootet und diesen Skript

wget -O – https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install | sudo bash

im Terminal eingibt, hängt er sich wie gesagt mit immer einer anderen Meldung ab

Schade hatte mich gefreut....

Es will einfach nicht klappen.

  

bei Antwort benachrichtigen
Borlander cacare

„Raspberry Pi 3 - Openmediavault installieren“

Optionen
Die Installation von Raspbian lite und die Aktualisierung funktioniert gut und ohne Probleme sobald man Rebootet und diesen Skript
wget -O – https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install | sudo bash
im Terminal eingibt, hängt er sich wie gesagt mit immer einer anderen Meldung ab

Also diese Form der Installation ist auf jeden Fall schon sehr fragwürdig :-\

bei Antwort benachrichtigen
cacare Borlander

„Also diese Form der Installation ist auf jeden Fall schon sehr fragwürdig :-“

Optionen

Entschuldige aber immer diese Form wird in den Anleitungen von Openmediavault erwähnt es gibt keine andere 

Und auch heute ist diese Fehlermeldung erschienen:

Job for smbd.service failed because a timeout was exceeded.
See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.
● smbd.service - Samba SMB Daemon
Loaded: loaded (/lib/systemd/system/smbd.service; disabled; vendor preset: enabled)
Active: failed (Result: timeout) since Thu 2021-05-06 01:08:52 CEST; 92ms ago
Docs: man:smbd(8)
man:samba(7)
man:smb.conf(5)
Process: 19688 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
Process: 19689 ExecStart=/usr/sbin/smbd --foreground --no-process-group $SMBDOPTIONS (code=killed, signal=KILL)
Main PID: 19689 (code=killed, signal=KILL)

May 06 01:05:39 Nas systemd[1]: Starting Samba SMB Daemon...
May 06 01:07:10 Nas systemd[1]: smbd.service: Start operation timed out. Terminating.
May 06 01:08:40 Nas systemd[1]: smbd.service: State 'stop-sigterm' timed out. Killing.
May 06 01:08:40 Nas systemd[1]: smbd.service: Killing process 19689 (smbd) with signal SIGKILL.
May 06 01:08:52 Nas systemd[1]: smbd.service: Main process exited, code=killed, status=9/KILL
May 06 01:08:52 Nas systemd[1]: smbd.service: Failed with result 'timeout'.
May 06 01:08:52 Nas systemd[1]: Failed to start Samba SMB Daemon.
dpkg: error processing package samba (--configure):
installed samba package post-installation script subprocess returned error exit status 1
Setting up nginx (1.14.2-2+deb10u3) ...
dpkg: dependency problems prevent configuration of openmediavault:
openmediavault depends on samba; however:
Package samba is not configured yet.

dpkg: error processing package openmediavault (--configure):
dependency problems - leaving unconfigured
Setting up wsdd (0.6.2-1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/wsdd.service → /lib/systemd/system/wsdd.service.
Setting up liblvm2cmd2.03:armhf (2.03.02-3) ...
Setting up dmeventd (2:1.02.155-3) ...
Created symlink /etc/systemd/system/sockets.target.wants/dm-event.socket → /lib/systemd/system/dm-event.socket.
dm-event.service is a disabled or a static unit, not starting it.
Setting up lvm2 (2.03.02-3) ...
update-initramfs: deferring update (trigger activated)
Created symlink /etc/systemd/system/sysinit.target.wants/blk-availability.service → /lib/systemd/system/blk-availability.service.
Created symlink /etc/systemd/system/sysinit.target.wants/lvm2-monitor.service → /lib/systemd/system/lvm2-monitor.service.
Created symlink /etc/systemd/system/sysinit.target.wants/lvm2-lvmpolld.socket → /lib/systemd/system/lvm2-lvmpolld.socket.
Processing triggers for initramfs-tools (0.133+deb10u1) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...
Processing triggers for rsyslog (8.1901.0-1) ...
Processing triggers for systemd (241-7~deb10u7+rpi1) ...
Processing triggers for man-db (2.8.5-2) ...
Errors were encountered while processing:
samba
openmediavault
E: Sub-process /usr/bin/dpkg returned an error code (1)
failed to install openmediavault package.

Ich wüsste nicht was es noch für eine andere Art von Installation gibt habe keine gefunden kennst du eine andere??

bei Antwort benachrichtigen
fbe cacare

„Entschuldige aber immer diese Form wird in den Anleitungen von Openmediavault erwähnt es gibt keine andere Und auch heute ...“

Optionen

Ich kenn mich mit rasberry nicht aus. Ich les aber in deinem Posting:

Job for smbd.service failed because a timeout was exceeded.

Da würde ich den Fehler suchen.

bei Antwort benachrichtigen
Borlander cacare

„Entschuldige aber immer diese Form wird in den Anleitungen von Openmediavault erwähnt es gibt keine andere Und auch heute ...“

Optionen
Entschuldige aber immer diese Form wird in den Anleitungen von Openmediavault erwähnt es gibt keine andere 

Und das macht es leider nicht besser. Blind Scripte herunterzuladen und mit Root-Rechten auszuführen halte ich für fahrlässig. Da sollte man doch wenigstens mal vorher rein schauen was das Script so macht. Zumal Du sonst auch nicht sicher sein kannst, dass jedes mal das selbe Scrtipt ausgeführt wird…

bei Antwort benachrichtigen
Borlander cacare

„Entschuldige aber immer diese Form wird in den Anleitungen von Openmediavault erwähnt es gibt keine andere Und auch heute ...“

Optionen
installed samba package post-installation script subprocess returned error exit status

Das ist also irgendwas bei der Installation von Samba nicht korrekt abgelaufen.

See "systemctl status smbd.service" and "journalctl -xe" for details.

Das schon mal getan?

bei Antwort benachrichtigen
Michael Nickles cacare

„Raspberry Pi 3 - Openmediavault installieren“

Optionen

Hi Cacare,

Generell läuft die Installation von Openmediavault eigentlich reibungslos ab, hatte noch nie Probleme damit. Ob Du dieses generell sehr gute NAS System überhaupt haben willst, solltest Du aber gut überlegen. Es ist funktionell sehr gut aber die Einarbeitung kann hart sein.

Für einfache NAS-Zwecke mit dem Raspberry Pi verwende ich zunehmend gerne einfach ein "Kodi Mediacenter", einfach als Image installiert. Im Setup von Kodi lässt sich einstellen, dass alle angeschlossenen USB-Datenträger automatisch im Netzwerk freigegegeben werden.

Hängt man so einen Pi mit Kodi an einen Fernseher, hat man ein prima Mediacenter und nebenbei ist auch "einfache" Laufwerkfreigabe schnell und simpel erledigt. 

Grüße,

Mike

bei Antwort benachrichtigen
cacare Michael Nickles

„Hi Cacare, Generell läuft die Installation von Openmediavault eigentlich reibungslos ab, hatte noch nie Probleme damit. Ob ...“

Optionen

Eigentlich wollte ich dabei etwas lernen

Ich habe eigentlich schon ein Nas und zwar ein readynas duo zwar nicht mehr der neueste

ist von 2011 aber funktioniert immer noch sehr gut

ich wollte es ausprobieren und neues lernen 

und da war der Raspi genau richtig

übrigens ich kenne Kodi als es noch XMBC hiess und ich muss sagen

es hat mir nie gefallen.

Aber das ganze hat sich jetzt erledigt ich habe es hinbekommen

also danke auch dir für die Hilfe Michael

Danke dir.

bei Antwort benachrichtigen
bappseggl cacare

„Raspberry Pi 3 - Openmediavault installieren“

Optionen

Ist das Problem noch aktuell?

Hab das heute mal mit einem Raspi3 und einem Pi-400 nachvollzogen.
Funktioniert hier problemlos.

bei Antwort benachrichtigen
cacare bappseggl

„Ist das Problem noch aktuell? Hab das heute mal mit einem Raspi3 und einem Pi-400 nachvollzogen. Funktioniert hier ...“

Optionen

nachdem ich eine neue SD Karte gekauft habe und sie eingesetzt habe

versuchte ich es zum letzten mal 

und habe es nach dieser Anleitung schritt für schritt nachgemacht

https://www.youtube.com/watch?v=gmaExrygKvU

und siehe da hat auf anhieb alles geklappt auch raspbian konnte ich danach aktualisieren

ohne Probleme wie gesagt alles auf anhieb geklappt

Also zum Schluss kann ich sagen ist die SD Karte sehr wahrscheinlich nach kaputt gewesen.

Für mich hat sich in dem Fall das ganze gelohnt funktioniert perfekt mit dem Raspi 3

Danke an alle für die Hilfe.

bei Antwort benachrichtigen