Office - Word, Excel und Co. 9.524 Themen, 38.907 Beiträge

Excel/Google Tabelle summe über mehrere Blätter

Marc6500 / 0 Antworten / Baumansicht Nickles

Hallo,

ich hab folgendens Problem:

Ich hab eine Kegel Spiel Ergebniss Tabelle über mehrere Jahre von 2000 bis jetzt mit jeweils einem Blatt pro Jahr.

Nun zähle ich die Anzahl der Holz/Neuner/Pudel auf jedem Blatt für jeden Spieler zusammen. Diese Formel hab ich quasi mit dem "holzhammer" entworfen.

Als Beispiel für die Gesamt Punkte:

=SUMME(SUMMEWENN(A20:A266;A2;D20:D266)+SUMMEWENN(A20:A266;A2;G20:G266)+SUMMEWENN(A20:A266;A2;J20:J266)+SUMMEWENN(A20:A266;A2;M20:M266)+SUMMEWENN(A20:A266;A2;P20:P266)+SUMMEWENN(A20:A266;A2;S20:S266)+SUMMEWENN(A20:A266;A2;V20:V266)+SUMMEWENN(A20:A266;A2;Y20:Y266)+SUMMEWENN(A20:A266;A2;AB20:AB266)+SUMMEWENN(A20:A266;A2;AE20:AE266)+SUMMEWENN(A20:A266;A2;AH20:AH266)+SUMMEWENN(A20:A266;A2;AK20:AK266)+SUMMEWENN(A20:A266;A2;AN20:AN266)+SUMMEWENN(A20:A266;A2;AQ20:AQ266)+SUMMEWENN(A20:A266;A2;AT20:AT266)+SUMMEWENN(A20:A266;A2;AW20:AW266))

Mit dieser Formel kann ich in "A2 " den Spielernamen ändern und er zeigt mir den jeweiligen Wert direkt an.

Die Tabelle ist immer gleich ab "D20" kommt immer 3 Felder weiter die nächsten Punkte zum zählen.

Kann man so eine Formel eleganter lösen? 

Aber eigentlich ist mein größeres Problem:

Das Blatt in dem ich alle Jahre zusammenzähle:

=SUMME(SUMMEWENN('2000'!A2:A16;A3;'2000'!B2:B16)+SUMMEWENN('2001'!A2:A16;A3;'2001'!B2:B16)+SUMMEWENN('2002'!A2:A16;A3;'2002'!B2:B16)+SUMMEWENN('2003'!A2:A16;A3;'2003'!B2:B16)+SUMMEWENN('2004'!A2:A17;A3;'2004'!B2:B17)+SUMMEWENN('2005'!A2:A16;A3;'2005'!B2:B16)+SUMMEWENN('2006'!A2:A16;A3;'2006'!B2:B16)+SUMMEWENN('2007'!A2:A16;A3;'2007'!B2:B16)+SUMMEWENN('2008'!A2:A16;A3;'2008'!B2:B16)+SUMMEWENN('2009'!A2:A16;A3;'2009'!B2:B16))

hier hab ich die Holzhammer methode erstmal bei 2009 gestoppt. Weil ich auf einer Excel hilf seite gelesen habe man könnte das vereinfachen.

  1. Um nun noch einen Verweis über die Tabellenblätter Jan – Dez zu erstellen, ergänzen Sie die Formel wie folgt:
    =SUMME(Jan:Dez!B7)

Aber unter Google Tabelle das ich hierfür grad verwende (damit diese Tabelle für alle Mitglieder freigegeben werden kann, weil es so schön einfach ist. Funktioniert mit meiner Fahrgemeinschaft auch Super) bekomme ich das mit Zahlen irgendwie nicht auf die reihe

So sieht meine Interpretation dafür aus.

=SUMMEWENN('2000':'2009'!A2:A16;A3;'2000':'2009'!B2:B16)

Geht sowas nicht bei google Tabelle und nur bei excel? Oder hab irgendwo nen derben Fehler verbaut?

bei Antwort benachrichtigen