Mainboards, BIOS, Prozessoren, RAM 27.269 Themen, 123.690 Beiträge

Secure Boot wird trotz Aktivierung im BIOS nicht durchgeführt

kugelkolibri / 22 Antworten / Baumansicht Nickles

Hallo, ich bereite meinen PC (AMD Ryzen 5 2600, Asrock B450M Pro 4 BIOS 3.60) gerade für das Upgrade von Windows 10 auf 11 vor. Dazu habe ich ich das TPM 2.0 Modul und auch das Secure-Boot-Verfahren im BIOS aktiviert. Leider zeigt mir die PC-Integritäts-Prüfung (als einzigen Fehler) trotzdem an, dass der PC den sicheren Start nicht unterstützt.

Ich habe mir schon verschiedene Tutorials bei Youtube angesehen, bin jede einzelne Position im BIOS durchgegangen und habe es auch mit deaktivieren und wiederaktivieren des Secure-Boot-Modus versucht. Alles ohne Erfolg; ich weiß nicht, woran es liegen könnte bzw. was ich machen soll.

Jetzt hoffe ich darauf, das einer von euch einen Tipp für mich hat.

bei Antwort benachrichtigen
RW1 kugelkolibri „Secure Boot wird trotz Aktivierung im BIOS nicht durchgeführt“
Optionen

Hast Du denn auch den UEFI Start "aktiviert" oder arbeitest du noch im normalen BIOS Modus?

bei Antwort benachrichtigen
kugelkolibri RW1 „Hast Du denn auch den UEFI Start aktiviert oder arbeitest du noch im normalen BIOS Modus?“
Optionen

Es handelt sich um ein UEFI-BIOS, eine Option "Legacy" wie früher habe ich bisher nicht gesehen. Eine Einstellungsmöglichkeit für einen "UEFI-Start" auch nicht. Wo sollte die zu finden sein?

bei Antwort benachrichtigen
kugelkolibri Nachtrag zu: „Es handelt sich um ein UEFI-BIOS, eine Option Legacy wie früher habe ich bisher nicht gesehen. Eine ...“
Optionen

Ich habe gerade noch mal nachgesehen: Bei den Bootoptionen steht bei #1: NVME SSD 1 (eine 500 GB M2-SSD mit dem Betriebssystem) und bei #2: AHCI SSD2 (eine 500 GB 2,5" SATA-SSD als Datenspeicher). Hier werden nur die installierten SSDs und die Option "disabled" angeboten. Eine im Handbuch im Bild sichtbare UEFI-Option gibt es nicht.

Die Deaktivierung der Kompabilitätseinstellung führte dazu, dass der normale Start gar nicht mehr erfolgte und ich immer wieder gleich im BIOS landete. Deshalb habe ich den Modus wieder aktiviert.

Unterhalb der K-E gab es noch die Punkte PxOpRon und StorageOpRon mit den Auswahlmöglichkeiten Legacy, UEFI und nicht starten. Die habe ich auf UEFI geändert, das hatte aber keinen sichtbaren Erfolg. Beim Integritäts-Check wird immer noch ein fehlender sicherer Systemstart bemängelt.

bei Antwort benachrichtigen
fakiauso kugelkolibri „Secure Boot wird trotz Aktivierung im BIOS nicht durchgeführt“
Optionen

Hast Du bei Asrock selber schon nachgesehen und die dort verlinkte Anleitung durchgeackert?

https://www.asrock.com/support/faq.asp?id=500

Das aktuellste BIOS ist 5.70 und sollte natürlich vorher geflasht werden.

Das Aktivieren von AMD CPU fTPM sollte dann  das Zauberwort sein.

Edit: Von Deinem Board gibt es noch eine Revision R2.0. Bitte auf das richtige Board achten!

HTH

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
kugelkolibri fakiauso „Hast Du bei Asrock selber schon nachgesehen und die dort verlinkte Anleitung durchgeackert? ...“
Optionen

Die Anleitung bei AsRock kannte ich noch nicht. Hab sie ausprobiert, leider ohne Erfolg. Wenn ich CSM deaktiviere -egal ob mit oder ohne fTPM- startet das Betriebssystem überhaupt nicht mehr und ich lande immer wieder gleich im BIOS.

Ich habe es dann auch mit dem Laden der Standard-UEFI-Werte versucht; brachte aber leider auch nichts.

Das BIOS habe ich noch nicht geflasht. Das will ich erst als letztes versuchen. Die Youtube-Tutorials waren mit B460M-Boards ohne dieses Update und dort gab es das Problem nicht. Deshalb vermute ich, dass es an was anderem liegt.

P.S.: ich habe das erste B450M Pro 4, nicht die Rev. 2.0

bei Antwort benachrichtigen
fakiauso kugelkolibri „Die Anleitung bei AsRock kannte ich noch nicht. Hab sie ausprobiert, leider ohne Erfolg. Wenn ich CSM deaktiviere -egal ob ...“
Optionen
Das BIOS habe ich noch nicht geflasht. Das will ich erst als letztes versuchen. Die Youtube-Tutorials waren mit B460M-Boards ohne dieses Update und dort gab es das Problem nicht. Deshalb vermute ich, dass es an was anderem liegt.

Das aktuellste BIOS würde ich trotzdem installieren, weil darüber teils auch Sicherheits-Updates installiert werden. Anschließend versuche es noch einmal mit den Default Settings und ggf. mit einer Neuinstallation von W11, falls das jetzige mit den geänderten Settings nicht klarkommt.

Ansonsten ignoriere ggf. die Meldung der Integritätsprüfung und schaue, was W11 dann wirklich macht. Ein Backup ist natürlich Pflicht und ggf. baust Du nur die Platte ein, auf der Du installieren möchtest.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Eludi84 fakiauso „Das aktuellste BIOS würde ich trotzdem installieren, weil darüber teils auch Sicherheits-Updates installiert werden. ...“
Optionen
Die Deaktivierung der Kompabilitätseinstellung führte dazu, dass der normale Start gar nicht mehr erfolgte und ich immer wieder gleich im BIOS landete. Deshalb habe ich den Modus wieder aktiviert.
Wenn ich CSM deaktiviere

Demnach hat @kugelkolibri also nicht mit UEFI +GPT installiert sondern Bios+MBR und somit kann das System per UEFI doch gar nicht starten, oder verstehe ich da was falsch?

Also wie du schreibst:

Neuinstallation von W11

wäre wohl die saubereste Lösung.

Endlich auch mit Ubuntu :-) Aber immer noch im Wechsel mit Win10 und Win11 :-(
bei Antwort benachrichtigen
fakiauso Eludi84 „Demnach hat @kugelkolibri also nicht mit UEFI GPT installiert sondern Bios MBR und somit kann das System per UEFI doch gar ...“
Optionen
Demnach hat @kugelkolibri also nicht mit UEFI +GPT installiert sondern Bios+MBR und somit kann das System per UEFI doch gar nicht starten, oder verstehe ich da was falsch?


Wenn die M2 eine NMVe ist, sollte die doch ohnehin nur noch GPT+UEFI+SecureBoot machen?

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Eludi84 fakiauso „Wenn die M2 eine NMVe ist, sollte die doch ohnehin nur noch GPT UEFI SecureBoot machen?“
Optionen

Falls aber

https://www.computerbase.de/forum/threads/windows-10-nvme-ssd-gpt-oder-mbr.1946077/

#11:

Die Boards die mir bisher durch die Finger gegangen sind starten nicht im reinen UEFI Mode sondern im Kompatibilitäts Mode .. was auch immer das bedeuten mag, im UEFI auf UEFI Only stellen dann ist man sicher.

Endlich auch mit Ubuntu :-) Aber immer noch im Wechsel mit Win10 und Win11 :-(
bei Antwort benachrichtigen
kugelkolibri Eludi84 „Demnach hat @kugelkolibri also nicht mit UEFI GPT installiert sondern Bios MBR und somit kann das System per UEFI doch gar ...“
Optionen

Ich weiß noch von der Installation des W10, dass da UEFI Voraussetzung war. Zu GPT oder MBR kann ich leider nichts sagen. Kann ich irgendwie feststellen, was bei der Installation benutzt wurde bzw. was aktuell auf der SSD vorhanden ist, GPT oder MBR?

Bei aktiviertem CSM habe ich die Möglichkeit, zwei OpRon einzustellen, wahlweise auf Legacy, UEFI oder nicht starten. Aktuell ist "nur UEFI" eingestellt und der PC startet und läuft normal.

Was mich wundert ist, das bei dem Check angezeigt wird, dass der sichere Start nicht möglich ist, die Secure-Boot-Option im BIOS aber aktiviert ist. Wie kann das sein?

bei Antwort benachrichtigen
Eludi84 kugelkolibri „Ich weiß noch von der Installation des W10, dass da UEFI Voraussetzung war. Zu GPT oder MBR kann ich leider nichts sagen. ...“
Optionen
Kann ich irgendwie feststellen, was bei der Installation benutzt wurde bzw. was aktuell auf der SSD vorhanden ist, GPT oder MBR?

Über die Datenträgerverwaltung:

Endlich auch mit Ubuntu :-) Aber immer noch im Wechsel mit Win10 und Win11 :-(
bei Antwort benachrichtigen
Eludi84 Nachtrag zu: „Über die Datenträgerverwaltung:“
Optionen

Nachtrag:

Falls da bei Dir GPT steht- mach was @fakiauso vorgeschlagen hat.

Endlich auch mit Ubuntu :-) Aber immer noch im Wechsel mit Win10 und Win11 :-(
bei Antwort benachrichtigen
kugelkolibri Eludi84 „Über die Datenträgerverwaltung:“
Optionen

Leider bekomme ich das letzte Fenster mit dem Reiter "Volumes" nicht angezeigt. Wenn ich in der Datenträgerverwaltung die Festplatte mit rechts anklicke und dann "Eigenschaften" öffne, zeigt mir das Fenster nur die Reiter Allgemein, Tools, Hardware, Sicherheit, Kontingent und Anpassen. Und unter denen finde ich "Volumes" nicht.

Wie rufe ich dieses letzte Fenster bzw. die Volumes-Infos auf?

bei Antwort benachrichtigen
Eludi84 kugelkolibri „Leider bekomme ich das letzte Fenster mit dem Reiter Volumes nicht angezeigt. Wenn ich in der Datenträgerverwaltung die ...“
Optionen

Vermutlich bist Du über den Explorer dahin gegangen?

Rechtsklick auf das Windows-Logo- Datenträgerverwaltung auswählen...

Endlich auch mit Ubuntu :-) Aber immer noch im Wechsel mit Win10 und Win11 :-(
bei Antwort benachrichtigen
kugelkolibri Eludi84 „Vermutlich bist Du über den Explorer dahin gegangen? Rechtsklick auf das Windows-Logo- Datenträgerverwaltung auswählen...“
Optionen

Auch damit bekomme ich nur das Fenster mit den schon genannten Reitern, aber ohne Volumes.

bei Antwort benachrichtigen
kugelkolibri Nachtrag zu: „Auch damit bekomme ich nur das Fenster mit den schon genannten Reitern, aber ohne Volumes.“
Optionen

KORREKTUR

Ich hatte immer nur die jeweilige Partition angeklickt. Wenn ich aber den grauen Kasten links davon nehme, dann bekomme ich ich das Fenster wie bei Dir. Leider steht da MBR.

Ich vermute, das ist die Ursache meines Problems. Wenn ich eine Neuinstallation mache und dort dann GPT auswähle, sollte ich damm Windows 11 installieren können?

bei Antwort benachrichtigen
fakiauso kugelkolibri „KORREKTUR Ich hatte immer nur die jeweilige Partition angeklickt. Wenn ich aber den grauen Kasten links davon nehme, dann ...“
Optionen
Ich vermute, das ist die Ursache meines Problems. Wenn ich eine Neuinstallation mache und dort dann GPT auswähle, sollte ich damm Windows 11 installieren können?


In der Theorie kannst Du mittels MBR2GPT die Platte noch umstellen. Dazu muß die aber in einem PC stecken, der das im MBR-Modus booten kann. Sauber neu installieren dauert vermutlich auch nicht länger als das Gefrickel ohne völlige Aussicht auf Erfolg.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
kugelkolibri fakiauso „In der Theorie kannst Du mittels MBR2GPT die Platte noch umstellen. Dazu muß die aber in einem PC stecken, der das im ...“
Optionen

Sehe ich genauso, zumal es bei mir die Systemfestplatte ist. Dann lieber eine saubere Neuinstallation; war mir schon immer lieber.

Schönen Dank!

bei Antwort benachrichtigen
Eludi84 kugelkolibri „Auch damit bekomme ich nur das Fenster mit den schon genannten Reitern, aber ohne Volumes.“
Optionen

Endlich auch mit Ubuntu :-) Aber immer noch im Wechsel mit Win10 und Win11 :-(
bei Antwort benachrichtigen
kugelkolibri Eludi84 „...“
Optionen

Heißt das ja oder nein?

bei Antwort benachrichtigen
Eludi84 kugelkolibri „Heißt das ja oder nein?“
Optionen

Im Fall einer Neuinstallation macht Win11 das.
Im Bios prüfen ob die SSD im richtigen Slot (bei mehr als einem) sitzt und erkannt wird.

Ansonsten lies mal hier:

https://learn.microsoft.com/de-de/windows-hardware/manufacture/desktop/windows-setup-installing-using-the-mbr-or-gpt-partition-style?view=windows-11

Endlich auch mit Ubuntu :-) Aber immer noch im Wechsel mit Win10 und Win11 :-(
bei Antwort benachrichtigen
kugelkolibri Eludi84 „Im Fall einer Neuinstallation macht Win11 das. Im Bios prüfen ob die SSD im richtigen Slot bei mehr als einem sitzt und ...“
Optionen

Herzlichen Dank! Dann mache ich mich mal an die Arbeit.

bei Antwort benachrichtigen