Linux 14.981 Themen, 106.343 Beiträge

Archlinux nach Kernelupdate Bildschirm schwarz

johnT / 10 Antworten / Baumansicht Nickles

Hi,

sorry, hat man das Grubproblem gelöst kommt bei mir das nächste Problem. Leider habe ich trotz intensiver Suche nirgends eine Lösung oder einen gleich gelagerten Fall finden können.

Gewohnheitsmäßig wurde mit pacman das kommen Update gemacht. Betroffen waren die Pakete linux-lts-5.15.70-1, nvidia-lts-1:515.76-2, nvidia-settings-515.76-1 und nvidia-utils-515.76-1. Nach dem Neustart zeigt sich Grub wie gewohnt, wird Archlinux (Dualboot Win11)ausgewählt wird angezeigt, dass die Ramdisk geladen wird. Danach blinkt es noch zwei, drei mal dann bleibt der Bildschirm schwarz. Habe vermutet, dass es mit Nvidiatreiber zusammenhängen könnte. Bin dann mal vom LTS-Kernel auf den normalen Kernel samt samt Nvidiagefolge umgestiegen. Liefert aber das gleiche Ergebnis.

Vorrübergehende Lösung ist momentan der Downgrad auf den Linux-lts Kernel mit der Endnummer 69-1.

Dürfte doch eigentlich nicht der Einzige sein der nun Schwierigkeiten bekommen hat oder? Vielleicht hat jemand einen Tip?

bei Antwort benachrichtigen
johnT Nachtrag zu: „Archlinux nach Kernelupdate Bildschirm schwarz“
Optionen

Kleines Update.

Auf Laptops mit gleichartiger Konfiguration liefen die genannten Updates komischer Weise problemlos durch Lachend.  Nur beim PC hapert es nach der Initialisierung der Ramdisk ein paar mal Blinken... dann aus. Weinend Also bleibt es zunächst bei Downgrade. Verstehe es einfach nicht, weil es doch vorher funktionierte...Brüllend Was hat sich da geändert?

bei Antwort benachrichtigen
fakiauso johnT „Kleines Update. Auf Laptops mit gleichartiger Konfiguration liefen die genannten Updates komischer Weise problemlos durch . ...“
Optionen

Kommst Du auf eine Konsole ohne grafischen Login?

Klingt für mich so, als ob für den zu ladenden Kernel schlicht kein Kernelmodul für die Grafik geladen wird, weil es entweder kein passendes gibt oder dieses während der Installation nicht gebaut wurde.

Wenn Du Dich auf der Konsole einloggen kannst, dann lasse mal dmesg laufen und prüfe auf Fehlermeldungen.

Falls Du in grub noch ältere Kerneleinträge oder ein Fallback zur Auswahl hast, dann wähle diesen aus und schaue, ob der mit Grafik startet.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
johnT fakiauso „Kommst Du auf eine Konsole ohne grafischen Login? Klingt für mich so, als ob für den zu ladenden Kernel schlicht kein ...“
Optionen

Danke für die Anregungen. Bisher habe ich per arch-chroot mit der Installations-CD gearbeitet und konnte so den Downgrade des Kernels und der Nvidiapakete aus var/cache/pacman vornehmen. Insofern komme ich mit der CD ins System und kann Veränderungen  vornehmen.

Habe Grub und die neuen Pakete Pakete (linux-lts-5.15.70-1, nvidia-lts-1:515.76-2, nvidia-settings-515.76-1 und nvidia-utils-515.76-1) noch mal neu installiert, hat aber nichts gebracht, eben so wie die Probe mit den aktuellen normalen linux-kernel. Ich denke auch, das es ein Problem mit dem Laden der Grafik gibt, zumal der Bildschirm schwarz bleibt, also nicht ausgeschaltet ist, jedoch ohne Meldungen und eher schwarz abgedunkelt erscheint.

Eigentlich habe ich die Schritte nachvollzogen, welche ich auch bei Installation gemacht hatte. Aber offenbar reichen die nicht aus. Dann will ich noch mal ran...

bei Antwort benachrichtigen
fakiauso johnT „Danke für die Anregungen. Bisher habe ich per arch-chroot mit der Installations-CD gearbeitet und konnte so den Downgrade ...“
Optionen

Meckert pacman bei der vollständigen Aktualisierung mittels -Syu über fehlende Schlüssel?

Denn bei mir ebenfalls mit einer Nvidia gibt es keine Probleme, aber da wurstelt nur der normale und nicht zusätzlich der LTS-Kernel.

Ist das ein Desktop mit ggf. noch Prozessorgrafik oder ein Notebook mit beiden GPUs? Dann kann auch das für ein Umschalten nötige prime das Problem sein.

Wie gesagt mittels dmesg die Kernel-Meldungen auslesen und eventuell wurde auch wieder grub nicht korrekt aktualisiert und deshalb fährt der Bootloader den falschen Kernel an.

Wären so die naheliegendsten Fehler aus meiner Sicht...

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
johnT fakiauso „Meckert pacman bei der vollständigen Aktualisierung mittels -Syu über fehlende Schlüssel? Denn bei mir ebenfalls mit ...“
Optionen

Es ist einfach Wahnsinn Zwinkernd Bei dmesg konnte ich nur feststellen, dass die Bootpartition wegen fat32-Fehler nicht gelesen werden konnte, weil Daten korrupt sein könnten. Das habe ich bereinigt und den dortigen Inhalt neu installiert. Obwohl irgendwie unlogisch, da es bei Downgrade doch alles funktionierte. 

Gleichwohl kommt in der Xorg.0.log als auch unter startx die Meldung, dass die NVIDIA Kernel module nicht initialisiert werden konnten. No screen found. Gesucht wird in  X11/xorg.conf.d, obwohl da nix drin ist und xorg.conf nichts bringt.

Ansonsten erschlagen mich die Meldungen unter dmesg. Habe damit noch nie gearbeitet. Sind auch nicht gerade aktuell. Ich weis nicht wo die Kernelmodule hin sein könnten Zwinkernd. Mir fällt nichts mehr ein. Mehr wie Installieren kann man doch nicht.  Grub, linux-lts, nvidia-lts ...rauf und runter...

Ist ein Desktop PC, ein HP Envy vom Juli 2022 mit ner NVIDIA GeForce RTX 3060 Ti  und viel Platz. Hab wieder Downgradet, damit ich hier schreiben kann. So langsam bekommt man echt Übung...

bei Antwort benachrichtigen
fakiauso johnT „Es ist einfach Wahnsinn Bei dmesg konnte ich nur feststellen, dass die Bootpartition wegen fat32-Fehler nicht gelesen ...“
Optionen

Was steht denn in der xorg.conf drin?

Sonst könnte man auch noch vermuten, dass statt des nvidia der nouveau angesprochen wird und das deshalb schief geht wie in diesem Fall.

Wirf auchmal diese Abfrage aus diesem Thread rein:

pacman -Q nvidia{,-{libgl,utils}}

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
johnT fakiauso „Was steht denn in der xorg.conf drin? Sonst könnte man auch noch vermuten, dass statt des nvidia der nouveau angesprochen ...“
Optionen

Hallo und erst mal vielen Dank für die Bemühungen und die Hilfestellung!

Nun habe ich den pacman -Q nvidia{,-{libgl, utils}} beim linux-lts-5.15.69-1 (den Downgraded funktionierenden System) durchgeführt
und die Rückmeldung erhalten, dass libgl und utils vorhanden sind. Nach dem Update auf linux-lts-5.15.70-1, nvidia-lts-1:515.76-2,nvidia-settings-515.76-1, nvidia-utils-515.76-1 können diese allerdings nicht mehr gefunden werden. Not found.

Eine xorg.conf gibt es wohl nicht mehr.  Und ich bin wohl doch auch nicht allein, wenn ich das richtig sehe. Es soll wohl ein Bug von Nvidia sein.

Da bleibt einen nur übrig abzuwarten.

bei Antwort benachrichtigen
johnT Nachtrag zu: „Hallo und erst mal vielen Dank für die Bemühungen und die Hilfestellung! Nun habe ich den pacman -Q nvidia ,- libgl, ...“
Optionen

Kurzinfo: Ein Update auf nvidia-lts-1:515.76-3 beseitigt bei mir das Problem nicht.

bei Antwort benachrichtigen
johnT Nachtrag zu: „Kurzinfo: Ein Update auf nvidia-lts-1:515.76-3 beseitigt bei mir das Problem nicht.“
Optionen

Triff ebenso auf nvidia-lts-1:515.76-4 so zu.

Aber es gibt langsam Hoffnung. NVIDIA konnten das Problem lokal duplizieren und debuggen es derzeit. Offenbar fehlt die Initialisierung von HDMI, da DisplayPort-Kabel hiervon nicht betroffen sein sollen.

bei Antwort benachrichtigen
johnT Nachtrag zu: „Triff ebenso auf nvidia-lts-1:515.76-4 so zu. Aber es gibt langsam Hoffnung. NVIDIA konnten das Problem lokal duplizieren ...“
Optionen

Der Bug wurde mit Update vom 14.10.2022 von Nvidia behoben. Alles wieder funktionsfähig. Lächelnd

bei Antwort benachrichtigen