Linux 14.935 Themen, 105.676 Beiträge

Dolphin unter KDE

Olaf Runge / 5 Antworten / Baumansicht Nickles

Hi Leute,

sowohl bei OpenSuse Leap 15.3 als auch bei Garuda Linux finde ich keine Möglichkeit beim Dateibrowser Dolphin Benutzername als auch Passwörter von SMB-Netzlaufwerken zu speichern.

Es ist lästig diese immer wieder neu einzugeben.

Wenn ich dann die Netzlaufwerke bzw. -ordner geöffnet habe, kann ich die Dateien nicht öffnen. Ich wollte Musikdateien in Clementine verschieben und öffnen.

Bei einem solch ausgefeilten System wie KDE sollte dies doch möglich sein,

Gruss und Dank für Lösungsvorschläge.

Olaf

bei Antwort benachrichtigen
st.lu Olaf Runge

„Dolphin unter KDE“

Optionen

Hallo,

hatte ähnliche Schwierigkeiten auf meinem Linux-Mint System, das durch einen Eintrag in der /etc/fstab dann gelöst werden konnte.

Wenn die hier

https://wiki.ubuntuusers.de/mount.cifs/

genannten Bedingungen auch bei Dir gegeben sind, könnte auch bei dir ein Eintrag in die fstab villeicht Abhilfe schaffen.

//192.168.178.1/fritz.nas/ /home//fritz_all cifs credentials=/home//.smbcredentials,uid=1000,gid=1000,file_mode=0644,dir_mode=0755,noauto,noserverino,user,users, 0 0

<dein Username> ist dein Anmeldenamen unter Linux, bei der Datei .smbcredentials gibst du dann den Namen und das Password für den Zugriff auf das Netzlaufwerk ein.

Beachte auch, das der eingetragene Text im Zitat bei mir im Orginal nur eine Zeile ist, der hier durch den Editor umgebrochen wird.

Noch ein paar Erläuterungen:

Es geht bei diesem Eintrag auf den Zugriff auf eine Datei in der Fritz-Box (fritz.nas und dann alles weitere),

fritz_all ist der einzurichtende Mount-Point (mit mkdir z.B., Name beliebig, muss dann aber mit dem Eintrag in der fstab übereinstimmen),

.smbcredentials ist ebenfalls ein beliebiger Name,

über noauto wird das Netzlaufwerk nur bei Bedarf manuell eingebunden,

noserverino war nötig geworden nach dem Fritz-Box Update, wo (endlich) die SMB Version auf 3 angehoben wurde,

für den Rest schau in der verlinkten Seite nach (oder entsprechenden).

Nach Eintrag bei mir in die fstab habe ich auf dem Desktop ein verblasstes fritz-all Icon, was ich bei Bedarf anklicke und damit das Netzlaufwerk mounte. Das mag bei deinem System nicht unbedingt so sein.

So, das reicht erst mal für heute, villeicht klappt es ja auch bei Dir damit, ev. Modifikationen nicht ausgeschlossen.

MfG

bei Antwort benachrichtigen
st.lu

Nachtrag zu: „Hallo, hatte ähnliche Schwierigkeiten auf meinem Linux-Mint System, das durch einen Eintrag in der /etc/fstab dann gelöst ...“

Optionen

Nachtrag wg. Umbruch durch den Editor:

nach noauto wird einiges nicht angezeigt, daher ab noauto der Rest hier:

noauto,noserverino,user,users, 0 0

wie gesagt, alles in einer Zeile (//192.168.178.1/  ......   users, 0 0).

bei Antwort benachrichtigen
Olaf Runge st.lu

„Nachtrag wg. Umbruch durch den Editor: nach noauto wird einiges nicht angezeigt, daher ab noauto der Rest hier: wie gesagt, ...“

Optionen

Hallo st.lu,

Danke für die Hinweise. Ich hab diverse Optionen probiert. Ich bekomme die Fehlermeldung: cifs mount permission denied.

Der Hintergrund ist, dass ich ein Tablet-PC als Musikcomputer eingerichtet habe. Da muss drag and drop funktionieren auch vom Netzlaufwerk. Ich hatte vorher Deepin OS installiert da funktionierte dies mit abspeichern des Passwortes im Dateimanager. Aber nach einem Upgarde gab es immer Abspielpausen oder die Musik blieb plötzlich ganz stehen.

Ich finde auch keine knackige Lösung für die obige Fehlermeldung.

Gruss Ound Dan k laf

 

bei Antwort benachrichtigen
st.lu Olaf Runge

„Hallo st.lu, Danke für die Hinweise. Ich hab diverse Optionen probiert. Ich bekomme die Fehlermeldung: cifs mount ...“

Optionen
denied.

Hört sich irgendwie nach Rechte-Problem an.

Ich hatte es jetzt im 1. Posting nicht erwähnt, aber der erwähnte Eintrag war mit vorrangestelltem SUDO gemacht worden.

Weiter kann ich mich noch etwas erinnern, was im Link steht mit der Plazierung der Credentials.

Ich schau mal nach:

Einbindung

Hinweis:

mount.cifs sollte nur transparent über mount -t cifs aufgerufen werden, d. h. mount.cifs tritt für den Benutzer nicht explizit in Erscheinung.

Das Einbinden als CIFS vfs geschieht durch einen Aufruf des Befehls mount mit der Option -t cifs oder über einen Eintrag in der Datei /etc/fstab. Das Aushängen geschieht mittels umount.

Im Folgenden wird zwischen "Einbinden mit hohen Privilegien" und "Einbinden mit niedrigen Privilegien" unterschieden:

  • Einbinden mit hohen Privilegien/systemweit: Um Freigaben mittels mount -t cifs (bzw. mount.cifs) systemweit einzubinden, werden Root-Rechte benötigt.

  • Einbinden mit niedrigen Privilegien: Um Freigaben auch ohne Root-Rechte persönlich einbinden und wieder aushängen zu können, muss für mount.cifs das SUID-Bit gesetzt sein. Dies ist standardmäßig der Fall. Sollte es jedoch einmal nicht der Fall sein, so lässt es sich mit folgender Befehlszeile nachholen:

    sudo chmod +s /sbin/mount.cifs 

Siehe Hinweise in virtuelle Netzwerkdateisysteme.

Mountpunkt erstellen

Um eine Freigabe einzubinden, muss zunächst ein Mountpunkt erstellt werden. Dieser kann im Prinzip an jeder beliebigen Stelle im Dateiverzeichnis gewählt werden. Üblich ist jedoch folgendes Vorgehen:

  • Einbinden mit hohen Privilegien: Der Mountpunkt muss Eigentum von root sein. Soll die Freigabe dauerhaft gemountet werden, eignet sich ein leerer Ordner im Verzeichnis /media. Möchte man die Freigabe nur vorübergehend einbinden, empfiehlt sich ein leerer Ordner in /mnt. Beispiel:

    sudo mkdir /media/austausch 
  • Einbinden mit niedrigen Privilegien: Der Mountpunkt muss Eigentum des jeweiligen Benutzers sein. Es empfiehlt sich ein leerer Ordner in dessen Heimverzeichnis. Beispiel:

    mkdir ~/Daten 

Weitere Informationen finden sich auch in den Artikeln mount und Datenverwaltung.

Soweit aus dem Ubuntu-Wiki.

Ähnliches dürfte auch bei Dir zutreffen (Dateizugriff ist wohl Linux Ebene unterhalb der Benutzeroberfläche).

Wie genau das jetzt auf deinem System zu realisieren ist, kann ich nicht sagen (hab es einfach nicht).

Irgendwie müssen da höhere Rechte gesetzt werden.

MfG

bei Antwort benachrichtigen
Olaf Runge st.lu

„Hört sich irgendwie nach Rechte-Problem an. Ich hatte es jetzt im 1. Posting nicht erwähnt, aber der erwähnte Eintrag ...“

Optionen

Hallo,

mit dem Eintrag in der fstab klappt es nicht - es gibt keinen knackigen Hinweis wo ich die Recht setzen kann - cifs mount . permission denied.

Aber ich habe jetzt bei KDE herausgefunden, wo die smb-Passwörter gespeichert werden - nämlich unter den KDE-Systemeinstellungen - Netzwerk - Verbindungen -Windowsfreigaben..

Danach zeigt Dolphin auch die Netzwerkinhalte an - aber drag and drop funktioniert nur von internen und usb-Laufwerken - nicht von Netzlaufwerken. Hab irgendwo gelesen, dies sei ein Bug in Dolphin.

Jetzt verreise ich aber erst einmal und kümmer mich in 1 Monat wieder um dieses Problem - vielleicht ist der Bug bis dahin behoben.

Gruss und Dank Olaf

bei Antwort benachrichtigen