Linux 14.883 Themen, 105.084 Beiträge

Bunsenlabs-Neuinstallation und Reinfall

tina-w2k / 17 Antworten / Baumansicht Nickles

guten Tag Leute

Ich habe noch den kleinen Lappi-Asus aus der Eee PC series (Intelchipsatz 440Bx) und hatte noch vor ca 3 Jahren das Crunchbang darauf installiert. Als das dann nicht mehr weiter gepflegt wurde, habe ich auf Anraten bunsenlabs installiert und war recht zufrieden. Das Wlan im Gerät erkannte alle Funksender und nach Eingabe der jeweiligen PSWs hatte ich WiFi-Betrieb. Dann stellte sich heraus, dass die Version (leider nicht aufgeschrieben) manche Installationen, wie z.b. Mesiathekview nicht unterstütze und nun habe ich mir das neue ISO runtergeladen, aufgebrannt und installiert.

Leider zeigt sich nun, dass der eingebaute Wlan-Adapter keine SSIDs mehr meldet. Ein Berater in der Uni meinte, dass das Gerät zu alt sei und mit dem neuen BS an dieser Stelle nicht mehr harmoniert. Den Wlan-Hardwareschalter habe ich natürlich auch mehrfach beträtigt, nützt nichts.

Frage: teilt Ihr das Urteil? Gibt es noch die alte Version irgendwo, dass ich sie wieder reinblasen könnte? Was soll/kann ich noch tun? Es täte mir so leid, wenn ich dieses antiquierte, aber liebgewonnene Kästchen deswegen schrotten müsste.

bei Antwort benachrichtigen
luttyy tina-w2k

„Bunsenlabs-Neuinstallation und Reinfall“

Optionen

Habe zwar keine Ahnung von Linux, aber die Kiste hat doch bestimmt einen USB-Anschluß?

Und da müsste doch ein Linux geeigneter W-LAN-Stick zur Not Abhilfe schaffen..

Gruß

bei Antwort benachrichtigen
Alpha13 tina-w2k

„Bunsenlabs-Neuinstallation und Reinfall“

Optionen

https://kelaino.bunsenlabs.org/ddl/Archive/

Und da nimmt man natürlich ne alte i386 NON PAE ISO!

bei Antwort benachrichtigen
fakiauso tina-w2k

„Bunsenlabs-Neuinstallation und Reinfall“

Optionen

Gib mal die genaue Bezeichnung des EEE an. Vermutlich fehlt da bei einem proprietären Chipsatz nur die Firmware oder so.

Du kannst auch auf der Konsole laufen lassen:

lspci

lsusb

Dann sollten die angeschlossenen Geräte angezeigt werden und dabei auch der WLAN-Adapter.

Manchmal ist das Ding auch blockiert. Dann hilft rfkill list. Lies auch mal im Link die spezifischen Probleme bei bestimmten Geräten.

https://wiki.ubuntuusers.de/rfkill/

Hast Du den Networkmanager installiert, dann kannst Du es auch mal mit Wicd versuchen, das ist ggf. zuverlässiger.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
tina-w2k fakiauso

„Gib mal die genaue Bezeichnung des EEE an. Vermutlich fehlt da bei einem proprietären Chipsatz nur die Firmware oder so. ...“

Optionen

danke  @faki

hier zunächst die genaue Modellbezeichnung: ASUS Eee PC 4G

um Deine anderen Hinweise kann ich mich erst morgen kümmern, da dann wieder zu Hause

mfg

bei Antwort benachrichtigen
tina-w2k

Nachtrag zu: „danke @faki hier zunächst die genaue Modellbezeichnung: ASUS Eee PC 4G um Deine anderen Hinweise kann ich mich erst morgen ...“

Optionen

Der Befehl lspci lieferte:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 04)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
03:00.0 Ethernet controller: Qualcomm Atheros Attansic L2 Fast Ethernet (rev a0)

Der Befehl lsusb lieferte:

Bus 001 Device 003: ID eb1a:2761 eMPIA Technology, Inc. EeePC 701 integrated Webcam
Bus 001 Device 002: ID 0951:1606 Kingston Technology Eee PC 701 SD Card Reader [ENE UB6225]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

der Befehl rfkill list:

0: eeepc-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

weiter bin ich noch nicht gekommen

gruss @faki

bei Antwort benachrichtigen
fakiauso tina-w2k

„Der Befehl lspci lieferte: 00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM ...“

Optionen

https://wiki.ubuntuusers.de/rfkill/#Kernelmodul-ist-nicht-geladen

Versuche bitte folgendes:

sudo rfkill unblock phy0

sudo modprobe eeepc_laptop

Mit etwas Glück wird dann das korrekte Kernel-Modul geladen und WLAN läuft. Ggf. auch den Kniff mit Drücken der WLAN-Taste versuchen und statt des Networkmanagers WiCD für das Verwalten des WLAN nutzen.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
tina-w2k fakiauso

„https://wiki.ubuntuusers.de/rfkill/ Kernelmodul-ist-nicht-geladen Versuche bitte folgendes:sudo rfkill unblock phy0sudo ...“

Optionen

muss bei den Befehlen der Laptop per Ethernetkabel am Internet hängen oder geht es offline? Per Kabel klappt es ja mit dem Netzanschluss.

beim ersten Befehl sagt er: bogus unblock argument 'phy0'

beim zweiten sagt er nichts

wlan geht nicht

wie nutze ich WICD?

also bei rfkill list   sagt er immer: soft blocked yes  unter phyx

egal ob ich den Wlan Tastenschalter gedrückt habe oder nicht

bei Antwort benachrichtigen
fakiauso tina-w2k

„muss bei den Befehlen der Laptop per Ethernetkabel am Internet hängen oder geht es offline? Per Kabel klappt es ja mit dem ...“

Optionen
muss bei den Befehlen der Laptop per Ethernetkabel am Internet hängen oder geht es offline? Per Kabel klappt es ja mit dem Netzanschluss.


Dafür muss die Kiste nicht angeschlossen sein.

Unabhängig von allem würde ich trotzdem per LAN anschliessen und eine komplette Systemaktualisierung durchführen.

Um WiCD zu installieren, brauchst Du sowieso Internet.

Wenn ich das Richtig gesehen habe, musst Du das WLAN "auf BIOS-Ebene" drücken, ergo beim Booten die WLAN-Taste drücken.

Laut Angaben von Asus hat Dein EEE ein Atheros-WLAN und das sollte aus dem Stand laufen.

So als weiterer Ansatzpunkt kommt noch das falsch geladene acer_wmi in Betracht:

https://forum.ubuntuusers.de/topic/wlan-wird-abeschaltet/3/

https://wiki.ubuntuusers.de/rfkill/#Modul-acer-wmi

Also dann das Modul erst abfragen:

sudo lsmod | grep acer

Befindet sich besagtes Mudol in der Treiberliste, dann entlade es mit:

sudo rmmod acer_wmi

Anschliessend lädst Du das (wahrscheinlich) für Dein Gerät passende Modul:

sudo modprobe eeepc_laptop

HTH

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
tina-w2k fakiauso

„Dafür muss die Kiste nicht angeschlossen sein. Unabhängig von allem würde ich trotzdem per LAN anschliessen und eine ...“

Optionen

danke, bin gerade gekommen und versuche alles melde mich dann wieder

p.p den Harwareschalter für das Wlan kann man meines Wissens auch mitten im Betrieb drücken und damit die Funktion ein-und ausknipsen, aber vlt irre ich mich

bei Antwort benachrichtigen
tina-w2k

Nachtrag zu: „danke, bin gerade gekommen und versuche alles melde mich dann wieder p.p den Harwareschalter für das Wlan kann man meines ...“

Optionen

sehr peinlich für mich, aber das Wlan war im Bios ausgeschaltet. Habe es aktiviert, aber es geht trotzdem nicht. Es gibt also eine Hierarchie von Wlan-Schaltern: Bios, dann Taste F2 mit grüner Vortaste und dann noch das Betriebsystem, hier bs-Helium. Wie die ersten beiden zusammenarbeiten - keine Ahnung

rfkill list sagt: eeepc-wlan, softblocked yes, hardblocked no

acer_wmi habe ich löschen wollen, aber da sagt er: 'es ist nicht geladen'

das modprobe eeepc_laptop schluckt er nach psw-eingabe kommentarlos

sag mal: die neue Version ist im iso-downloadbereich nicht mehr als NonPAE gekennzeichnet, im gegensatz zu den beiden vorgerigen (Hydrogen und Deuterium). Hat das was zu sagen? Soll ich Deuterium mal laden? Hatte ja vorher Hydrogen, da lief es ja, war aber veraltet, konnte damals (glaube Mediathekview nicht mehr installieren)

gruss, morgen weiter wenn Du noch nicht frustriert abfällst

bei Antwort benachrichtigen
fakiauso tina-w2k

„sehr peinlich für mich, aber das Wlan war im Bios ausgeschaltet. Habe es aktiviert, aber es geht trotzdem nicht. Es gibt ...“

Optionen
gruss, morgen weiter wenn Du noch nicht frustriert abfällst

Bumms...

sag mal: die neue Version ist im iso-downloadbereich nicht mehr als NonPAE gekennzeichnet, im gegensatz zu den beiden vorgerigen (Hydrogen und Deuterium). Hat das was zu sagen?

Es gibt aber noch die No-PAE, wobei Du das schon gemerkt hättest, weil sich die 32bit-Version dann m.E. gar nicht hätte installieren lassen.

https://www.bunsenlabs.org/installation.html

Die Sache mit den Modulen sieht doch jetzt schon mal gar nicht so schlecht aus und im Grunde geht es "nur" noch darum, den softblocked wegzubekommen.

Hast Du nochmal versucht, die Sperre mittels unblock aufzuheben?

sudo rfkill unblock eeepc-wlan

Das Ausschalten im BIOS war mal eine Macke, wo sich zwar über Hotkey das WLAN abschalten liess, aber nicht mehr an und dann auch im BIOS deaktiviert war.

Daher installiere über LAN tatsächlich mal WiCD, denn das kann soweit ich das in Erinnerung habe, das WLAN-Modul auch aus sich heraus starten. Zumindest hatte ich da bei "schwierigen" Chipsätzen eher Erfolg als über den Netzwerkmanager.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
tina-w2k fakiauso

„Bumms... Es gibt aber noch die No-PAE, wobei Du das schon gemerkt hättest, weil sich die 32bit-Version dann m.E. gar ...“

Optionen

sudo rfkill unblock eeepc-wlan

hab ich gemacht. er sagt wieder 'Bogus unblock argument 'eeepc-wlan'

verträgt der das irgendwie nicht?

gute Nacht

das mit WiCD mach ich morgen.

äh, was muss ich da am Kabel hängend eingeben, vlt

sudo apt-get install WiCD?

bei Antwort benachrichtigen
fakiauso tina-w2k

„sudo rfkill unblock eeepc-wlan hab ich gemacht. er sagt wieder Bogus unblock argument eeepc-wlan verträgt der das ...“

Optionen
sudo apt-get install WiCD?


Versuche es mal mit:

sudo apt-getinstall wicd firmware-linux

Im Paket firmware-linux sollten auch die Firmwares für Atheros drin sein, falls das nötig wäre.

Falls das Ding von Atheros auch Bluetooth mit druaf hat, kannst Du es auch damit versuchen:

sudo rfkill unblock all

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
tina-w2k fakiauso

„Versuche es mal mit:sudo apt-getinstall wicd firmware-linux Im Paket firmware-linux sollten auch die Firmwares für ...“

Optionen

also (sprach die Frau Mama):

das von Dir angegebene.. getinstal...l hab ich durch ...get install.. ersetzt (so weit bin ich in Linux schon gekommen, oh Wunder)

dann orgelte der ne Weile rum und anschliessend habe ich einen Neustart gemacht. da wurde dann auch der Marker für die WICD Funknetztverwaltung angezeigt (oben rechtszwei verschachtelte Bildschirme)

rufe ich das WICD-Panel auf, sagt der: kein Netzwerkname vorhanden

obwohl ich hier an einer Funkumgebung arbeite (anderer Laptop, Radio) und die Telekombox natürlich Wlan aktiviert ist.

sudo rfkill unblock all eingegeben

dann rfkill list:

0 eeepc-wlan: wireless LAN

       soft b: no

       harb b: no

2:    phy1: wireless lan

       soft b: yes

       hard b: no

nach wie vor Funkstille

so, mein Lieber, jetzt ist der Ball wieder bei you

bei Antwort benachrichtigen
tina-w2k

Nachtrag zu: „also sprach die Frau Mama : das von Dir angegebene.. getinstal...l hab ich durch ...get install.. ersetzt so weit bin ich ...“

Optionen

p.s. ich  habe mal das Bios nachgesehen. es ist die Version 0801 von 01/08/08

also, wenn man das rückwärts lesen soll, wäre es von 2001

die Firmware hat die Nummer 701_073

ich habe ein neueres Bios bei Asus ausfindig gemacht: eine .ROM-Datei mit der Bezeichnung 701-asus-1303.ROM

für das Gerät EeePC G4/Linux

das müsste ja passend sein. soll ich das reinpfeifen? mir fehlt dazu nur noch ein Ladeprogramm. Die sprachen von Flash unter Windows. das habe ich ja nicht drauf.

aber vlt ist  das alles auch nicht nötig, da @Faki eine scheniale Idee hat.

beste Grüsse

T

bei Antwort benachrichtigen
Alpha13 tina-w2k

„p.s. ich habe mal das Bios nachgesehen. es ist die Version 0801 von 01/08/08 also, wenn man das rückwärts lesen soll, ...“

Optionen

https://wiki.debian.org/de/EeePC/HowTo/UpgradeBIOS

https://www.asus.com/de/supportonly/Eee%20PC%204GLinux/HelpDesk_BIOS/

Die Biose sind da natürlich von 2007 - 2009 und das neueste Bios hilft da AFAIK nicht.

Zudem kannst du die Kiste durch ein Biosupdate natürlich auch endgültig schrotten.

2001 paßt da nur zu deiner falschen Annahme die Kiste hätte nen "Intelchipsatz 440Bx", was definitiv nicht stimmt!

https://en.wikipedia.org/wiki/Intel_440BX

https://de.wikipedia.org/wiki/Intel-Chips%C3%A4tze#Pentium_M/Celeron_M_(Mobil)

https://www.linux-magazin.de/ausgaben/2008/01/sympathischer-rechner-zwerg/

Das 701 hat natürlich immer nen 915GM Chipsatz!

Was man da macht habe Ich dir schon gesagt.

bei Antwort benachrichtigen
fakiauso tina-w2k

„p.s. ich habe mal das Bios nachgesehen. es ist die Version 0801 von 01/08/08 also, wenn man das rückwärts lesen soll, ...“

Optionen

Das Update würde ich trotzdem machen und anschliessend oder auch jetzt mal ein CMOS-Clear oder wenigstens im BIOS die Defaults laden.

Wie das Update funktioniert, hat Alpha13 bereits verlinkt.

Warum sich das jetzt so sparrig hat, kann ich mir auch nicht erklären, noch dazu weil es vorher ja lief. Anscheinend muss das trotzdem etwas mit Firmware oder so zu tun haben, denn bei Asus gibt es noch eine Anleitung für das original installierte Linux, mit welchem ein "Patch" für das WLAN installiert wird:

https://dlcdnets.asus.com/pub/ASUS/EeePC/EeePC4G(701)/SOP_for_701_WIFI_installation.zip

Der bekloppte Atheros 5211 sollte normalerweise aus dem Stand laufen. Eine weiter Aktion wäre noch das Anschliessen eines WLAN-Sticks, damit dieser ggf. beim verbinden das eingebaute WLAN mit "hochzieht". Das ist irgendeine Softwaremacke, die ich so ähnlich schon mal mit einem Medion hatte und dort liess sich das dann über die acer_hk lösen, mit denen das Aktivieren per Fn+F2 funktionierte.

acer_hk ist aber out und durch acer_wmi ersetzt. Wenn ich das teil vor mir hätte, sähe es anders aus.

Hier gibt es auch noch zwei Geschichten dazu und der Networkmanager wurde ja wahrscheinlich bei der Installation von wicd entfernt? Denn sonst kommen sich die Tools in die Quere.

https://ubuntuforums.org/showthread.php?t=2175271

https://peppermintos.net/viewtopic.php?f=11&t=5916


Und hier hatte der User auch keine Probleme beim Installieren der Distri:

https://askubuntu.com/questions/418246/ubuntu-on-an-asus-eee-pc-4g-701/1131000#1131000

https://askubuntu.com/questions/27099/asus-eee-pc-701-4g-hangs-on-boot/1130998#1130998

Das einzige Problem, welches erwähnt wird, ist der nicht erkannte Cardreader, der aber als erste Bootquelle im BIOS und mit der Option "OS installed" auf "Finished" laufen soll...

Ansonsten gehen mir bis auf BIOS-Upgrade/Default Settings und ggf. noch ein neuer Installationsversuch so langsam die Ideen aus.

Wenn Helium in der Live-Version das WLAN aktivieren kann, dann böte sich auch eine Installation aus dieser an. Dabei sollen die Einstellungen für WLAN usw. nämlich gleich in das System übernommen werden.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen