Linux 14.802 Themen, 104.275 Beiträge

Wlan nicht aktivierbar

rednaxela / 22 Antworten / Baumansicht Nickles

Hallo Experten,
ich habe einem Medion Laptop E5214 Lubuntu 18.04 spendiert.
Die Bootzeit war dann nach etlichen Fehlermeldungen unertr?glich langsam. Das System lief dann aber gut...
Ich habe recherchiert und bin zu einer Loesung gekommen:
Das habe ich dann gemacht:

This is a bug. To avoid delay you can use workaround. From terminal run:

sudo nano /etc/default/grub
Then add the kernel boot parameter: video=SVIDEO-1:d, so it will look like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

sudo update-grub
sudo reboot

danach bootet das Laptop in normaler Zeit, ich war zufrieden.
Aber das Wlan l?sst sich ums Verrecken nicht per Tastenkombi Fn+F1 einschalten.

Zuvor hatte ich Linux Mint Mate tara installiert mit gleicher Bootzeit...ca. 5 min...
da lief das Wlan aber... ich hatte da aber die grub-Modifikation noch nicht durchgef?hrt. Ich weiss auch nicht, was sie eigentlich bewirkt... ich wollte es aber leichter und deshalb Lubuntu...

hat jemand eine Idee zu diesem Problem?
Ich w?rde mich sehr ?ber eure Meinungen freuen

Mfg Alex.

bei Antwort benachrichtigen
VC1541 rednaxela

„Wlan nicht aktivierbar“

Optionen

Poste mal die Ausgabe von "sudo ifconfig"

bei Antwort benachrichtigen
rednaxela VC1541

„Poste mal die Ausgabe von sudo ifconfig“

Optionen

Hallo VC1541,

seine Antwort lautet: Befehl nicht gefunden

was mache ich falsch?

bei Antwort benachrichtigen
VC1541 rednaxela

„Hallo VC1541, seine Antwort lautet: Befehl nicht gefunden was mache ich falsch?“

Optionen

sudo apt-get install net-tools machen. Dann nochmal.

bei Antwort benachrichtigen
rednaxela VC1541

„sudo apt-get install net-tools machen. Dann nochmal.“

Optionen

Hallo zusammen,

sudo ifconfig ergibt folgendes:

enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.40  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fe80::8448:c4d8:8790:1661  prefixlen 64  scopeid 0x20<link>
        ether 00:1f:16:1d:77:a6  txqueuelen 1000  (Ethernet)
        RX packets 6558  bytes 6135234 (6.1 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 5272  bytes 825838 (825.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Lokale Schleife)
        RX packets 546  bytes 49342 (49.3 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 546  bytes 49342 (49.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

mfG Alex

bei Antwort benachrichtigen
fakiauso rednaxela

„Hallo zusammen, sudo ifconfig ergibt folgendes: enp2s0: flags 4163 mtu 1500 inet 192.168.178.40 netmask 255.255.255.0 ...“

Optionen

Da wird Dein WLAN gar nicht aufgeführt.

Die erste Schnittstelle ist LAN, die zweite das Loopback-Interface.

Wahrscheinlich hast Du mittels der tastenkombi das Ding komplett deaktiviert und jetzt kannst Du es mangels Software nicht mehr einschalten.

acerhk als Modul dürfte bei einer aktuellen Distri wie 18.04 keine Rolle mehr spielen, prüfe daher mal, ob Du mit rfkill das WLAN aktivieren kannst und schaue auch, ob WLAN nicht im BIOS mit deaktiviert wurde.

sudo rfkill list zeigt Dir die Funk-Schnittstellen an.

Eine Übersicht der Devices erfährst Du mit:

lspci
lsusb

Oder Du benennst Dein Medion-Teil. Für prprietäre hardware kann es sein, dass Du noch eine zusätzliche Firmware benötigst, die bei 18.04 nicht mehr von Haus aus mitinstalliert wird.

Entweder suchst Du direkt über zusätzliche Treiber oder Du installierst die Firmwares direkt per sudo apt-get install linux-firmware und startest einfach neu.

Noch etwas Input:

https://wiki.ubuntuusers.de/WLAN/#WLAN-Sondertasten

https://wiki.ubuntuusers.de/WLAN/#Hardware-und-Treiber


Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
rednaxela fakiauso

„Da wird Dein WLAN gar nicht aufgeführt. Die erste Schnittstelle ist LAN, die zweite das Loopback-Interface. Wahrscheinlich ...“

Optionen

sudo rfkill list zeigt:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

firmware ist aktuell

bei Antwort benachrichtigen
fakiauso rednaxela

„sudo rfkill list zeigt: 0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes firmware ist aktuell“

Optionen

Dann  ist das Ding hardwareseitig geblockt.

BIOS hast Du geprüft?

Was bewirkt sudo rfkill unblock phy0?

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
rednaxela fakiauso

„Dann ist das Ding hardwareseitig geblockt. BIOS hast Du geprüft? Was bewirkt sudo rfkill unblock phy0?“

Optionen

diese Ausgabe:

invalid identifier: phy0

im bios gibt es 2 Optionen:

bei Antwort benachrichtigen
rednaxela

Nachtrag zu: „diese Ausgabe: invalid identifier: phy0 im bios gibt es 2 Optionen:“

Optionen

disabled oder last state

bei Antwort benachrichtigen
rednaxela

Nachtrag zu: „disabled oder last state“

Optionen

bei beiden Optionen das gleiche Ergebnis

bei Antwort benachrichtigen
fakiauso rednaxela

„bei beiden Optionen das gleiche Ergebnis“

Optionen

Lies Dir mal das durch:

https://wiki.ubuntuusers.de/rfkill/

Auch darunter den Absatz zu acer_wmi und ggf. die Bootoptionen fűr rfkill. Ein Windows parallel hast Du nicht installiert,welches beim Ausschalten  den Adapter deaktiviert? Last Stage ist zumindest die richtige Option und ein BIOS-Reset kann auch helfen. Dann musst  Du natürlich die restlichen  Optionen auch neu einrichten.

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
rednaxela fakiauso

„Lies Dir mal das durch: https://wiki.ubuntuusers.de/rfkill/ Auch darunter den Absatz zu acer_wmi und ggf. die Bootoptionen ...“

Optionen

nein, da ist nur Lubuntu drauf...

sehr interessant, der Artikel.. sowas ähnliches hab ich auch auf englisch gelesen... ich muss erst mal weg....

Fakiauso, erstmal vielen leben Dank fuer Deine Muehe. Echt verdammt nett. Das muss ich hier deutlich sagen....

bei Antwort benachrichtigen
fakiauso rednaxela

„nein, da ist nur Lubuntu drauf... sehr interessant, der Artikel.. sowas ähnliches hab ich auch auf englisch gelesen... ich ...“

Optionen
nein, da ist nur Lubuntu drauf...


Schade - mit Last State im BIOS und einer Live-Distri, welche das Kernel-Modul drin hat , WLAN aktivieren kann und dann beim Herunterfahren aktiviert lässt, kann es auch klappen.

Plan B wäre dann der Weg über wistron btns.

Es kann dann noch folgendermaßen funktionieren:

http://kushellig.de/linux-ubuntu-fn-funktionstasten-helligkeit/

Wobei hier die Geschichte mit acpi_osi=linux wichtig sein dürfte, acpi_backlight=vendor  aber auch nix schaden dürfte.

Oder so wie hier dann noch die ganze Reisebeschreibung mit wistron_btns, bei der sich das Ding dann mittels last_state im BIOS wieder hochholen lassen sollte.

Ist halt immer blöd, wenn Hersteller solche essentiellen Dinge in Software realisieren...

Ansonsten danke für das Dankeschön;-)

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
rednaxela fakiauso

„Schade - mit Last State im BIOS und einer Live-Distri, welche das Kernel-Modul drin hat , WLAN aktivieren kann und dann ...“

Optionen

Hallo Fakiauso,

tolle Gedanken und Lösungsansätze.

Ich habe wistron ausgeführt, das kennt er aber nicht. 

Ich verstehe das jetzt ansatzweise... 

Es war ein geschrottetes Vista drauf, daher kommt wahrscheinlich die wlan Aktivierung...dann hab ich mate drauf gemacht, dann lief sogar  nach dem Booten das wlan....dann hab ich Lubuntu installiert und wlan war nicht mehr zu aktivieren.

Welche live DVD nehme ich am besten für das Experiment?

Ich konnte das andere noch nicht probieren, da ich gerade sehr eingespannt bin..

Vielen lieben Dank

bei Antwort benachrichtigen
fakiauso rednaxela

„Hallo Fakiauso, tolle Gedanken und Lösungsansätze. Ich habe wistron ausgeführt, das kennt er aber nicht. Ich verstehe ...“

Optionen

Dann nimm doch gleich das MATE...

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
rednaxela fakiauso

„Dann nimm doch gleich das MATE...“

Optionen

Das wäre zu überlegen..

Aber mit Lubuntu läuft die Gurke ein bißchen flotter.

Und es ist fraglich, ob das nur wegen last state ging... 

Ich war sehr zufrieden, hatte die Bootdatei angepasst, die Kiste läuft echt gut nur kein wlan... 

Ich hatte gehofft, daß das einfacher ist...

bei Antwort benachrichtigen
fakiauso rednaxela

„Das wäre zu überlegen.. Aber mit Lubuntu läuft die Gurke ein bißchen flotter. Und es ist fraglich, ob das nur wegen ...“

Optionen
Aber mit Lubuntu läuft die Gurke ein bißchen flotter.


Neeee - schon Lubuntu drauf lassen, aber mit Mint MATE als Live-Distri das Ding quasi "fremdstarten" und hoffen, dass bei damit eingeschaltetem WLAN und Last State im BIOS dann auch hinterher das Ding wieder aktiviert ist.

Ist das eine der älteren MD98xxx von Medion? Vielleicht findet sich explizit über das Gerät auch schneller ein Würgaround.

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
rednaxela fakiauso

„Neeee - schon Lubuntu drauf lassen, aber mit Mint MATE als Live-Distri das Ding quasi fremdstarten und hoffen, dass bei ...“

Optionen

Ach so... Ich probiere das mal aus

Das ist ein E5214...klar, der ist alt

10 Jahre oder so

bei Antwort benachrichtigen
rednaxela

Nachtrag zu: „Ach so... Ich probiere das mal aus Das ist ein E5214...klar, der ist alt 10 Jahre oder so“

Optionen

Das hat alles nix gebracht...

ich habe Mate live DVD gestartet...nix. Die Hardwareaktivierung kam wohl noch von Vista. Komisch ist, dass ich wistron nicht habe, obwohl es doch im Kernel enthalten sein soll.

Ein paar Fn Tasten habe ich jetzt mehr in Funktion, aber nicht die WLAN-Taste...

bei Antwort benachrichtigen
fakiauso rednaxela

„Das hat alles nix gebracht... ich habe Mate live DVD gestartet...nix. Die Hardwareaktivierung kam wohl noch von Vista. ...“

Optionen
Die Hardwareaktivierung kam wohl noch von Vista.


Das ist relativ wahrscheinlich. Schaltet man dann das WLAN aus (was ja blöderweisegeht), dann ist es eben aus. Hattest Du als Option Last State im BIOS aktiv, als Du mit MATE gestartet hast?

Sonst würde ich das mit dem Modul wistron_btns trotzdem nochmal versuchen so wie in dieser Anleitung von MINT:

Du kannst ja die Befehl mittels Copy&Paste in die Konsole geben und auch die Ausgaben vergleichen und ggf. hier einstellen.

https://www.linuxmintusers.de/index.php?topic=19560.0

sudo modprobe -v wistron_btns

Der Schalter -v steht für verbose=gesprächig, und mit dem weiteren Verlauf des Threads im MINT-Forum sollte sich die Macke doch finden lassen.

Vielleicht hilft Dir auch explizit dieser Beitrag aus besagtem Thread schnell über die Latte:

https://www.linuxmintusers.de/index.php?topic=19560.msg255795#msg255795

Aber keene Bange, in letzter Zeit geht es auch bei mir nur noch mit x Anläufen und über Eck: Zahnriemen beim Auto, OT-Geber beim nächsten Auto, Drucker verreckt, ein Reparatur-Laptop mit W8.1 zickt seit Wochen und ich finde keinen Hebel - also keep cool und shit happens, bei mir gibt es erstmal ein Faxe...

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
rednaxela fakiauso

„Das ist relativ wahrscheinlich. Schaltet man dann das WLAN aus was ja blöderweisegeht , dann ist es eben aus. Hattest Du ...“

Optionen

Hey Fakiauso,

nochmals vielen lieben Dank für Deinen Einsatz und Deine Hilfsbereitschaft.

Ich habe letztendlich die Nerven verloren und den Hardwareweg beschritten: Die Karte ist ja standardmässig an und wird über Software (MS+Treiber) aus oder wieder angeschaltet und verharrt dann durch last state in diesem Zustand... Keine Ahnung wie ich die unter Linux ausgekriegt habe...

Also habe ich die Möglichkeit zum Ausschalten unterbunden, ich habe pin 20 auf der PCI-e Karte abgeklebt; jetzt läuft sie dauerhaft während keine WLAN Leuchte leuchtet.

Die Karte ist permanent an und lässt sich nicht mehr abschalten.

Diese zwei Beiträge hatte ich gefunden:

http://adrian.kochs-online.net/2014/07/31/herr-aldi-ist-nicht-tot/  und

https://richarddouglasdenton.wordpress.com/2011/05/11/how-to-bypass-a-laptop-wireless-switch/

noch weiterhin viel Glück bei Deinen Projekten. Du scheinst ja wirklich vieles selber zu machen...

Also mach es gut...

Viele Grüsse, Alex

bei Antwort benachrichtigen
fakiauso rednaxela

„Hey Fakiauso, nochmals vielen lieben Dank für Deinen Einsatz und Deine Hilfsbereitschaft. Ich habe letztendlich die Nerven ...“

Optionen
Ich habe letztendlich die Nerven verloren und den Hardwareweg beschritten

Wenn es sogar nicht anders geht, auch wenn´s unelegant ist...;-)

noch weiterhin viel Glück bei Deinen Projekten.


Naja - in letzter Zeit eher weniger...

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen