Linux 14.821 Themen, 104.500 Beiträge

Griffith auf Ubuntu zum laufen bringen

zarastro / 25 Antworten / Baumansicht Nickles

Hallo Linux Experten,

ich versuche seit einigen Tagen Griffith auf Ubuntu zum laufen zu bringen. Die

Installation ist gelungen, leider startet das Programm nicht.

Ich versuche es auf einen Gigabyte GA-Z87-D3HP mit Linux Mint und Ubuntu

Studio.

Ich hoffe Ihr könnt mir weiter .

Gruß

Zarastro.

bei Antwort benachrichtigen
the_mic zarastro

„Griffith auf Ubuntu zum laufen bringen“

Optionen

- Wie genau bist du vorgegangen, um das Programm zu installieren?

- Gibt es eine Fehlermeldung wenn du es startest? Was passiert, wenn du es via Konsole startest (Terminalfenster öffnen und dort mal griffith [enter] eingeben)?

cat /dev/brain > /dev/null
bei Antwort benachrichtigen
zarastro the_mic

„- Wie genau bist du vorgegangen, um das Programm zu ...“

Optionen

Hallo the_mic,

danke fuer Deine Antwort. Ich habe "griffith [enter]" eingegeben und bekomme

folgende Antwort

raceback (most recent call last):
File "/usr/bin/griffith", line 86, in <module>
import add
File "/usr/share/griffith/lib/add.py", line 31, in <module>
import quick_filter
File "/usr/share/griffith/lib/quick_filter.py", line 25, in <module>
import db
File "/usr/share/griffith/lib/db/__init__.py", line 30, in <module>
from _objects import *
File "/usr/share/griffith/lib/db/_objects.py", line 33, in <module>
import validators
File "/usr/share/griffith/lib/db/validators.py", line 26, in <module>
ImportError: cannot import name InstrumentationManager

Gruß

Zarastro.

bei Antwort benachrichtigen
fakiauso zarastro

„Griffith auf Ubuntu zum laufen bringen“

Optionen
Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
zarastro fakiauso

„Hilft das:http://wiki.ubuntuusers.de/Griffith ...“

Optionen

fakiauso,

danke fuer Deine Hilfe, der Link war natürlich meine erste Idee.

Gruß

Zarastro.

bei Antwort benachrichtigen
fakiauso zarastro

„fakiauso, danke fuer Deine Hilfe, der Link war natürlich ...“

Optionen
danke fuer Deine Hilfe, der Link war natürlich meine erste Idee.


Moin
Und die Fehlermeldung ist dieselbe wie bei Dir!

Hast Du dann auch den Würgaround darunter durchgeführt:

Beheben kann man das Problem, indem man die Datei validators.py {dl} herunterlädt und mit Root-Rechten in das Installationsverzeichnis verschiebt:
Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
zarastro fakiauso

„Moin Und die Fehlermeldung ist dieselbe wie bei Dir! Hast ...“

Optionen

Guten Tag fakiauso,

ich bin noch relativ neu bei Linux und verstehe offenbar den Begriff Root-Rechte

nicht. Wie komme ich in die Root Rechte ? Ich habe "sudo abt-get"  und Pass-

wort eingegeben, das wurde aber nicht akzeptiert.

Gruss

Zarastro.

bei Antwort benachrichtigen
the_mic zarastro

„Guten Tag fakiauso, ich bin noch relativ neu bei Linux und ...“

Optionen

Root-Rechte verschaffst du dir unter Ubuntu, indem du dem Befehl "sudo" voranstellst. Danach musst du dein Passwort eingeben.

Das funktioniert aber nur, wenn du a) das Passwort korrekt eingibst und b) du den Benutzer verwendest, der bei der Installation angelegt wurde (natürlich funktioniert es auch mit nachträglich angelegten Benutzern, diese müssen aber Mitglied der Gruppe "admin" sein)

Korrekterweise heisst der Befehl "apt-get" und erfordert noch weitere Argumente. Was ist die genaue Fehlermeldung, die du erhalten hast? Du kannst diese hier posten, indem du sie in der Konsole markierst und mit Klick auf die mittleren Maustaste (Mausrad) am gewünschten Ort einfügst

cat /dev/brain > /dev/null
bei Antwort benachrichtigen
fakiauso zarastro

„Guten Tag fakiauso, ich bin noch relativ neu bei Linux und ...“

Optionen

Moin

Einiges hat the_mic schon erklärt.

Herunterladen kannst Du die Datei validators.py, indem Du unter Firefox einen Rechtsklick auf den Link machst und dann "Ziel speichern unter..." anklickst.
Dann wählst Du Dein Download-Verzeichnis als Ziel aus und speicherst die Datei dort.
Nachdem the_mic schon den feinen Hinweis gegeben hat, wie Du mit gedrückter linker Maustaste einen Text kopierst und durch Klick auf das Mausrad an der gewünschten Stelle wieder einfügst, kannst Du das gleich einmal praktisch versuchen.
Im Wiki befindet sich ein grauer Kasten mit den erforderlichen Befehlen für die Konsole/das Terminal, diese kannst Du von dort oder hier aus meinem Beitrag genauso einkopieren und anschliessend mit Enter ausführen, dabei bitte Zeile für Zeile vorgehen, sonst wird es u.U. Murks:-)

sudo mv /usr/share/griffith/lib/db/validators.py /usr/share/griffith/lib/db/validators.py.backup

sudo mv /home/<USER>/Downloads/validators.py /usr/share/griffith/lib/db/

sudo chown root:root /usr/share/griffith/lib/db/validators.py

sudo chmod 644 /usr/share/griffith/lib/db/validators.py


PS.

- Das root-Passwort ist unter Ubuntu üblicherweise identisch mit dem des ersten Benutzers, also vermutlich Dein eigenes

- Statt <USER> im zweiten Befehl fährst Du den Cursor an die Stelle in der Befehlszeile und änderst diesen Eintrag in den Namen Deines /home-Verzeichnisses, also ggf. zarastro

Bei Anfällen von Panik und Misserfolg einfach wieder hier schreien;-)

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
zarastro fakiauso

„Moin Einiges hat the_mic schon erklärt. Herunterladen ...“

Optionen

Guten Tag fakiauso, guten Tag the_mic.

danke für Eure Hilfe. fakiauso ich habe Deine Befehle eingegeben und bekomme

folgende Fehlermeldung.

mv: das angegebene Ziel »/usr/share/griffith/lib/db/validators.py“ ist kein Verzeichnis

Gruss

Zarastro.

bei Antwort benachrichtigen
fakiauso zarastro

„Guten Tag fakiauso, guten Tag the_mic. danke für Eure ...“

Optionen

Moin

Da ist vermutlich beim Kopieren etwas schiefgegangen wegen des Zeilenumbruchs. Du kannst auch erst in das betreffende Verzeichnis wechseln:

cd /usr/share/griffith/lib/db/

Dann benennst Du die Datei direkt dort um:

mv validators.py validators.py.backup

Anschliessend verschiebst Du die heruntergeladene Datei wie gehabt vom Downloadverzeichnis in das Arbeitsverzeichnis und passt Besitzer und Rechte an:

sudo mv /home/<USER>/Downloads/validators.py /usr/share/griffith/lib/db/
sudo chown root:root /usr/share/griffith/lib/db/validators.py


sudo chmod 644 /usr/share/griffith/lib/db/validators.py

Noch ein paar Hinweise - beim Verzeichniswechsel oder überhaupt bei Eingaben auf der Konsole kannst Du mittels der Tabulator-Taste das Autovervollständigen nutzen:

http://linuxundich.de/gnu-linux/tipps-und-tricks-fur-den-alltag-mit-linux-ii/

Wenn Du nicht ständig sudo voransetzen möchtest und nach Ablaufen der voreingestellten Zeit das root-Passwort erneut eingeben musst, kannst Du über

sudo su
Passwort

auf der Konsole dauerhaft root werden. Zu sehen ist das daran, dass sich das Dollarzeichen am Ende der befehlszeile in ein Lattenkreuz verwandelt.
Hast Du die administrativen Eingaben beendet, gibst Du entweder exit ein, drückst Strg+D oder schliesst einfach die Konsole.

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
zarastro fakiauso

„Moin Da ist vermutlich beim Kopieren etwas schiefgegangen ...“

Optionen

Guten Tag fakiauso,

ich habe es noch einmal mit Deinen neuen Vorschlägen bei Linux Mint

probiert, wieder eine Fehleranzeige, dann folgte Ubuntu Studio, dort

ist Griffith sogar in der Anwendungsverwaltung, es funktionierte auch

nicht. Ich habe es bei meinen anderen PC mit ASUS P5KPL-CM und

Debian probiert, keine Probleme, Griffith ist in der Paketverwaltung,

lässt sich problemlos installieren und erscheint auch beim anklicken.

Ich werde mir also auch noch Debian auf den Gigabyte installieren.

Noch einmal vielen Dank für Eure Hilfe. Einige User im Linux Forum

sagen ja immer "es gibt nur zwei richtige Linux Systeme, Debian und

Fedora" anscheinend ist da etwas Wahres dran.

Gruss

Zarastro. 

bei Antwort benachrichtigen
fakiauso zarastro

„Guten Tag fakiauso, ich habe es noch einmal mit Deinen neuen ...“

Optionen
ich habe es noch einmal mit Deinen neuen Vorschlägen bei Linux Mint probiert, wieder eine Fehleranzeige, dann folgte Ubuntu Studio, dort ist Griffith sogar in der Anwendungsverwaltung, es funktionierte auch nicht


Das ist natürlich schade. Die Pakete sind unter Trusty und unter Debian allerdings alle in Version 0.13-3, daran kann es m.E. also nicht liegen. Diese kommen auch bei beiden Distris über die Paketverwaltung:

http://packages.ubuntu.com/de/trusty/gnome/griffith

https://packages.debian.org/search?keywords=griffith&searchon=names&suite=stable&section=all

Hattest Du die Paketversion von Ubuntu installiert oder den Download aus dem Link zu griffith selber?
Die hardware schliesse ich jetzt als Ursache einmal aus, eventuell nutzt Du statt Ubuntu Studio Ubuntu direkt. Die paar fehlenden Codecs kannst Du auch nachinstallieren über die restricted-Pakete, wenn etwas fehlen sollte.

Ist die Fehlermeldung immer noch dieselbe wie beim Eingangsproblem?

Sonst kann es durchaus sein, dass Python der Auslöser ist.

Einige User im Linux Forum sagen ja immer "es gibt nur zwei richtige Linux Systeme, Debian und Fedora" anscheinend ist da etwas Wahres dran.


Naja, die haben auch ihre Macken, nur vielleicht weniger, weil die Software zumindest im stable-Bereich nach sehr konservativen Maßstäben freigegeben wird. Dafür ist sie dann manchmal schon gut abgehangen, aber das muss ja kein Nachteil sein;-)

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
zarastro fakiauso

„Das ist natürlich schade. Die Pakete sind unter Trusty und ...“

Optionen

Guten Tag fakiauso,

Du schriebst.

Hattest Du die Paketversion von Ubuntu installiert oder den Download aus dem Link zu griffith selber?

Ich habe den Download von Griffith benutzt.

Auf den ASUS habe ich auch Xubuntu installiert, da mir Ubuntu nicht gefällt, ich

habe auf diesen BS allerdings Griffith nicht ausprobiert.

Wichtig für mich ist das Griffith jetzt funktioniert, obwohl ich im Augenblick ueber-

wiegend Linux Mint benutze und damit auch zufrieden bin.

Es kam folgende Fehlermeldung:

Verschieben von „validators.py“ nach „validators.py.backup“ nicht möglich: Keine Berechtigung

Wie ich nach Recherche im Internet sehe, ist Python eine Programmiersprache,

was hat diese Sprache jetzt mit den fertigen Programmen zu tun? Wie Linux

Mint in seinen Einführungstext behauptet werden alle Programme, ehe sie

freigegeben werden, überprüft.

Gruss

Zarastro

bei Antwort benachrichtigen
fakiauso zarastro

„Guten Tag fakiauso, Du schriebst. Hattest Du die ...“

Optionen

Moin

Verschieben von „validators.py“ nach „validators.py.backup“ nicht möglich: Keine Berechtigung


Hast Du das Umbenennen im Verzeichnis als root gemacht, sprich mit sudo vor dem eigentlich Befehl?

sudo mv validators.py validators.py.backup

Ausserhalb Deines home-Verzeichnisses hast Du keine Schreibrechte, wenn diese nicht explizit erteilt wurden und dann geht es natürlich schief.

Wenn Du den grafischen Weg bevorzugst, kannst Du auch unter Mint den Dateimanager (Nemo?) mit root-Rechten öffnen, Dich in das Verzeichnis /usr/share/griffith/lib/db begeben und dort per Rechtsklick die Datei validators.py in validators.py.backup ändern.
Bist Du einmal dort, verschiebst Du die heruntergeladene Datei gleich noch mit in das Verzeichnis und kannst dann die Rechte und den Besitzer ebenfalls per Rechtsklick auf die Datei validators.py anpassen.

Meistens ist im Systemmenü bereits ein Eintrag für den Dateimanager als Systemverwalter enthalten, sonst startest Du unter Mint Nemo wie unten beschrieben als root:

http://wiki.ubuntuusers.de/Nemo#Bedienung

Das Umbenennen selber sollte kein Problem sein, Rechte und Besitzer änderst Du per Rechtsklick-->Eigenschaften im Dateimanager so:



Als Besitzer stellst Du root ein (entspricht sudo chown root:root /usr/share/griffith/lib/db/validators.py)

Die Rechte setzt Du bei 644 so:

root = Lesen und Schreiben (6)
Gruppe = Lesen (4)
Andere = Lesen (4)

Oder eben als Befehl auf der Konsole (entspricht sudo chmod 644 /usr/share/griffith/lib/db/validators.py)

Nun noch etwas OT zu Python - wie Du an der Endung *.py siehst, läuft das Ding als Python-Skript, daher kann es schon Probleme geben, wenn eine Python-Umgebung und ein Skript nicht miteinander können. Das ist aber hier explizit nicht der Fall!
Es gab z.B. in manchen Fällen unter Ubuntu 12.04 ein Problem, ein PPA für Canon-Drucker einzubinden, das in einer kryptischen Fehlermeldung endete und am Importieren des zugehörigen Schlüssels für das Repo scheiterte. Nun konnte man diesen entweder manuell einspielen oder die Python-Version per Paketverwaltung zwangsweise ein version zurücksetzen, damit es funktioniert,nach dem erfolgreichen Einbinden des Repos die Sperre für das Python-Paket aufheben und wieder auf den aktuellen Stand bringen. Blöderweise trat das nur manchmal auf und nicht immer, aber als Ahnungsloser wie ich steht man da erst einmal im Wald und sieht nur Bäume.

Aber das Ganze wie gesagt nur als OT und nun hoffentlich gutes Gelingen, man möge  mir die Kurzgeschichte verzeihen;-)

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
zarastro fakiauso

„Moin Hast Du das Umbenennen im Verzeichnis als root gemacht, ...“

Optionen

Guten Tag fakiauso,

ich habe es noch einmal bei Ubuntu Studio probiert und bekomme den Fehler-

Bericht:

mv: der Aufruf von stat für »validators.py“ ist nicht möglich: Datei oder Verzeichnis nicht gefunden

Es ist aber auch kein großes Problem, die Bearbeitung der Videos kann ich auch

mit Debian machen. Ich werde es allerdings auch einmal mit Nero probieren,

meine Hoffnung auf eine Funktion sind aber recht gering.

Gruß

Zarastro. 

bei Antwort benachrichtigen
fakiauso zarastro

„Guten Tag fakiauso, ich habe es noch einmal bei Ubuntu ...“

Optionen
mv: der Aufruf von stat für »validators.py“ ist nicht möglich: Datei oder Verzeichnis nicht gefunden


Hach, jetzt bist Du bestimmt wieder nicht in´s Verzeichnis /usr/share/griffith/lib/db/ gewechselt;-)

Versuche es einmal mit der Methode von LohrerMopper oder eben wie bei mir im Vorbeitrag beschrieben mittels Nemo unter root.
Du kannst auch per Rechtsklick das Kontextmenü öffnen und dann die Option "Als root öffnen oder so" wählen. Voraussetzung ist das installierte Paket gksu.

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
zarastro fakiauso

„Hach, jetzt bist Du bestimmt wieder nicht in s Verzeichnis ...“

Optionen

ich habe nachgesehen "gksu" ist die neueste Version installiert. Ich mache

jetzt mit Versuchen erst einmal Pause mir raucht der Kopf, außerdem hat

der Laptop mit Windows 7 Probleme, darum muss ich mich erst einmal 

kümmern, sonst handeln wir uns einen Virenstamm ein.

Gruß

Zarastro. 

bei Antwort benachrichtigen
LohrerMopper fakiauso

„Moin Da ist vermutlich beim Kopieren etwas schiefgegangen ...“

Optionen
Wenn Du nicht ständig sudo voransetzen möchtest und nach Ablaufen der voreingestellten Zeit das root-Passwort erneut eingeben musst, kannst Du über sudo su Passwort auf der Konsole dauerhaft root werden.

Bei meinem Kubuntu gebe ich einmal:

Sudo dolphin

und das Passwort ein.

Dann startet der grafische Dateimanager mit ROOT-Rechten und man kann bequem und komfortabel seine Dateien bearbeiten.

bei Antwort benachrichtigen
zarastro LohrerMopper

„Bei meinem Kubuntu gebe ich einmal: Sudo dolphin und das ...“

Optionen

Guten Tag LohrerMopper,

ich habe Deinen Vorschlag ausprobiert und bekomme folgende Antwort:

Z87-D3HP ~ $ Sudo dolphin
Der Befehl »Sudo« wurde nicht gefunden, meinten Sie vielleicht:
Befehl »udo« aus dem Paket »udo« (universe)
Befehl »sudo« aus dem Paket »sudo« (main)
Befehl »sudo« aus dem Paket »sudo-ldap« (universe)
Sudo: Befehl nicht gefunden.

Offenbar funktioniert dieser Befehl bei Linux Mint nicht.

Gruß

Zarastro.
.

bei Antwort benachrichtigen
LohrerMopper zarastro

„Guten Tag LohrerMopper, ich habe Deinen Vorschlag ...“

Optionen

Richtig!

Bei Mint ist ein anderer Dateimanager (wahrscheinlich Nemo) dabei und Sdo gibt es auch nicht.

Wahrscheinlich muss man:

gksu nemo

eingeben. Siehe auch:

http://www.linuxmintusers.de/index.php?topic=10839.0

Mint ist doch etwas anders als (K)Ubuntu.Zwinkernd

bei Antwort benachrichtigen
zarastro LohrerMopper

„Richtig! Bei Mint ist ein anderer Dateimanager ...“

Optionen

genau so ist es "gksu nemo" funktioniert

Gruß 

Zarastro.

bei Antwort benachrichtigen
LohrerMopper zarastro

„Guten Tag LohrerMopper, ich habe Deinen Vorschlag ...“

Optionen

Vielleicht hilft es auch, das Programm mit dem Paketmanager zu deinstallieren und dann das Pakt von:

http://community.linuxmint.com/software/view/griffith

neu zu installieren. Eigentlich müsste ein Mausklick auf "Install" genügen.

bei Antwort benachrichtigen
fakiauso zarastro

„Guten Tag LohrerMopper, ich habe Deinen Vorschlag ...“

Optionen
Z87-D3HP ~ $ Sudo dolphin


So wird das auch nix, im gegensatz zu Windows unterscheidet Linux restriktiv zwischen Gross- und Kleinschreibung und da heisst der Befehl nun einmal:

sudo dolphin

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen
zarastro fakiauso

„So wird das auch nix, im gegensatz zu Windows unterscheidet ...“

Optionen

Hallo fakiauso,

da habe ich mich offenbar vertippt, ich habe es noch einmal probiert. Es

funktioniert trotzdem nicht.

~ $ sudo dolphin
[sudo] password for 
sudo: dolphin: command not found

Gruß

Zarastro.

bei Antwort benachrichtigen
fakiauso zarastro

„Hallo fakiauso, da habe ich mich offenbar vertippt, ich habe ...“

Optionen

Moin

Dann ist dolphin vermutlich nicht installiert, aber nemo als voreingestellter Dateimanager sollte doch da sein.

Versuche es einfach noch einmal mit dem vielleicht etwas komplizierten Weg über die Konsole oder starte nemo mit root-Rechten.
Gehe vor allem sicher, dass Du:

- korrekten Verzeichnis bist
- oder bei der Befehlseingabe die korrekten Pfade benutzt- und die Befehle richtig eingibst

Daher auch der Hinweis, das mittels Kopieren/Einfügen von der Webseite bei Ubuntu durchzuführen. Da Du das heruntergeladene Paket von Griffith installiert hast, kannst Du dieses auch erst entfernen:

sudo apt-get remove griffith

oder um auch die Konfigurationsdateien mit zu entfernen (was in Deinem Fall sinnvoll ist):

sudo apt-get purge griffith

Danach löschst Du das heruntergeladene Paket von griffith und installierst das aus der Paketverwaltung von Mint/Ubuntu Studio.
Startet dann Griffith immer noch nicht bzw. mit der bekannten Fehlermeldung,
setzt Du noch einmal die Anleitung von Ubuntu um und zwar genau so, wie es dort beschrieben ist, nur eben mit dem richtigen Pfad Deines /home-Verzeichnisses und dem Download-Ordner, in welchem Du gespeichert hast.
Das Kopieren der heruntergeladenen validators.py und das Anpassen der rechte kannst Du auch grafisch vornehmen, indem Du den vorhandenen Dateimanager eben mittels sudo als root startest.

Irgendwann muss es doch klappen;-)

Wenn die Welt gerettet wurde, wird es durch Frauen geschehen sein...
bei Antwort benachrichtigen