Linux 14.926 Themen, 105.540 Beiträge

irq´s

reinhold / 1 Antworten / Baumansicht Nickles

hallo, ich bin´s mal wieder
habe heute meine netzwerkkarte eingebaut (d-link 528 pci)
mein win95 hat sie auch ohne probleme angenommen, aber seitdem das ding drin ist bootet
linux nicht mehr.
mein bios schmeißt das ding auf irq11 zusammen mit meinem scsi controller und meiner grafikkarte.
beim booten von linux checkt er jetzt usb und ncr58c8xx jeweils zweimal, und bei ´checking file system´
passiert gar nichts mehr.
im bios ist der eintrag ´pnp-system´ auf ´no´ geschaltet. und eine vergabe die irq´s von hand ist
in meinem bios (award4.51) meiner ansicht nicht möglich.
gibt es so etwas wie irq-sharing auch für linux?
unter win95 sind 4 irq´s doppelt und einer dreifach belegt, aber mit irq-holder gab´s noch nie probleme.
bitte helft mir
vielen dank (reinhold)

Antwort:
wenn du die nicht brauchst: schalt mal deine COM, LPT und USB anschlüsse im bios ab. vielleicht hilfts.
Der Pinky
((Anonym))

Antwort:
danke für den tip
habe mein system soweit abgespeckt, daß kein irq doppelt belegt ist.
linux bootet aber immer noch nicht.
kann es sein, daß linux sich nicht findet?
mein linux liegt auf einer scsi-platte, der controller hat aber nach der installation der netzwerkkarte
einen anderen irq als bei der linux installation.
kann es sein daß linux den scsi-controller an dem irq sucht, an dem er bei der installation lag,
und dabei jetzt ein ganz anderes gerät abfragt?
aber dann dürfte ja auch die hardware erkennung nicht geladen werden, oder???!!
oder ist mein file-system beschädigt, weil linux sich immer bei ´checkin file system...wait´ aufhängt???
oder bin ich durch die nutzung von winows einfach zu abgestumpft???!!!
(reinhold)

Antwort:
Hmmm.. jetzt wirds komlex.
bitte gib doch mal genau an, welche hardware du benutzt und welche Linux-distribution (mir version, etc..).
erstmal kann ich dich beruhigen, es liegt nicht am windoof, denn manchmal ist die konfiguration unter DOS+Win311 einfacher als unter linux.
ich gehe mal davon aus, dass du eine Suse-6.x distribution hast.
wenn du von diskette bootest, (oder von cd) startet linux ohne probleme.. (denk ich). deine scsi-karte wird erkannt und das entsprechende modul geladen (fehlerfrei). Die installation ging ohne probleme und du hast am ende der installation einen kernel ausgewählt, der scsi-systeme unsterstützt und deine scsi-karte ansprechen kann (treiber). du hast den rechner neu gestartet und nun will linux nicht von der platte starten. du bootest wieder neu, linux bleibt beim beschriebenen Fehler hängen, bei der festplatte tut sich nichts, kein rattern, dein lämpchen leuchtet (siehst du überhaupt, wann der rechner auf die festplatte zugreift?).
angenommen, ich habe alles richtig zusammengefasst, so versuche folgendes: les den beitrag über dem hier (IRQ), starte ein "rettungssystem" und überprüfe die konfg in der "/etc/modules.conf" datei. stimmt der IRQ? wenn dass nicht hilft, prüfe "/etc/lilo.conf" das ist die datei für den linux-bootmanager. ist dort die richtige partition angegeben? dann nimm dir die "/etc/fstab" (oder heisst die "etc/fsstab.conf"?) vor. überprüfe, ob die angaben richtig sind. deine partitionen sollten mit "/dev/hds1" oder so aufgeführt werden.. wenn du nicht weisst, ob etwas richtig ist, kannst du ja hier einen auszug auflisten.. (oder du mails mich an: soterski@gmx.d ,oder ICQ:28384550 / 58672451)
wenn du lust hast, kannst du versuchen linux neu zu installieren - mit der neuen konfiguration...
mehr fällt mir jetzt so spontan allgemeines nicht ein...
Viel glück!
der Pinky
ach ja, das noch: nach einem absturz prüft linux das dateisystem und bleibt bei genau deiner meldung stehen. dies kann bei grossen platten auch schon mal ne minute oder länger dauern.. also wart ein wenig..
((Anonym))

bei Antwort benachrichtigen
(Anonym) reinhold

„irq´s“

Optionen

wenn du die nicht brauchst: schalt mal deine COM, LPT und USB anschlüsse im bios ab. vielleicht hilfts.
Der Pinky
((Anonym))

bei Antwort benachrichtigen