Linux 14.928 Themen, 105.575 Beiträge

GeForce2 MX

(Anonym) / 22 Antworten / Baumansicht Nickles

Ich besitze eine GeForce 2 MX und bringe den X-Server einfach nicht zum laufen...allles was ich bis jetzt geschaft habe war ein vga server mit 16 farben....
Ich habe es schon mit Suse 7.0 und Mandrake 7.1 ausprobiert...ich bekomme immer folgende Fehlermeldung beim starten durch "startx" "No screen found"
Die NVIDIA Treiber habe ich alle schon probiert...
Für Hilfe wäre ich SEHR dankbar

bei Antwort benachrichtigen
Bombenleger (Anonym)

„GeForce2 MX“

Optionen

Hallo

Hol Dir von NVidia die Linux-Treiber .094, am besten das src-Paket. Dann installier Linux 7.0, ohne sax2
zu starten. dann install den Nvidia-src-Treiber wie beschrieben (Englisch). Wenn das fertig ist reboote.
Melde Dich unter root an und gib lsmod ein. Ist agppart und NVDriver in der Liste, wenn nicht dann
editiere die /etc/rc.config.d/boot.local und trage am Ende folgende Zeilen ein:
insmod agppart
insmod NVDriver
und reboote erneut. Jetzt geh in das Verzeichnis /usr/X11/lib/modules und benenn nv_drv.o in nv_drv.x um
und starte sax2 -f. Danach kannst Du als Grafik-Treiber nvidia auswaehlen und je Farbpalette die gewuenschte
Aufloesung, z.B. alle nur 1024x768, aendern. In den Experteneinstellungen muss in jeder Auswahl auto
stehen. Wichtig ist die Auswahl des Monitors bzw. die Anpassung der angezeigten vsync/hsync-Werte. Die
koennen manuell geaendert werden, indem man die Maus an das Ende eines Eintrags klickt, nicht markiert,
und per Backspace-Taste die Eintraege entfernt und neu eingibt, immer im Format xx.x-xx.x. Wenn jetzt per
weiter der finish gedrueckt wird und sich das Bild aufgebaut hat, ist Teil 1 schon mal erfolgt. Nach Abspeicherung
editier jetzt noch die /etc/X11/XF86Config und trage bei den Modulen zusaetzlich "glx" als weitere Zeile ein
und marschier dann weiter zum Monitor und gib die Startwerte fuer vsync/hsync erneut ein, stehen auf 0.
Ist zwar alles etwas umstaendlich, aber der XFree4.x-Treiber (nv_drv) vertraegt sich nicht mit GeForce 2.
CU

bei Antwort benachrichtigen
(Anonym) Bombenleger

„HalloHol Dir von NVidia die Linux-Treiber .094, am besten das src-Paket. Dann...“

Optionen

Also...ich habe mit Mandrake den X-Server zum laufen gebracht...nur wenn ich z.B. Quake starten will bricht der Server zusammen....die NVIDIA Treiber habe ich ohne Error installiert und auch alte Mesa Treiber kann ich keine mehr finden.....

bei Antwort benachrichtigen
Bombenleger (Anonym)

„Also...ich habe mit Mandrake den X-Server zum laufen gebracht...nur wenn ich...“

Optionen

Hallo

Die "alten" Mesa-Treiber (glx) laufen nicht mit NVidia-Karten, deshalb liefert NVidia einen eigenen
glx.so mit, der ueber die /etc/X11/XF86Config zusaetzlich als Modul geladen werden muss, da die
Linux-Konfigurationsprogramme das nicht automatisch vornehmen. Es gibt da drin einen Modul-Block
in dem schon ein paar Standards drinstehen. Deshalb die letzte Modulzeile verdoppeln und innerhalb
des 2. "..." Eintrag's das ganze durch glx ersetzen, nicht durch glx.so, denn NVDriver haengt .so an.
Schoenes Wochenende

bei Antwort benachrichtigen
(Anonym) Bombenleger

„HalloDie alten Mesa-Treiber glx laufen nicht mit NVidia-Karten, deshalb liefert...“

Optionen

Danke für deine Antwort!
Ich habe das schon versucht aber z.B. Quake funktioniert nicht....der X-Server crashd einfach und das wars....die letzte Meldung von Server ist Load glx....

bei Antwort benachrichtigen
Bombenleger (Anonym)

„Danke für deine Antwort!Ich habe das schon versucht aber z.B. Quake...“

Optionen

Hallo

Was passiert, wenn startx eingegeben wird (ohne Quake) ?

bei Antwort benachrichtigen
(Anonym) Bombenleger

„HalloWas passiert, wenn startx eingegeben wird ohne Quake ?“

Optionen

Also...wenn ich die NVIDIA Treiber 0.94 (glx+kernel) installiere startet der Server nicht wegen irgend einem Problem mit glx...wenn ich die Datei libGL.so entferne startet es ganz normal ohne error in jeder beliebigen auflösung...

bei Antwort benachrichtigen
Bombenleger (Anonym)

„Also...wenn ich die NVIDIA Treiber 0.94 glx kernel installiere startet der...“

Optionen

Hallo

Und was ist mit Quake 3, ohne die libGL.so, die ja wahrscheinlich zu Mesa gehoert, oder gibt es ausser
der libglx.so + entsprechender links da drauf, noch andere gl-Bibliotheken ? Deinstallier doch einfach
mal das Paket Mesa. startx muesste dann weiterhin laufen und Quake muesste meckern, weil ihm
irgendwas von Mesa fehlt, da es nicht mit dem NVDriver klarkommt. Reinstallieren laesst es sich ja.

bei Antwort benachrichtigen
(Anonym) Bombenleger

„HalloUnd was ist mit Quake 3, ohne die libGL.so, die ja wahrscheinlich zu Mesa...“

Optionen

Also...Mesa ist deinstalliert und ich kann keine anderen gl-Bibliotheken mehr finden. Um aber startx zum laufen zu bringen, muss ich die Datei libglx.so löschen...sonst startet X nicht und ich bekomme einen "ERROR 11".....
Irgendwelche Ideen??

bei Antwort benachrichtigen
Bombenleger (Anonym)

„Also...Mesa ist deinstalliert und ich kann keine anderen gl-Bibliotheken mehr...“

Optionen

Hallo

Den Error hatte ich auch. Nachdem ich aber von der PC-Welt-CD mein System habe updaten lassen und
ich nv_drv.o in nv_drv.x umbenannt hatte lief es auch mit glx. Habe mir mal die neuen .095-Treiber
geholt und werde die mal installieren. Auch werde ich mal nach Ausschau nach einer Quake-Demo
fuer Linux halten, damit ich ggf. die Ursache fuer das Problem finden kann.
CU

bei Antwort benachrichtigen
(Anonym) Bombenleger

„HalloDen Error hatte ich auch. Nachdem ich aber von der PC-Welt-CD mein System...“

Optionen

Wenn ich nv_drv.o in nv_drv.x umbenenne, geht gar nichts mehr....ich bekomme dann nur ein "no screens found" beim starten von X....

bei Antwort benachrichtigen
Bombenleger (Anonym)

„Wenn ich nv_drv.o in nv_drv.x umbenenne, geht gar nichts mehr....ich bekomme...“

Optionen

Hallo

Unter http://www.linuxgames.com/quake/ gibt es schon mal Info's. Wenn nv_drv.o nicht mehr existiert,
sollte es da aber nvidia.o geben und genau der muss auch in /etc/X11/XF86Config stehen.
Mal sehen wie lange der ca. 47 MB Download dauert, wenn man nur V.90 hat.
CU

bei Antwort benachrichtigen
(Anonym) Bombenleger

„HalloUnter http://www.linuxgames.com/quake/ gibt es schon mal Info s. Wenn...“

Optionen

Ich habe Kabel :)

bei Antwort benachrichtigen
(Anonym)

Nachtrag zu: „Ich habe Kabel : “

Optionen

Ach ja, ich glaube X versucht immer nv zu laden obwohl ich es in /etc/X11/XF86Config auf nvidia geändert habe...

bei Antwort benachrichtigen
(Anonym)

Nachtrag zu: „Ach ja, ich glaube X versucht immer nv zu laden obwohl ich es in...“

Optionen

OK, ich habe es zum laufen gebracht! Allerdings nur in 256 Farben....gibts da was, was ich tun kann?
Thanks again!

bei Antwort benachrichtigen
Bombenleger (Anonym)

„OK, ich habe es zum laufen gebracht! Allerdings nur in 256 Farben....gibts da...“

Optionen

Hallo

Weiss ich noch nicht, da der Download ueber Linux-Netscape nach 20 MB abgeschmiert ist. Muss es
ueber Win98 SE noch mal probieren (Netscape Download Manager). Uebrigens .095 bringt bei mir
auch Caught Signal 11. Nach reinstallation von .094 vom Band ging es wieder. Sieht so aus als
wuesste NVidia immer noch nicht, das die MX keine Chipsatz-Kennung hat, zumindest nicht im
bisherigen Bios 3.11.00.07.
Klappte das per Anleitung von Quake 2 ? Vielleicht gibt es ja noch ein "Setup" indem man die
Aufloesung/Farbtiefe aendern kann. Unter Win ist das ja recht komfortabel einstellbar ueber die
Optionen in Quake III.
Ach ja, den Typ von oben (vor Zaphod) sollte man dieses Problem mal loesen lassen. Was unter
Win so "einfach" geht, benoetigt unter Linux erheblich mehr Aufwand, da es ja auch stabiler ist.
Bis dann

bei Antwort benachrichtigen
(Anonym) Bombenleger

„HalloWeiss ich noch nicht, da der Download ueber Linux-Netscape nach 20 MB...“

Optionen

Hat sich erledigt!! Jetzt läuft alles perfekt!! :) Wieso? Keine Ahnung *g*

Danke für deine Tipps!

bei Antwort benachrichtigen
Bombenleger (Anonym)

„Hat sich erledigt!! Jetzt läuft alles perfekt!! : Wieso? Keine Ahnung g Danke...“

Optionen

Hallo

Hoert sich gut an, aber mit welchem Treiber: .094 oder neuer ?

bei Antwort benachrichtigen
(Anonym) Bombenleger

„HalloHoert sich gut an, aber mit welchem Treiber: .094 oder neuer ?“

Optionen

Es geht mit beiden aber wenn ich 0.95 benutze, flackert das Bild herum wenn ich KDE starte....also habe ich Version 0.94 benutzt, jetzt läuft alles bestens! :)

bei Antwort benachrichtigen
assi (Anonym) (Anonym)

„GeForce2 MX“

Optionen

Wieso nimmst du kein Windows, du Blödmann

bei Antwort benachrichtigen
Zaphod assi (Anonym)

„Wieso nimmst du kein Windows, du Blödmann“

Optionen

... kannst du mal hier abhauen, es reicht!
Z.

bei Antwort benachrichtigen
(Anonym) Zaphod

„... kannst du mal hier abhauen, es reicht!Z.“

Optionen

Was soll das eigentlich? Nur weil du unfähig bist, Linux zu installieren heisst das noch lange nicht, dass es scheisse ist!
Das wars...ich werde darüber nicht länger diskutieren!

bei Antwort benachrichtigen
assi (Anonym) (Anonym)

„GeForce2 MX“

Optionen

Warum willst du deine Geforce mx unter Linux zum Laufen bringen?
256 Farben reichen dir um Brettspiele unter Linux zu spielen,du Schwachkopf.
Geile Spiele gibts nur für windows.

bei Antwort benachrichtigen