Linux 14.940 Themen, 105.766 Beiträge

Maxi Sound 64 unter Linux

RotFuchs / 4 Antworten / Baumansicht Nickles

Ich habe das gleiche Problem wie schon jemand vor einiger Zeit :
Als Linux-Neuling möchte ich meine Guillemot Maxi Sound 64 Home Studio Pro unter SuSe 6.1 zum
Tönen bringen. Durch pnpdump & isapnp kann ich die Karte initialisieren, aber der Versuch, einen
einfachen SB-Treiber zu laden schlägt fehl. Seltsam übrigens: der IRQ9, mit dem's unter WIN95
immer Probleme gab, scheint hier verwendbar zu sein, nicht aber der IRQ 12
(für das 4. logische Gerät). Wenn ich die isapnp.conf ändere, gibt es Fehlermeldungen.
Ich habe es auch mit zwei Versionen des OSS versucht. Auch hier wird die Karte richtig erkannt
(als ESS1868), der Befehl soundon liefert allerdings sinngemäß die Ausgabe:
"Warning! Some devices failed to initialize." - und wieder kein Ton!
Wer kann mir helfen, doch noch Krach zu machen?
Bitte keine Hinweise auf Howto-Dateien, die habe ich schon erfolglos durchgesehen. (Rotfuchs)

Antwort:
Hi,
damals hat jemand auf die Treiber unter
ftp://sunsite.unc.edu/pub/Linux/kernel/sound/
hingewiesen...funktionieren die nicht ?
j.
(jay)

Antwort:
Hallo,
auf den ersten Blick finde ich da nichts Passendes. Außerdem kann ich noch nicht ohne größere Verrenkungen Dateien von Windows nach Linux bringen.
Was war damals der genaue Ratschlag?
(Rotfuchs)

Antwort:
Den genauen Ratschlag hab ich nicht mehr im Kopf, aber Du kannst unter Linux deine Windows Partitionen mounten, und dann Dateien kopieren.
j.
(jay)

Antwort:
Ich hab die Version Home Studio 2 dieser Karte...
das Problem ist, dass die Karte beim Startup initialisiert werden muss,
d.h. nicht bloss Reset, sondern Firmware Code und "Jumper-Settings" werden geladen.
Das passiert normalerweise mit dem DOS-Treiber (maxinit.exe).
Möglicherweise kann man das unter Linux nachholen, indem man maxinit unter
dosemu ausführt - hab ich aber nicht probiert.
Am besten starten man DOS (bzw. Win95 - Eingabeaufforderung),
und startet Linux dann per loadlin, und dann die Kernel-Soundmodule mit
den Settings aus der DOS-.ini. Das hat bei mir funktioniert.
Allerdings offenbar nur mit 8bit-Modus (SB-Pro).
Der Wave-Kanal funktioniert, sowohl interner Synthesizer als auch externer MIDI-Port (bzw. Daughterboard)
verhalten sich dann wir erwartet.
(Martin Biribauer)

bei Antwort benachrichtigen
jay RotFuchs

„Maxi Sound 64 unter Linux“

Optionen

Hi,
damals hat jemand auf die Treiber unter
ftp://sunsite.unc.edu/pub/Linux/kernel/sound/
hingewiesen...funktionieren die nicht ?
j.
(jay)

bei Antwort benachrichtigen
RotFuchs jay

„Maxi Sound 64 unter Linux“

Optionen

Hallo,
auf den ersten Blick finde ich da nichts Passendes. Außerdem kann ich noch nicht ohne größere Verrenkungen Dateien von Windows nach Linux bringen.
Was war damals der genaue Ratschlag?
(Rotfuchs)

bei Antwort benachrichtigen
jay RotFuchs

„Maxi Sound 64 unter Linux“

Optionen

Den genauen Ratschlag hab ich nicht mehr im Kopf, aber Du kannst unter Linux deine Windows Partitionen mounten, und dann Dateien kopieren.
j.
(jay)

bei Antwort benachrichtigen
Martin Biribauer RotFuchs

„Maxi Sound 64 unter Linux“

Optionen

Ich hab die Version Home Studio 2 dieser Karte...
das Problem ist, dass die Karte beim Startup initialisiert werden muss,
d.h. nicht bloss Reset, sondern Firmware Code und "Jumper-Settings" werden geladen.
Das passiert normalerweise mit dem DOS-Treiber (maxinit.exe).
Möglicherweise kann man das unter Linux nachholen, indem man maxinit unter
dosemu ausführt - hab ich aber nicht probiert.
Am besten starten man DOS (bzw. Win95 - Eingabeaufforderung),
und startet Linux dann per loadlin, und dann die Kernel-Soundmodule mit
den Settings aus der DOS-.ini. Das hat bei mir funktioniert.
Allerdings offenbar nur mit 8bit-Modus (SB-Pro).
Der Wave-Kanal funktioniert, sowohl interner Synthesizer als auch externer MIDI-Port (bzw. Daughterboard)
verhalten sich dann wir erwartet.
(Martin Biribauer)

bei Antwort benachrichtigen