Linux 14.816 Themen, 104.460 Beiträge

Linux auf secondary Master installiert (hdc) Jetzt auf Primary M

WinKill / 3 Antworten / Baumansicht Nickles

Hi
Ich habe SuSe 6.1 installiert.
Damit das CD-ROM Laufwerk erkannt wurde mußte ich es auf Primary Master stecken und die Festplatte dann auf Secondary Master.
Nun ist mein Linux installiert (mein erstes übrigens). Allerdings konnte ich LiLo nicht in den MBR schreiben, da die Festplatte hdc ist - sie müsste aber hda sein. Von BootDisk kann ich Linux einwandfrei starten.
stecke ich jetzt die Festplatte zurück auf Primary Master, wird zwar Lilo dann von dort erkannt, allerdings stop Linux beim booten mit der Meldung:
Panic Kernel
Liegt wohl daran, daß die Festplatte bei der Installation hdc war und jetzt hda ist.
Jetzt meine Fragen: Wie kann ich das ändern? Ich hab mir überlegt, ein Master / Slave Kabel zu kaufen und FP als Primary Master und CD-Rom als Primary Slave laufen zu lassen. Aber noch mal installieren kanns ja wohl nciht sein, daß muß doch auch anders gehen!
(WinKill)

Antwort:
Nach jeder Änderung der Partitionsanordnung sollte Lilo neu gestartet werden.
Also: Von Diskette Booten (mit Platte als hda) eventuell Parameter angeben "root=/dev/hda". Dann "lilo.conf" editieren, und "lilo" aufrufen.
j.
(jay)

Antwort:
Hatte diesen Tip schon erhalten und ausgeführt.
Allerdings hab ich, bedingt durch Diskussion mit meiner Freundin (zu viel vorm computer bla bla bla), lilo nach der Änderung der lilo.conf nicht ausgeführt.
Und jetzt stimmt mein ROOT PW nicht mehr!!
Ich versteh das absolut nicht, also ich hab sicher kein passwd eingegeben oder so was und der computer ist nicht am Netz und außer mir war definitiv keiner dran.
lediglich die lilo.conf habe ich geändert und dann eben lilo vor dem runterfahren nicht ausgeführt.
ich hab auch die alten PWs probiert, da ich 3 mal gewechselt hab - nix geht!
woran kann jetzt das liegen? Muß ich jetzt am Ende doch alles noch mal drauf hauen?
(WinKill)

Antwort:
ROOT PW weg ???
Oh mann, das hatte ich mal bei der KDE beta vor 1.0 gehabt das Problem.
Ich bin dann einfach hergegangen und habe eine KOPIE des Binarys /usr/bin/passwd GEHACKT, so dass es nicht nach
dem alten Passwort fragt beim Aendern. (setzt ein wenig C-Kenntnisse allerdings voraus). Habe das Teil
dann hpasswd genannt (um das alte nicht zu ueberschreiben, hpasswd auf eine DISKETTE gepackt und hpasswd dann von der
Platte geschmissen (waere zu gefaehrlich!!)
Damit war das Problem (gottseidank! *puuuuh*) - geloest.
Sonst haette ich - wie du richtig gesagt hast - alles neu installieren muessen.
Es sei denn es geht noch anders.
(andy1)

bei Antwort benachrichtigen
jay WinKill

„Linux auf secondary Master installiert (hdc) Jetzt auf Primary M“

Optionen

Nach jeder Änderung der Partitionsanordnung sollte Lilo neu gestartet werden.
Also: Von Diskette Booten (mit Platte als hda) eventuell Parameter angeben "root=/dev/hda". Dann "lilo.conf" editieren, und "lilo" aufrufen.
j.
(jay)

bei Antwort benachrichtigen
WinKill jay

„Linux auf secondary Master installiert (hdc) Jetzt auf Primary M“

Optionen

Hatte diesen Tip schon erhalten und ausgeführt.
Allerdings hab ich, bedingt durch Diskussion mit meiner Freundin (zu viel vorm computer bla bla bla), lilo nach der Änderung der lilo.conf nicht ausgeführt.
Und jetzt stimmt mein ROOT PW nicht mehr!!
Ich versteh das absolut nicht, also ich hab sicher kein passwd eingegeben oder so was und der computer ist nicht am Netz und außer mir war definitiv keiner dran.
lediglich die lilo.conf habe ich geändert und dann eben lilo vor dem runterfahren nicht ausgeführt.
ich hab auch die alten PWs probiert, da ich 3 mal gewechselt hab - nix geht!
woran kann jetzt das liegen? Muß ich jetzt am Ende doch alles noch mal drauf hauen?
(WinKill)

bei Antwort benachrichtigen
Andy1 WinKill

„Linux auf secondary Master installiert (hdc) Jetzt auf Primary M“

Optionen

ROOT PW weg ???
Oh mann, das hatte ich mal bei der KDE beta vor 1.0 gehabt das Problem.
Ich bin dann einfach hergegangen und habe eine KOPIE des Binarys /usr/bin/passwd GEHACKT, so dass es nicht nach
dem alten Passwort fragt beim Aendern. (setzt ein wenig C-Kenntnisse allerdings voraus). Habe das Teil
dann hpasswd genannt (um das alte nicht zu ueberschreiben, hpasswd auf eine DISKETTE gepackt und hpasswd dann von der
Platte geschmissen (waere zu gefaehrlich!!)
Damit war das Problem (gottseidank! *puuuuh*) - geloest.
Sonst haette ich - wie du richtig gesagt hast - alles neu installieren muessen.
Es sei denn es geht noch anders.
(andy1)

bei Antwort benachrichtigen