Linux 14.949 Themen, 105.915 Beiträge

Internetzugang über 1&1 internet.profi

Leif Klinkhardt / 1 Antworten / Baumansicht Nickles

Hallo,
wer hilft mir bei der Konfiguration des Internetzugangs (per Modem) für den Provider 1&1 internet.profi.
Ich bin LINUX Anfänger und komme nicht weiter...

Gruß Leif (Leif Klinkhardt)

Antwort:
Wie weit bist Du denn, bzw. wo kommst Du nicht weiter ?
j.
(jay )

Antwort:
Hallo,
danke für die schnelle Antwort.
Ich habe laut SuSE-Handbuch das Modem und den PPP Zugang konfiguriert.
Wenn ich dann die Einwahl teste, wählt das modem auch die Nummer, Name und password werden übertragen, der Vorgang bleibt dann bei der Vergabe der IP-Adressen stehen. Auf der 1und1 Hopegage gibt es eine Konfigurationsanleitung für LINUX, die ist allerdings sehr unverständlich und bezieht sich auf ISDN. Dem Text kann man aber entnehmen, daß das Problem des 1und1 Zugangs wohl daran liegt, "daß auch die IP Adresse der Gegenstelle dynamisch vergeben wird." Es wäre also unbekannt auf welche Adresse das Default Gateway gelegt werdn müsse. Zuerst solle man eine fiktive Default-Route vergeben, diese dann mit einem ausführbaren Script verändern, sobald die IP-Verbindung steht...
Alles relativ unverständlich für mich
Gruß Leif
(Leif Klinkhardt)

Antwort:
Gut...also...
in /etc/ppp/options
0.0.0.0:
ipcp-accept_local
ipcp-accept-remote
noipdefault
dann in /etc/ip-up
route add default ppp0
(Ich kann es leider nicht mit Bestimmtheit sagen, da ich nur ISDN verwende.)
j.
(jay )

Antwort:
Hallo,
beim ersten Versuch war die letzte meldung in /var/log/messages irgendetwas mit CRON
Beim zweiten und allen folgenden Versuchen kam die Meldung
cannot open ip-up exec format error
?????
Gruß lEif
(Leif Klinkhardt)

Antwort:
Hallo,
beim ersten Versuch war die letzte meldung in /var/log/messages irgendetwas mit CRON
Beim zweiten und allen folgenden Versuchen kam die Meldung
cannot open ip-up exec format error
?????
Gruß lEif
(Leif Klinkhardt)

Antwort:
Zunaechst eine Fehlerkorrektur: ip-up muss natuerlich in /etc/ppp stehen. (Da steht i.A. aber auch das Beispielscript)
Also mein ip-up sieht folgendermassen aus:
#!/bin/sh
sleep 1
route add default ippp0
Die erste Zeile ist wichtig, da sonst das Script nicht ausführbar ist.
Die zweite Zeile steht da, weil ich paranoid bin. :)
Die dritte Zeile leistet das gewünschte...(ippp0 weil ich isdn habe, ppp0 fuer modems)
Ein ls -l ip-up ergibt:
-rwx------ 1 root root 101 Sep 11 1997 ip-up
Also mode 700, user und group = root, so muss es sein.
j.
(jay )

Antwort:
Es hat funktioniert!!!
Vielen Dank
(Leif Klinkhardt)

Antwort:
Es funktioniert
ALLERDINGS muß ich ip-up immer erst einmal von "Hand" aufrufen...
Gruß Leif
(Leif Klinkhardt)

bei Antwort benachrichtigen
jay Leif Klinkhardt

„Internetzugang über 1&1 internet.profi“

Optionen

Wie weit bist Du denn, bzw. wo kommst Du nicht weiter ?
j.
(jay )

bei Antwort benachrichtigen