Linux 14.797 Themen, 104.224 Beiträge

Internet + Kppp = Kopfweh ?!?

florian / 3 Antworten / Baumansicht Nickles

HI Leute !
Erst mal; KDE ist echt super ! ... Bis auf Kppp, das manchmal nicht so richtig will.
Erst mal ein paar Tricks:
Kppp initialisiert das Modem zu Tode: Einstellungen/Modem/Modemkommandos Init-Verzögerung raufdrehen
Sorry, das Modem ist nicht bereit: Diese Meldung hab ich bekommen, nachdem ich bei ausgeschaltetem Modem mal wählen lassen wollte. Leider "verrennt" sich Kppp danach und das Modem ist nie mehr bereit. Geholfen hat in $home/.kde/share/config die Datei kppprc zu löschen. Man muß zwar alle Providerdaten neu eintragen, aber man kann wieder wählen.
Nun zu meinem PROBLEM:
Seit dem ich ein neues Modem besitze ( Elsa Microlink 56k ) kann ich mich fast nicht mehr bei meinem Provider einwählen. Mit ppp-up ( bei S.u.S.E Linux ) klappt es bei jedem 3-4 mal wählen, mit Kppp geht es überhaupt nicht mehr. Kppp wählt normal, es pfeift eine Zeit lang ... und pppd "died unexpectedly" Mittlerweile hab ich pppd soweit, daß er nicht mehr stirbt ( persist-Option in /etc/ppp/options ) , aber mein Modem legt trotzdem auf. /var/log/messages sagt dazu: pppd connect /dev/modem, pppd send LCP Conf Req, pppd last message repeated 2 times, pppd hangup (SIGHUB)
Hat irendjemand dazu eine Idee, bzw hat jemand dieses Modem und funktioniert es ??? Mit meinem alten Creatix-Modem hat es nie ein Problem gegeben. ( Ist leider beim letzten Gewitter durch einen Stromschlag ÜBER DIE TELEFONLEITUNG ! gestorben. )
... Noch ein paar BUGS
Rechter Mausklick auf /dev/modem verursacht Absturz des KDE-Dateimanagers
Kppp Einstellungen/Modem/Terminal öffnen und kurz mal aufs Klo gehen oder was anderes tun. Bis zum Zurückkommen hat sich Kppp aufgehängt.
Probiert es bitte mal aus und schreibt mir, ob das bei euch ähnlich ist, oder ob mein PC spinnt.
Grüße aus Linz
FLORIAN (Florian)

Antwort:
PROBLEM GELÖST !
AT-J0 und AT\N6 lautet die Lösung.
Grüße Florian
(Florian)

Antwort:
Hi,
bitte erklär mir noch genauer, wie Du das mit dem "...died unexpectedly" hingekriegt hast. Ich habe es noch nicht geschafft mich damit einzuwählen. Über ppp-up, redialer und ppp-off klappt alles wunderbar. Dieselben Einstellungen bei kppp scheinen allerdings nicht zu klappen.
Was hat es mit AT-J0 und AT\N6 auf sich? Ich habe auch ein 56er Modem, allerdings eines von Askey. Was sind das für AT-Kommandos?
Vielen Dank schon aml im Voraus,
Falko
(Falko)

Antwort:
HI !
Hmmm ... Kppp macht anscheinend anderen auch Probleme.
Bei mir haben eben diese 2 AT-Kommandos geholfen. AT-J0 schaltet die Detect-Phase aus. ( Modemhandbuch : Bei Schwierigkeiten mit Modems, die die Detect-Phase nicht erkennen, V.42-Verbindungen aufzubauen, ist es möglich diese auszuschalten. ) Mit der Standardkonfiguration ( AT\N3 ) kann dann allerdings keine V.42-Verbindung mehr aufgebaut werden. Deshalb muß man zusätzlich noch auf AT\N6 umschalten. Soweit ich weiß, sind die AT-Kommandos bei allen Modems gleich, schau aber trotzdem mal im Handbuch nach. Eingeben kannst Du die Kommandos über Minicom oder über den Kppp-Terminal. ( Einstellungen/Modem/Terminal ) Damit diese Einstellungen auch nach dem Ausschalten gespeichert bleiben, mußt Du noch AT&W0 eingeben.
Falls das nicht helfen sollte, schreib in /etc/ppp/options mal debug rein und schau Dir nach dem nächsten Einwählen mal /var/log/messages an.
Zusätzlich kann ich Dir auch noch empfehlen mal man pppd aufzurufen und Dir die paar Seiten auszudrucken. ( In meiner messages-Datei stand immer was mit lcp time out. Auf der man-page von pppd hab ich dann eine Menge Optionen für lcp gefunden. Einfach probieren ! )
Manchmal kann es auch helfen, wenn Du das IPX-Protokoll ( ist bei den Netzwerk-Optionen ) fix in den Kernel einkompilierst. ( Schau dazu mal in /var/log/warn ob da was von fehlender IPX-Unterstützung steht )
Mein Provider hätte gerne CHAP zur Anmeldung. Funktionieren tut es aber nur mit PAP.
Auch für Kppp soll in /etc/ppp/pap-secrets ( bzw chap-secrets ) "Dein-Username" * "Dein-Passwort" stehen.
Ich hoffe, daß ich Dir damit helfen konnte !
Grüße
Florian
(Florian)

bei Antwort benachrichtigen
florian

Nachtrag zu: „Internet + Kppp = Kopfweh ?!?“

Optionen

PROBLEM GELÖST !
AT-J0 und AT\N6 lautet die Lösung.
Grüße Florian
(Florian)

bei Antwort benachrichtigen
FALKO florian

„Internet + Kppp = Kopfweh ?!?“

Optionen

Hi,
bitte erklär mir noch genauer, wie Du das mit dem "...died unexpectedly" hingekriegt hast. Ich habe es noch nicht geschafft mich damit einzuwählen. Über ppp-up, redialer und ppp-off klappt alles wunderbar. Dieselben Einstellungen bei kppp scheinen allerdings nicht zu klappen.
Was hat es mit AT-J0 und AT\N6 auf sich? Ich habe auch ein 56er Modem, allerdings eines von Askey. Was sind das für AT-Kommandos?
Vielen Dank schon aml im Voraus,
Falko
(Falko)

bei Antwort benachrichtigen
florian FALKO

„Internet + Kppp = Kopfweh ?!?“

Optionen

HI !
Hmmm ... Kppp macht anscheinend anderen auch Probleme.
Bei mir haben eben diese 2 AT-Kommandos geholfen. AT-J0 schaltet die Detect-Phase aus. ( Modemhandbuch : Bei Schwierigkeiten mit Modems, die die Detect-Phase nicht erkennen, V.42-Verbindungen aufzubauen, ist es möglich diese auszuschalten. ) Mit der Standardkonfiguration ( AT\N3 ) kann dann allerdings keine V.42-Verbindung mehr aufgebaut werden. Deshalb muß man zusätzlich noch auf AT\N6 umschalten. Soweit ich weiß, sind die AT-Kommandos bei allen Modems gleich, schau aber trotzdem mal im Handbuch nach. Eingeben kannst Du die Kommandos über Minicom oder über den Kppp-Terminal. ( Einstellungen/Modem/Terminal ) Damit diese Einstellungen auch nach dem Ausschalten gespeichert bleiben, mußt Du noch AT&W0 eingeben.
Falls das nicht helfen sollte, schreib in /etc/ppp/options mal debug rein und schau Dir nach dem nächsten Einwählen mal /var/log/messages an.
Zusätzlich kann ich Dir auch noch empfehlen mal man pppd aufzurufen und Dir die paar Seiten auszudrucken. ( In meiner messages-Datei stand immer was mit lcp time out. Auf der man-page von pppd hab ich dann eine Menge Optionen für lcp gefunden. Einfach probieren ! )
Manchmal kann es auch helfen, wenn Du das IPX-Protokoll ( ist bei den Netzwerk-Optionen ) fix in den Kernel einkompilierst. ( Schau dazu mal in /var/log/warn ob da was von fehlender IPX-Unterstützung steht )
Mein Provider hätte gerne CHAP zur Anmeldung. Funktionieren tut es aber nur mit PAP.
Auch für Kppp soll in /etc/ppp/pap-secrets ( bzw chap-secrets ) "Dein-Username" * "Dein-Passwort" stehen.
Ich hoffe, daß ich Dir damit helfen konnte !
Grüße
Florian
(Florian)

bei Antwort benachrichtigen