Archiv Hardware perfekt konfigurieren 12.949 Themen, 54.079 Beiträge

Absturz beim Booten wegen SCSI-Controller

Klaus / 4 Antworten / Baumansicht Nickles

Habe mir einen PC zusammengebaut mit folgenden Komponenten:
Siemens D-1107 Board, 64 MB SDRAM, PIII 450MHz, nur PCI-Karten, darunter ADAPTEC 2490 mit vier externen Geräten. Ich boote von der EIDE-HD.
Beim Booten gibt es zwei Variationen:
1. Er fährt fehlerfrei hoch, erkennt den SCSI-Controller, listet schön alle vier Geräte auf, meldet daß das SCSI-Bios deaktiviert ist - soll ja auch so sein, da ich von der EIDE-HD boote -, startet WIN98 und ich bin happy. Oder:
2. Er fährt bis zum SCSI-Controller, meldet dann, daß die Controller-Konfiguration fehlerhaft sei und bleibt bereits dort stehen oder versucht noch, WIN98 zu starten und bleibt dann stehen. Reset. Start im abgesicherten Modus gelingt, Neustart verläuft fehlerfrei: Dann stimmt die SCSI-Controller-Konfiguration für ihn wieder.
Die SCSI-Karte lief in meinem alten Rechner fehlerlos, ich habe an ihr oder der Konfiguration nichts geändert.
Karte umstecken, Kontakte säubern, alles schon gemacht.
Was nun? (Klaus)

Antwort:
hi,
ich habe ein ähnliches problem, mein aha2940uw wird beim booten zuerst
nicht richtig erkannt (in einem reinenm scsi-system bleibt dann der
pc einfach hängen "...insert system disk..." -> reset, dann funzt es
wieder. auch ein bios-update des controllers und des mobo's brachten
nichts. umstecken der karte in einen anderen slot und feste zuweisung
des irq's durch bios -> nothing.
wenn jemand eine lösung hat, bitte posten.
was für externe geräte hast du denn?
yeti
(yeti)

Antwort:
Ein paar Starts ging es gut, dann wieder die Fehlermeldung "Host Adapter Configuration Error". Beim Neustart: alles ok.
Ich habe eine Festplatte, ein Zip-Laufwerk, ein CD-Rom und einen CD-Brenner extern angeschlossen. Die von Dir breschriebenen Maßnahmen habe ich auch schon ausprobiert, ohne Erfolg. Läuft der PC erst einmal, funktionieren alle SCSI-Geräte einwandfrei.
(Klaus)

Antwort:
Hallo,
ich hatte mal ein ähnliches Problem zwischen einem Asus-Mainbord und einem AHA 2940AU.
Beim ersten Einschalten lief alles Problemlos, aber nach einem Neustart gabs Abstürze.
Fehlerursache war, das das Mainboard beim Warmstart keinen ordentlichen Reset des PCI-Busses
durchgeführt hat und deshalb der SCSI-Controller nicht richtig initialisiert wurde. Problemlösung
gab es damals keine, nur immer Herunterfahren, Ausschalten, 5Sekunden warten und dann wieder
Einschalten. Eventuell ist das in den aktuellen BIOS-Versionen aber inzwischen korrigiert.
Grüße
oscar
(oscar)

Antwort:
Danke für Eure Antworten. Mein Bios ist absolut aktuell. Ich habe aus der Beobachtung des Fehlers, nicht aufgrund meines Wissens, folgenden Verdacht:
Wenn der Rechner längere Zeit (mehr als 1 Tag) nicht in Betrieb war, "vergißt" er die Host-Adapter-Konfiguration. Nach dem Einschalten und Restart hat er sie dann wieder und egal, wie oft ich ihn dann tagsüber ausschalte und neu starte, der Fehler tritt nicht mehr auf.
Gibt es auf der Adaptec-Karte ein Eprom für die Einstellungen, das defekt sein könnte?
(Klaus)

yeti Klaus

„Absturz beim Booten wegen SCSI-Controller“

Optionen

hi,
ich habe ein ähnliches problem, mein aha2940uw wird beim booten zuerst
nicht richtig erkannt (in einem reinenm scsi-system bleibt dann der
pc einfach hängen "...insert system disk..." -> reset, dann funzt es
wieder. auch ein bios-update des controllers und des mobo's brachten
nichts. umstecken der karte in einen anderen slot und feste zuweisung
des irq's durch bios -> nothing.
wenn jemand eine lösung hat, bitte posten.
was für externe geräte hast du denn?
yeti
(yeti)

Klaus yeti

„Absturz beim Booten wegen SCSI-Controller“

Optionen

Ein paar Starts ging es gut, dann wieder die Fehlermeldung "Host Adapter Configuration Error". Beim Neustart: alles ok.
Ich habe eine Festplatte, ein Zip-Laufwerk, ein CD-Rom und einen CD-Brenner extern angeschlossen. Die von Dir breschriebenen Maßnahmen habe ich auch schon ausprobiert, ohne Erfolg. Läuft der PC erst einmal, funktionieren alle SCSI-Geräte einwandfrei.
(Klaus)

oscar Klaus

„Absturz beim Booten wegen SCSI-Controller“

Optionen

Hallo,
ich hatte mal ein ähnliches Problem zwischen einem Asus-Mainbord und einem AHA 2940AU.
Beim ersten Einschalten lief alles Problemlos, aber nach einem Neustart gabs Abstürze.
Fehlerursache war, das das Mainboard beim Warmstart keinen ordentlichen Reset des PCI-Busses
durchgeführt hat und deshalb der SCSI-Controller nicht richtig initialisiert wurde. Problemlösung
gab es damals keine, nur immer Herunterfahren, Ausschalten, 5Sekunden warten und dann wieder
Einschalten. Eventuell ist das in den aktuellen BIOS-Versionen aber inzwischen korrigiert.
Grüße
oscar
(oscar)

Klaus oscar

„Absturz beim Booten wegen SCSI-Controller“

Optionen

Danke für Eure Antworten. Mein Bios ist absolut aktuell. Ich habe aus der Beobachtung des Fehlers, nicht aufgrund meines Wissens, folgenden Verdacht:
Wenn der Rechner längere Zeit (mehr als 1 Tag) nicht in Betrieb war, "vergißt" er die Host-Adapter-Konfiguration. Nach dem Einschalten und Restart hat er sie dann wieder und egal, wie oft ich ihn dann tagsüber ausschalte und neu starte, der Fehler tritt nicht mehr auf.
Gibt es auf der Adaptec-Karte ein Eprom für die Einstellungen, das defekt sein könnte?
(Klaus)