Datenträger - Festplatten, SSDs, Speichersticks und -Karten, CD/ 19.440 Themen, 107.872 Beiträge

Platte >8.4 GB ohne DMA unter Win98?

Fletch / 1 Antworten / Baumansicht Nickles

Meine neue 17.4 GB Maxtor wird im Bios (HD-Erkennung und DMA-Modus auf AUTO) korrekt als Primary Master mit
UDMA-4 erkannt.
Unter Win98 schaltet das System jedoch immer auf Kompatibilitätsmodus, wenn ich das DMA-Kästchen für dieses Drive
aktiviere. Ausserdem ist das noch ein gelbes Ausrufezeichen im Gerätemanager neben dem "Ersten
Festplattenkontroller". Heisst das, dass ich für meine Platte kein DMA verwenden kann? Ohne aktiviertes DMA läuft alles
prima, nur hab ich gerade mal 2-3 MB Datendurchsatz, was gerade für Video-Bearbeitung völlig unbrauchbar ist.
Ausserdem läuft meine "alte" IBM im UDMA Mode 2 schneller (ca. 4MB).
Wer kann mir helfen???
Noch ein paar Infos zu meinem System: 440LX Board, 64MB 100MHz Ram, Celeron 333MhZ (System läuft mit
75MHz Bustakt). (Fletch)

Antwort:
Ich hatte ein ähnliches Problem. Das lag aber dann am Mainboard, das die Platte als UDMA 4 erkannt hat, aber den Modus nicht richtig aktivieren konnte. Ich habe mir einen Patch runtergeladen und danach wurde die UDMA 4 wieder als UDMA 2 erkannt und funktionierte perfekt. Außerdem kann es auch noch an der Platte selbst liegen, manche Hersteller bieten Tools an, um die Platte in einen anderen Modus zu schalten, damit diese Probleme nicht mehr auftreten. Oder Du gibst richtig Geld aus und kaufst dir einen RAID-Controller. Das hab ich auch gemacht, allerdings mit zwei IBM-Platten. Die Werte sind gut bei normaler Auslastung machen die Dinger ca. 15 MB/s und wenn aus dem Cache der Platten gelesen wird knapp an 70 MB/s.
(Michael H.)

bei Antwort benachrichtigen
Michael H. Fletch

„Platte >8.4 GB ohne DMA unter Win98?“

Optionen

Ich hatte ein ähnliches Problem. Das lag aber dann am Mainboard, das die Platte als UDMA 4 erkannt hat, aber den Modus nicht richtig aktivieren konnte. Ich habe mir einen Patch runtergeladen und danach wurde die UDMA 4 wieder als UDMA 2 erkannt und funktionierte perfekt. Außerdem kann es auch noch an der Platte selbst liegen, manche Hersteller bieten Tools an, um die Platte in einen anderen Modus zu schalten, damit diese Probleme nicht mehr auftreten. Oder Du gibst richtig Geld aus und kaufst dir einen RAID-Controller. Das hab ich auch gemacht, allerdings mit zwei IBM-Platten. Die Werte sind gut bei normaler Auslastung machen die Dinger ca. 15 MB/s und wenn aus dem Cache der Platten gelesen wird knapp an 70 MB/s.
(Michael H.)

bei Antwort benachrichtigen