Festplatten - Prüfen, optimieren, Probleme lösen 18.807 Themen, 100.243 Beiträge

Kein Zugriff auf externe Festplatte mit USB-to-IDE-Adapter

kugelkolibri / 14 Antworten / Baumansicht Nickles

Hallo,

ich versuche, mittels eines USB-to-IDE Adapter auf eine externe Festplatte zuzugreifen. Die Festplatte (eine Maxtor Diamond Max plus 8; ATA 133 HDD; 40 GB; einwandfreie Funktion) ist ohne Gehäuse; der Strom wird von einem separaten Netzteil geliefert.

Zunächst mal mein System: Intel Pentium 4 2,26 GHz, Mainboard Shuttle AV49N, 768 MB DDR-RAM, Windows XP Home SP2.

Ich habe zu der Frage schon einiges bei Nickles und im Internet nachgelesen, aber nichts hat mich weitergebracht.

Die externe Festplatte wird (unter Laufwerke) als USB-Device im Gerätemanager angezeigt, aber nicht im Explorer oder in der Datenträgerverwaltung. Beim einstecken kommt der USB-Ton. Ich habe auch schon erfolglos versucht, ob es klappt, wenn ich die Festplatte nicht als Master sondern als Slave oder Cable select jumpere.

Seltsamerweise kann ich eine andere externe Festplatte, die allerdings in einem Gehäuse ist, problemlos über USB anschließen und bearbeiten.

Wie kriege ich es hin, dass ich die Festplatte mittels Explorer oder besser noch der Datenträgerverwaltung bearbeiten (Formatieren; Partionen erstellen; Daten schreiben bzw. löschen kann?

Wäre toll, wenn Euch dazu was einfällt.

Schönen Dank schon mal

Gruß kugelkolibri

bei Antwort benachrichtigen
siggi12 kugelkolibri

„Kein Zugriff auf externe Festplatte mit USB-to-IDE-Adapter“

Optionen

Tja das liegt warscheinlich einfach am Adapter.


MfG


siggi

1. Ich bin nicht der liebe Gott sondern versuche nur zu helfen ! 2.Manchmal versteht man etwas geschriebenes falsch oder die Antworten sind etwas flapsig das ist aber keine böswilligkeit !
bei Antwort benachrichtigen
nemesis² kugelkolibri

„Kein Zugriff auf externe Festplatte mit USB-to-IDE-Adapter“

Optionen

Hast du die Platte schon mal direkt an das Board angeschlossen und dort erst mal partitioniert/formatiert? Empfehlenswert wäre die Verwendung einer erweiterten Partition mit logischem Laufwerk drin.

Wie sieht die Erkennung unter Linux aus? Kann es (z. B. Knoppix) dort problemlos Partitionen erkennen bzw. erstellen?

Sind auf der Platte aktuell eigentlich Partitionen (ggf. samt Daten) drauf?

bei Antwort benachrichtigen
kugelkolibri nemesis²

„Hast du die Platte schon mal direkt an das Board angeschlossen und dort erst ...“

Optionen

Das der Adapter defekt ist, glaube ich aus zwei Gründen nicht: Zum einen ist er ganz neu und zum anderen wird ja die Festplatte als USB-Device im Gerätemanager aufgeführt.

Die Platte an sich funktioniert einwandfrei. Ich hatte sie auch schon mal eingebaut. Sie ist formatiert und mit einer Partition versehen, in der zu Testzwecken eine Datei gespeichert ist.

Zu Linux kann nichts sagen, da ich es nicht verwende.

bei Antwort benachrichtigen
King-Heinz kugelkolibri

„Das der Adapter defekt ist, glaube ich aus zwei Gründen nicht: Zum einen ...“

Optionen

Diese Billigteile haben einen entscheidenden Nachteil gegenüber "richtigen" externen Festplattengehäusen: Sie funktionieren nur, wenn sie es wollen. Ich selber habe auch so ein Teil hier herumliegen. Manchmal funktioniert es, manchmal nicht. Ein System, warum oder warum nicht, wieso oder wieso nicht, wann oder wann nicht etc. habe ich da noch nicht herausgefunden.

Schmeiß das Teil ganz einfach weg. Kauf dir ein externes Gehäuse, in welches du deine Festplatte einbauen kannst, das funktioniert! Ist zwar etwas mehr Arbeit, aber dafür brauchst du dich nicht über so ein Mistteil zu ärgern...

Gruß
K.-H.

„Die letzte Stimme, die man hört, bevor die Welt explodiert, wird die Stimme eines Experten sein, der sagt: ‚Das ist technisch unmöglich!’“ (Sir Peter Ustinov)
bei Antwort benachrichtigen
shrek3 King-Heinz

„Diese Billigteile haben einen entscheidenden Nachteil gegenüber richtigen ...“

Optionen
Das der Adapter defekt ist, glaube ich aus zwei Gründen nicht: Zum einen ist er ganz neu und zum anderen wird ja die Festplatte als USB-Device im Gerätemanager aufgeführt.

Das sind beides keine Belege dafür, dass der Adapter sauber arbeitet.
Und auch kein Beweis dafür, dass die Festplatte noch in Ordnung ist.

Da hilft alles nichts.
Um der Ursache auf die Spur zu kommen, bleibt dir nichts anderes übrig, als entweder die Festplatte testweise in den PC einzubauen, es mit einem anderen Adapter zu versuchen und/oder sie testweise an einem anderen Rechner anzuschließen.

Gruß
Shrek3
Sich über andere Leute ärgern heißt, sich dafür zu bestrafen, dass diese nicht so sind, wie man sie lieber hätte.
bei Antwort benachrichtigen
speedy27 shrek3

„Das der Adapter defekt ist, glaube ich aus zwei Gründen nicht: Zum einen ...“

Optionen

In der Datenträgerverwaltung von Windows mal nachschauen, ob das Lw auch einen Buchstaben erhalten hat. Wenn nicht, dort einen zuteilen.

bei Antwort benachrichtigen
Lukas9Gelöscht speedy27

„In der Datenträgerverwaltung von Windows mal nachschauen, ob das Lw auch ...“

Optionen

@kugelkolibri:

Gab es beim Anschließen des Adapters irgendwelche Installationswarnungen? Es müssten AFAIK 3 Stück sein, eines davon "Laufwerk"; du musst jeweils auf "Installation fortsetzen" drücken.

Ansonsten probier mal das aus: USB-Adapter abstecken -> WIN-Taste + Pause -> Erweitert -> Umgebungsvariablen -> [Systemvariablen] Neu -> Name: devmgr_show_nonpresent_devices Wert: 1 -> 2x OK -> PC neustarten -> Geräte-Manager -> Ansicht, Ausgeblendete Geräte anzeigen -> USB-Controller -> alle Einträge mit grauem Symbol deinstallieren, nicht deaktivieren -> Geräte-Manager schließen

Jetzt schließe zuerst das Festplatten-Datenkabel am Adapter an, dann stellst du die Stromversorgung her, dann erst verbindest du den Adapter mit dem PC.

Wenn Meldungen kommen, von wegen Treiberwarnung oder so, dann einfach auf "Installation fortsetzen" klicken. Kann bis zu drei Mal erscheinen.

Etwas besseres als den Tod finden wir überall
bei Antwort benachrichtigen
nemesis² kugelkolibri

„Kein Zugriff auf externe Festplatte mit USB-to-IDE-Adapter“

Optionen

Das Problem scheint es öfters zu geben, deshalb interessiert mich mal die genaue Ursache.

Vor allem möchte ich ausschließen, dass es nichts mit einer fehlenden Disk-ID zu tun hat (ohne die XP die Platte erst initialisieren müßte und es das im USB-Gehäuse eventuell nur nicht anbietet ...).

Vor dem Wegschmeißen wäre der emfohlene Linux-Test ratsam. Damit können Einflüsse des OS dann weitestgehend ausgeschlossen werden.

bei Antwort benachrichtigen
kugelkolibri nemesis²

„Das Problem scheint es öfters zu geben, deshalb interessiert mich mal die ...“

Optionen

So, ich habe jetzt mal alle Anregungen ausprobiert, leider, um es vorwegzunehmen, erfolglos.

Aber der Reihe nach:

In der Datenträgerverwaltung konnte ich keinen neuen Buchstaben vergeben, weil die Festplatte dort gar nicht erst erkennbar ist.

Ich habe auch die Festplatte noch mal direkt in den PC eingebaut. Keine Probleme und einwandfreie Funktion, alles ganz normal. Im übrigen habe ich auch noch mal ein DVD-Laufwerk drangehängt, aber das war das selbe Spielchen wie bei der Festplatte.

Als ich dann den Hinweis von lukas9 ausprobiert habe, bekam ich sogar kurz Hoffnung: Nach dem Wiedereinstecken des USB-Kabels kam der Hinweis USB-to-ATA/ATAPI-Brigde erkannt und installiert. Aber leider war wieder nur ein USB-Device im Gerätemanager zu erkennen, beim Explorer und in der Datenträgerverwaltung war immer noch Ebbe.

Trotzdem vielen herzlichen Dank!

Inzwischen bin ich geneigt, der Ansicht zuzustimmen, dass der Adapter nicht funktioniert. Deshalb möchte ich auch, wie bereits in der Überschrift angesprochen, meine Frage umformulieren:

Wenn ich so einen USB-to-IDE-Adapter einsetze, ist es dann wirklich so, dass (einen funktionierenden Adapter vorausgesetzt) daran angeschlossene Geräte (Festplatten, DVD etc.) im Explorer als Laufwerke mit eigener Laufwerksbezeichnung (Buchstaben) erkannt werden und ich sie so bearbeiten kann, wie eine normale Festplatte? Und zwar, ohne eine zusätzliche Software oder einen Treiber zu installieren. Hat jemand da Erfahrungen?

Und weiß jemand wo ich so einen funktionierenden Adapter kaufen kann?

Grüße vom kugelkolibri

bei Antwort benachrichtigen
nemesis² kugelkolibri

„So, ich habe jetzt mal alle Anregungen ausprobiert, leider, um es ...“

Optionen

Klar funktionieren die USB-Adapter so, daß dann die Laufwerke "normal" wie du es willst angsprochen werden können. Selbst unter Truecrypt kannst du problemlos auf die Laufwerke/Partitionen zugreifen und im Gerätemanger erscheinen die wie normale Platten auch.

Jetzt erinnere ich mich, dass einer meiner Adapter auch nur "unter bestimmten Umständen" den Inhalt der Platte rausgerückt hat (z. B. mehrmaiges An-/Abstecken usw.).

Problemlos, schnell bei der Erkennung und sogar native unter DOS läuft mein Gehäuse mit "CY7C68300B" (Alles mit CY7C683xx ist nahezu identisch), allerdings ist der Datendurchsatz etwas niedriger (nur 25 MB/s).

Drin ist der in meinem MS-Tech LU-535 (Gehäuse für 5,25" IDE-Geräte) - nur als Beispiel. Das Teil sollte aber nicht ohne extra Schutzleiteranschluss betrieben werden, sonst wird es schnell zickig und zum Festplatten-Killer!!!

Andere Leute haben da bestimmt noch bessere Empfehlungen.

bei Antwort benachrichtigen
hvoag kugelkolibri

„So, ich habe jetzt mal alle Anregungen ausprobiert, leider, um es ...“

Optionen

Hi!
Vor gut drei Wochen hab ich genau das gleiche Problem geschildert: http://www.nickles.de/thread_cache/538346686.html
Daß man Dir überhaupt antwortet, ist ja schon erfreulich. Aber ich glaube nicht, daß es an der Hardware hakt, dafür sind es zuviele Fälle, die berichtet werden im Netz.
Auch ich hatte schon mal von Digitus einen, der tadellos ging. Den gab ich aber zurück, weil ich nicht einsah, für ein Netzteil zahlen zu sollen, das ich für 2,5"-Platten nicht brauche. Nun der Gag: Vom gleichen Hersteller gibts das gleiche Teil, aber ohne Netzteil, und das funktionierte nicht. Neulich holte ich ein NoName-Teil m i t Netzteil, das auch nicht arbeitet!
Es herrschen ganz die gleichen Umstände wie Du sie geschildert hast. Das erste Teil (Herst. Digitus) hab ich bei Conrads gekauft, der bei Rückgabe immer sehr kulant ist. Artikel-Nr. ist 974903 - 62.
. . -Adapter einsetze, ist es dann wirklich so, dass daran angeschlossene Festplatten, DVD etc. im Explorer als Laufwerke erkannt werden und ich sie so bearbeiten kann, wie eine normale Festplatte? Und zwar, ohne eine zusätzliche Software oder einen Treiber zu installieren Ja, das ist genau so!
Wäre schön, wenn wir am Ball blieben und das leidige Problem lösen könnten. Zur Zeit hab ich einen Bekannten um Testen des Adapters gebeten, der auch mehrere PC hat. Melde mich dann, wenn ich was erfahre.
MfG, Hermann V.

bei Antwort benachrichtigen
kugelkolibri hvoag

„Hi! Vor gut drei Wochen hab ich genau das gleiche Problem geschildert: ...“

Optionen

Hallo,

schön zu wissen, dass es tatsächlich funktionieren kann. Nur noch ein kleiner Nachtrag: Wahrscheinlich ist nicht ganz deutlich geworden, dass es sich bei meinem "Problemkind" um eine nackte Festplatte handelt. Die auch erwähnte externe Festplatte in einem Gehäuse funktioniert tadellos und wird auch problemlos in den Explorer eingebunden.

Ich muß mir noch zwei neue Netzteile besorgen (habe gerade entdeckt, dass bei Netzteilen die Wattzahl gar nicht so entscheidend ist sondern andere Werte) und dazu einen Händler bei ebay aufgetan, der einen vernünftigen Eindruck macht. Bei ihm sind auch USB-to-IDE-Adapter für 12,90 EURO im Angebot. Den frage ich jetzt mal an, wie das im Falle des Nichtfunktionierens ist und werde dann mal einen mitbestellen.

Wird ein paar Tage dauern, bis er da ist und ich ihn getestet habe. Dann werde ich meine Erkenntnisse posten. Natürlich bleibe ich auch zwischenzeitlich am Ball und schau ab und zu nach, ob sich was getan hat.

Gruß kugelkolibri

bei Antwort benachrichtigen
hvoag kugelkolibri

„Hallo, schön zu wissen, dass es tatsächlich funktionieren kann. Nur noch ...“

Optionen
Wahrscheinlich ist nicht ganz deutlich geworden, dass es sich bei meinem "Problemkind" um eine nackte Festplatte handelt. Die auch erwähnte externe Festplatte in einem Gehäuse funktioniert tadellos und wird auch problemlos in den Explorer eingebunden. Doch, doch, nochmal - alles wie bei mir!
Wattzahl gar nicht so entscheidend ist sondern andere Werte Leistung (Watt) ist das Produkt aus Spannung und Strom; letztere müssen passen, deshalb werden sie exakt angegeben auf dem Geräte-Typenschild. Sorry, hab meines z.Zt. nicht da, sonst hätt' ich nachgeschaut :-(
Beste Grüße, Hermann V.
bei Antwort benachrichtigen
nemesis² kugelkolibri

„Hallo, schön zu wissen, dass es tatsächlich funktionieren kann. Nur noch ...“

Optionen

Habe es selbst nochmal getestet und sowohl im LU-535, als auch am LogiLink-USB-IDE-Adapter ließ sich eine nackte IDE-Platte problemlos partitionieren. Die Datenträgerverwaltung hat dabei auch gleich den Assistenten für die Initialisierung angeboten. Beim LogiLink-Adapter muss allerdings das USB-Kabel ab- und wieder angesteckt werden, wenn die Stromzufuhr der Platte ab- und wieder angeschaltet wurde. Andernfalls gibt es nur ein gelbes Ausrufezeichen im Gerätemanager.

... und da war auch mein EMV-Problem wieder, der sofortige Neustart, da ich so ja keinen extra Schutzleiter/Erde/Schirm für das Netzteil hatte ... .

Schon früher war mir allerdings aufgefallen, dass nicht jede Platte an jedem Adapter läuft - da gibt es zumindest vereinzelt Inkompatibilitäten.

3,5" Platten ziehen bis 3 A Anlaufstrom, fast alle neueren Samsung-Modelle sind mit max. 2,4 A (12 V) angegeben. Die Dauerbelastung liegt da meist deutlich unter 1 A und so reicht ein Schaltnetzteil mit 1,5-2 A eigentlich locker. Die 5 V Schiene ist kritischer, da diese dynamisch belastet wird und so schwankt die Spannung dort schnell gefährlich stark.
Normalerweise sind 2 A hier völlig ausreichend - es kommt nur drauf an, wie gut das Netzteil regelt und das steht sowieso auf keiner Verpackung.

Der LogiLink-Adapter war so einer:
http://www.logilink.org/cmsfiles/modules/i-sell2u/showproduct.htm?isu_zeigeartikel=AU0005A

Die gibt es auch noch mit SATA + Netzteil und ohne ist die Preislage um 10 Euro. Innerhalb der ersten 6 Monate hat ja der Händler die Pflicht, nachzuweisen, dass das Teil geht (ok, meherer Platten + ggf. CD/DVD-ROMs solltest du schon mal dran testen). Mein erster war auch schnell defekt, Ersatz kam aber problemlos.

Das soll aber keine Kaufempfehlung sein (im Archiv gibt es aber welche) und bei einer anderen Charge können auch ganz andere Bauteile verwendet werden (besser/schlechter - und vor allem billiger), das gilt auch für die Netzteile.

bei Antwort benachrichtigen